1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

check engine light

Discussion in 'Technical Chat' started by mixaro, Feb 7, 2009.

  1. Feb 7, 2009 at 4:11 PM
    #1
    mixaro

    mixaro [OP] Well-Known Member

    Joined:
    Nov 3, 2008
    Member:
    #10474
    Messages:
    345
    Gender:
    Male
    maine
    Vehicle:
    02 tacoma ext cab
    cat-back exhaust, k&n replacement filter, 5100 billy's, hellcreek 1.5" rear spring packs, 882 OME coils, Toytec 2" AAl, stainless brake lines, Light Racing UCA, 1" diff drop, BPV bracket, 4" deck plate mod, 886 fog light backup light mod, tom woods one piece drive shaft, spider trax 1.25 spacer.
    ok get this i have a 02 2.7 xcab and my check engine light come on when i fill the tank with gas and when it gets to half a tank the light gos off, i ran the code and it's the second bank o2 sensor, what the hell is going on?
     
  2. Feb 7, 2009 at 5:06 PM
    #2
    mixaro

    mixaro [OP] Well-Known Member

    Joined:
    Nov 3, 2008
    Member:
    #10474
    Messages:
    345
    Gender:
    Male
    maine
    Vehicle:
    02 tacoma ext cab
    cat-back exhaust, k&n replacement filter, 5100 billy's, hellcreek 1.5" rear spring packs, 882 OME coils, Toytec 2" AAl, stainless brake lines, Light Racing UCA, 1" diff drop, BPV bracket, 4" deck plate mod, 886 fog light backup light mod, tom woods one piece drive shaft, spider trax 1.25 spacer.
    yeah just one code i don't remember what it was but when i looked it up it said second bank o2 sensor, and i'm pretty sure the gas cap i tight i do th whole turn until it clicks a few times, but how would i check if it was leaking.
     
To Top