1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Check engine light

Discussion in 'Technical Chat' started by NumNutz, May 18, 2009.

  1. May 18, 2009 at 7:28 AM
    #1
    NumNutz

    NumNutz [OP] One of the original 7928

    Joined:
    Jul 14, 2008
    Member:
    #7928
    Messages:
    4,845
    Gender:
    Male
    Virginia Beach, VA
    Vehicle:
    07 Tacoma 4x4 - Kings, TC, Dakars, broken stuff
    Lots.
    My check engine light came on. The code off my scangauge says P0000. It actually says that there are two codes but only one shows up with a code

    Help me!!!
     
  2. May 18, 2009 at 8:13 AM
    #2
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,729
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
    P0000 No Diagnostic Trouble Codes (DTC) Present.

    Try resetting it with the scan tool or the battery and see if one comes back.
     
  3. May 18, 2009 at 8:20 AM
    #3
    NumNutz

    NumNutz [OP] One of the original 7928

    Joined:
    Jul 14, 2008
    Member:
    #7928
    Messages:
    4,845
    Gender:
    Male
    Virginia Beach, VA
    Vehicle:
    07 Tacoma 4x4 - Kings, TC, Dakars, broken stuff
    Lots.
    Okay I'll try that. What if that doesn't do it?

    Why would it have come on in the first place?
     
  4. May 18, 2009 at 8:22 AM
    #4
    bigguy78619

    bigguy78619 Well-Known Member

    Joined:
    May 16, 2008
    Member:
    #6668
    Messages:
    272
    san diego, ca
    Vehicle:
    07 TRD Off-Road PreRunner DC
    i had that happen to me once, is your gas cap on tightly?
     
  5. May 18, 2009 at 8:23 AM
    #5
    Bearskill

    Bearskill Well-Known Member

    Joined:
    Sep 7, 2008
    Member:
    #9064
    Messages:
    793
    Gender:
    Male
    Sac
    Vehicle:
    06 Access cab PreRunner Sport
    FlowMaster 40 duals out the back, T-Rex grill, Color matched TRD Nerf bars, Icon coilovers set at 2'', 2.75" OME Dakars spring packs, OME Nitro-Charger extended rear shocks, Carrier bearing drop kit, Wheeler's Extended break Lines, Total Chaos UCAs, Mojave Teflons and 31 1/2" Toyo Open Country A/Ts, Pioneer single din unit, Yakima roof rack, Malone roof basket with X2 KC 130w long range Slimmlights mounted to it, Garmin 255w nav, Fire bottle mod, Air Force standard First Aid kit mod, Hidden Muchette mod (don't ask), and 1 huge OCD about my truck.
    Turn your key to accessory till your milage comes up, then turn it off. Push and hold your odomiter button/post thing, while holding it turn key back to accessory. Instead of milege desplayd should have a bunch of dashes that count down till they are gone. hold till they are all gone and milege comes back up. Dealer showed me this. Eng light is supposed to come on every 5k to remind you to get your oil changed. If you take your ride into a shop they are the ones that reset it, thats prob why you have never seen it.
     
  6. May 18, 2009 at 8:24 AM
    #6
    bigguy78619

    bigguy78619 Well-Known Member

    Joined:
    May 16, 2008
    Member:
    #6668
    Messages:
    272
    san diego, ca
    Vehicle:
    07 TRD Off-Road PreRunner DC
    its not a check engine light, there is a maintenance light that comes up when the oil needs to be changed.
     
  7. May 18, 2009 at 8:29 AM
    #7
    NumNutz

    NumNutz [OP] One of the original 7928

    Joined:
    Jul 14, 2008
    Member:
    #7928
    Messages:
    4,845
    Gender:
    Male
    Virginia Beach, VA
    Vehicle:
    07 Tacoma 4x4 - Kings, TC, Dakars, broken stuff
    Lots.
    Yup your right. I'll try the gas cap. And I'll try the battery thing. Hopefully one will work.
     
  8. May 18, 2009 at 8:31 AM
    #8
    mws4ua

    mws4ua I'll try being nicer if you try being smarter.

    Joined:
    May 14, 2008
    Member:
    #6624
    Messages:
    7,073
    Gender:
    Male
    First Name:
    Matt
    Birmingham
    Vehicle:
    Sold my truck Jan '13... Still hang around.
    Yeah... "Maint. Required" and "Check Engine" are different. One's annoying, the other is scary.
     
  9. May 18, 2009 at 8:31 AM
    #9
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,127
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    If the code is 0000, the gas cap isnt gonna do a thing. Is it the maintinance light, or CEL?
     
  10. May 18, 2009 at 8:40 AM
    #10
    NumNutz

    NumNutz [OP] One of the original 7928

    Joined:
    Jul 14, 2008
    Member:
    #7928
    Messages:
    4,845
    Gender:
    Male
    Virginia Beach, VA
    Vehicle:
    07 Tacoma 4x4 - Kings, TC, Dakars, broken stuff
    Lots.
    CEL. What does 0000 mean?
     
  11. May 18, 2009 at 8:45 AM
    #11
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,729
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours

    It means there is a diagnostic failure. The ECU thinks something is wrong but has not clue what when in fact there maybe nothing wrong.
     
  12. May 18, 2009 at 8:47 AM
    #12
    bigguy78619

    bigguy78619 Well-Known Member

    Joined:
    May 16, 2008
    Member:
    #6668
    Messages:
    272
    san diego, ca
    Vehicle:
    07 TRD Off-Road PreRunner DC
    damn computers! had happened to the old days where mechanics disgnosed the car by just listening to the problem! LOL, the car used to talk to them!
     
  13. May 18, 2009 at 12:40 PM
    #13
    NumNutz

    NumNutz [OP] One of the original 7928

    Joined:
    Jul 14, 2008
    Member:
    #7928
    Messages:
    4,845
    Gender:
    Male
    Virginia Beach, VA
    Vehicle:
    07 Tacoma 4x4 - Kings, TC, Dakars, broken stuff
    Lots.
    Reset the truck by unplugging the negative and the CEL went off. YAYAYAY

    Thanks Everyone
     
To Top