1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

CLICKING NOISE FROM DRIVERS SIDE

Discussion in 'Suspension' started by bdonham1993, Dec 3, 2012.

  1. Dec 3, 2012 at 7:05 AM
    #1
    bdonham1993

    bdonham1993 [OP] New Member

    Joined:
    Dec 3, 2012
    Member:
    #92340
    Messages:
    2
    Gender:
    Male
    First Name:
    Brendon
    Tucson
    Vehicle:
    09 PreRunner
    3 inch revtech lift with add a leaf in the back magnaflow that drops down before rear axle knn 63 cold air intake
    ok so after a ruff day of offroading i was coming out of the trail i notice a clicking noise everytime i turned or would roll over a bump after doing some research i came to the conclusion it was my lower ball joint so this weekend me and a buddy took off my control arm went to base punched out the old ball joint and punched in a new one then put it all back together and there is still a click im running out of ideas i have heard people say that it could be the tie rod but i dont know just want to get some ideas on how else i should go about this
     
  2. Dec 3, 2012 at 7:25 AM
    #2
    52motorhead

    52motorhead Well-Known Member

    Joined:
    Dec 27, 2011
    Member:
    #69434
    Messages:
    72
    Gender:
    Male
    Clicking sound while turning sounds more like a cv joint in the front axl.
     
  3. Dec 3, 2012 at 1:25 PM
    #3
    hanrock

    hanrock Well-Known Member

    Joined:
    Oct 27, 2011
    Member:
    #65972
    Messages:
    127
    Gender:
    Male
    First Name:
    craig
    sask
    Vehicle:
    2012 nauticle blue dc lb
    2 1/4 front, 1 1/4 rear, fog light mod, KC daylighters
    is it a steady click click click while you are moveing if is this probably a cv !!!!!!! prerunner whoops !!!!!
     
  4. Dec 3, 2012 at 1:27 PM
    #4
    JoeTacoma02

    JoeTacoma02 Well-Known Member

    Joined:
    Jul 27, 2010
    Member:
    #40831
    Messages:
    3,362
    Gender:
    Male
    Beaverton, OR
    Vehicle:
    SWB 05 Double Cab 4x4 TRD Off Road
    Is it possible to get a video of it as well?
     
  5. Dec 3, 2012 at 1:32 PM
    #5
    MonkeyProof

    MonkeyProof Power Top

    Joined:
    Oct 7, 2008
    Member:
    #9774
    Messages:
    9,420
    SoCal- SGV
    Could also be a wheel bearing
     
  6. Dec 3, 2012 at 1:34 PM
    #6
    MonkeyProof

    MonkeyProof Power Top

    Joined:
    Oct 7, 2008
    Member:
    #9774
    Messages:
    9,420
    SoCal- SGV
    Says in his details that he is a prerunner
     
  7. Dec 3, 2012 at 1:49 PM
    #7
    Burgman

    Burgman I KEEEEEL YOU

    Joined:
    Apr 16, 2009
    Member:
    #16072
    Messages:
    26,737
    Gender:
    Male
    First Name:
    Stephen
    Ric VA
    Vehicle:
    08 PreRunner TRD sport Silver
    K&N intake, Boston Acoustic SL 60 6.5 components up front, Rockford Power T16 6.5 in rear, Pioneer P4100 HU, Soon to be Pioneer Prs 4200f
    Blinker still on?
     
  8. Dec 3, 2012 at 1:53 PM
    #8
    97yota4wd

    97yota4wd Well-Known Member

    Joined:
    Aug 26, 2010
    Member:
    #42280
    Messages:
    13,025
    Gender:
    Male
    First Name:
    Eric
    Mesa, AZ
    Vehicle:
    alot of metal, small engine, decent travel.
    caged, camburg long travel, 50t leafpack (soon to be installed) light rack over cab, 5pt harnesses etc
    bushings.
    click noise when going over bump, or turning, LCA bushings for sure.
     
  9. Dec 4, 2012 at 6:58 AM
    #9
    bdonham1993

    bdonham1993 [OP] New Member

    Joined:
    Dec 3, 2012
    Member:
    #92340
    Messages:
    2
    Gender:
    Male
    First Name:
    Brendon
    Tucson
    Vehicle:
    09 PreRunner
    3 inch revtech lift with add a leaf in the back magnaflow that drops down before rear axle knn 63 cold air intake
    i have also heard that it could be the cv as well.... i will try to get a video today after work and post it so yall can hear it thanx for all the response on this issue
     
  10. Dec 21, 2012 at 7:51 AM
    #10
    kyser13

    kyser13 Well-Known Member

    Joined:
    Feb 9, 2012
    Member:
    #72503
    Messages:
    193
    Gender:
    Male
    Vehicle:
    09 Tacoma/SR5 4X4
    Debadged, Inno bed rack blacked out brackets, Blacked out front Toyota badge, Interior red LEDS, 285/17-70 Duratracs, 17X9 Moto Metal 957s, Toytec 3" lift Bilstiens, Ultra Gauge, LED bed lights.
    i have a little bit of a click or pop every now and then in the driver and occasionally in the passenger. not all the time just occasionally for both. Any ideas on that, this is after a Toytech lift has been installed since mid October and the popping just started. Mostly noticed it is when turning or a slight bump.....any help would be great.
     
  11. Dec 21, 2012 at 7:54 AM
    #11
    Cbass38

    Cbass38 Well-Known Member

    Joined:
    Jul 26, 2011
    Member:
    #60562
    Messages:
    884
    Gender:
    Male
    First Name:
    sebastian
    scottsdale
    Vehicle:
    07 pre runner
    projector hids,wheels,small lift,flowmaster
    sounds more like a wheel bearing.
     
To Top