1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Code P0306. need input!

Discussion in 'Technical Chat' started by MT4x4Tacoma, Sep 24, 2011.

  1. Sep 24, 2011 at 8:41 PM
    #1
    MT4x4Tacoma

    MT4x4Tacoma [OP] MT4x4Tacoma

    Joined:
    Sep 8, 2011
    Member:
    #63142
    Messages:
    40
    Gender:
    Female
    First Name:
    Danielle
    Keizer, Oregon
    Vehicle:
    08' TRD Sport
    Rancho quick lift in the front w/ SPC UCA's, Rancho adjustable shocks rear. And hopefully more to come
    I have a 2000 tacoma. V6.
    The check engine light came on, and I got the P0306. which is cylinder 6 misfire.
    My truck sputters when I first take off, but then after I reach about 1500rpm it runs fine.

    Has anyone had this issue....where do I start? do I need to be really worried?
    THANKS
     
  2. Sep 24, 2011 at 8:45 PM
    #2
    Texoma

    Texoma Well-Known Member

    Joined:
    Feb 1, 2011
    Member:
    #50374
    Messages:
    5,398
    Gender:
    Male
    First Name:
    Chris(Topher)
    Lago Vista, TX
    Vehicle:
    10 Taco 4x4
    Poweraid TB spacer, a bunch a cool stickers, a bada ass MetalMiller Tx Longhorns grill emblem painted Hemi Orange, JBA 2035s headers and dey are perty, Diff breather mod, Red LED interior lights, Fancy head unit that plays ipod n movies, Also DIY install factory stuff like, factory cruise control, factory intermittent wipers, OME nitro struts with 886x springs and toy tec top plate, LR UCA's for better alignmnet and dey beefier too, Old Man Emu Dakar leaf springs in da rear with the gear, U bolt flipper, 5 factory 16" steels wit Pep Boys special Dakota Definity MT's in 285/75/16, some bad ass weather tech floor liners so I don't muck up my interior, an ATO shackle flipper for mo travel in da rear wit the gear, also super shiny Fox 2.0 shocks back there too, all sorts of steal armor for bouncing off of the rocks like demello sliders, AP front skid, trans skid, n transfer skid, demello gas tank skid, and a tough as nails ARB bumper with warn 8k winch, I'm sure there's more but it's alre
    Try checking your spark plugs, especially in that cylinder. Have you replaced your plugs yet? If you don't know then it sounds like a good time to do so.
     
  3. Oct 9, 2011 at 8:04 PM
    #3
    stagermx317

    stagermx317 Member

    Joined:
    Oct 9, 2011
    Member:
    #64919
    Messages:
    19
    Gender:
    Male
    First Name:
    Justin
    Missouri
    Vehicle:
    95 Tacoma 4x4 V-6
    Pacesetter Catback K&N Air Filter 3" lift 32x11.5 Tires Manik Grill Guard Performance Products Nerf Bars Carbon Fiber Tail lights
    I actually had the same thing happen to mine this morning. I have the same code, i pulled the plug from the #6 cylinder and it looked fine other than it was darker that the other ones. My guess is because of the unburnt fuel. But i swapped the #6 plug with the #4 plug to see if that is the problem. I guess I will see tomorrow when I drive it, if the #4 cyl starts to misfire. I have the Bosch Platinum 2's in my truck.
     
  4. Oct 10, 2011 at 2:53 PM
    #4
    MT4x4Tacoma

    MT4x4Tacoma [OP] MT4x4Tacoma

    Joined:
    Sep 8, 2011
    Member:
    #63142
    Messages:
    40
    Gender:
    Female
    First Name:
    Danielle
    Keizer, Oregon
    Vehicle:
    08' TRD Sport
    Rancho quick lift in the front w/ SPC UCA's, Rancho adjustable shocks rear. And hopefully more to come
    well i had just bought this truck not to long ago. And when that code came up I figured it was either an injector or a spark plug. I have my boyfriend change the spark plugs for me and it fixed it!
    the spark plugs looked like they hadnt be changed for a long time.

    I would definetly check an injector if the spark plug doesnt work,
    Dont throw money at it.
    I had the same problem, same cylinder with my Dakota
     
  5. Oct 10, 2011 at 3:06 PM
    #5
    Nicks4x4LT

    Nicks4x4LT Official Villain

    Joined:
    Mar 13, 2010
    Member:
    #33139
    Messages:
    1,323
    Gender:
    Male
    First Name:
    Nick
    714 Orange county
    Vehicle:
    2010 4x4 V6
    Custom front bumper, Icon 2.5 ext. travel coilovers, Defined rear long travel King smooties w/ resi. Avid Offroad sliders, Fiberwerx front fenders, Glassworks Shorty TT style rear glass, URD MAF calibrator, DT shorty headers, URD TCAI, Magnaflow catback
    By any chance do you have the oil type air filter or a cold air intake possibly from K&N? I had a problem similar where the oil from the air intake was messing up the mass airflow sensor causing the engine to misfire, but i had all the cylinders misfire, also you could always take it to toyota
     
  6. Oct 10, 2011 at 4:58 PM
    #6
    Texoma

    Texoma Well-Known Member

    Joined:
    Feb 1, 2011
    Member:
    #50374
    Messages:
    5,398
    Gender:
    Male
    First Name:
    Chris(Topher)
    Lago Vista, TX
    Vehicle:
    10 Taco 4x4
    Poweraid TB spacer, a bunch a cool stickers, a bada ass MetalMiller Tx Longhorns grill emblem painted Hemi Orange, JBA 2035s headers and dey are perty, Diff breather mod, Red LED interior lights, Fancy head unit that plays ipod n movies, Also DIY install factory stuff like, factory cruise control, factory intermittent wipers, OME nitro struts with 886x springs and toy tec top plate, LR UCA's for better alignmnet and dey beefier too, Old Man Emu Dakar leaf springs in da rear with the gear, U bolt flipper, 5 factory 16" steels wit Pep Boys special Dakota Definity MT's in 285/75/16, some bad ass weather tech floor liners so I don't muck up my interior, an ATO shackle flipper for mo travel in da rear wit the gear, also super shiny Fox 2.0 shocks back there too, all sorts of steal armor for bouncing off of the rocks like demello sliders, AP front skid, trans skid, n transfer skid, demello gas tank skid, and a tough as nails ARB bumper with warn 8k winch, I'm sure there's more but it's alre
    Check those bosch spark plugs. I had em before and they totally sucked for me. Stick with either NGK or Denso factory spec on the spark plugs, special plugs really do nothing for you. Check the thread "The truth about spark plugs" and you can find some decent info.
     
  7. Oct 10, 2011 at 4:59 PM
    #7
    Texoma

    Texoma Well-Known Member

    Joined:
    Feb 1, 2011
    Member:
    #50374
    Messages:
    5,398
    Gender:
    Male
    First Name:
    Chris(Topher)
    Lago Vista, TX
    Vehicle:
    10 Taco 4x4
    Poweraid TB spacer, a bunch a cool stickers, a bada ass MetalMiller Tx Longhorns grill emblem painted Hemi Orange, JBA 2035s headers and dey are perty, Diff breather mod, Red LED interior lights, Fancy head unit that plays ipod n movies, Also DIY install factory stuff like, factory cruise control, factory intermittent wipers, OME nitro struts with 886x springs and toy tec top plate, LR UCA's for better alignmnet and dey beefier too, Old Man Emu Dakar leaf springs in da rear with the gear, U bolt flipper, 5 factory 16" steels wit Pep Boys special Dakota Definity MT's in 285/75/16, some bad ass weather tech floor liners so I don't muck up my interior, an ATO shackle flipper for mo travel in da rear wit the gear, also super shiny Fox 2.0 shocks back there too, all sorts of steal armor for bouncing off of the rocks like demello sliders, AP front skid, trans skid, n transfer skid, demello gas tank skid, and a tough as nails ARB bumper with warn 8k winch, I'm sure there's more but it's alre
    Glad that worked for ya.
     
  8. Oct 10, 2011 at 7:28 PM
    #8
    stagermx317

    stagermx317 Member

    Joined:
    Oct 9, 2011
    Member:
    #64919
    Messages:
    19
    Gender:
    Male
    First Name:
    Justin
    Missouri
    Vehicle:
    95 Tacoma 4x4 V-6
    Pacesetter Catback K&N Air Filter 3" lift 32x11.5 Tires Manik Grill Guard Performance Products Nerf Bars Carbon Fiber Tail lights
    Thanks guys, yea I have the K&N air filter on mine, but i have had it for about 100k miles now and never had a prob with my MAF sensor. I did clean off the MAF sensor today and that did not help, I swapped my plug from another cylinder and i still have the #6 misfire. I and going to switch my coil pack with another and see what that does tomorrow. As for the Bosch plugs, I thought Bosch was a high end product? I have heard that the plugs arent good from a few people.
     
  9. Oct 11, 2011 at 3:17 PM
    #9
    Texoma

    Texoma Well-Known Member

    Joined:
    Feb 1, 2011
    Member:
    #50374
    Messages:
    5,398
    Gender:
    Male
    First Name:
    Chris(Topher)
    Lago Vista, TX
    Vehicle:
    10 Taco 4x4
    Poweraid TB spacer, a bunch a cool stickers, a bada ass MetalMiller Tx Longhorns grill emblem painted Hemi Orange, JBA 2035s headers and dey are perty, Diff breather mod, Red LED interior lights, Fancy head unit that plays ipod n movies, Also DIY install factory stuff like, factory cruise control, factory intermittent wipers, OME nitro struts with 886x springs and toy tec top plate, LR UCA's for better alignmnet and dey beefier too, Old Man Emu Dakar leaf springs in da rear with the gear, U bolt flipper, 5 factory 16" steels wit Pep Boys special Dakota Definity MT's in 285/75/16, some bad ass weather tech floor liners so I don't muck up my interior, an ATO shackle flipper for mo travel in da rear wit the gear, also super shiny Fox 2.0 shocks back there too, all sorts of steal armor for bouncing off of the rocks like demello sliders, AP front skid, trans skid, n transfer skid, demello gas tank skid, and a tough as nails ARB bumper with warn 8k winch, I'm sure there's more but it's alre
    They've fouled on all of my vehicles very quickly. Had a bosch water pump that crapped out on me not even a month after I installed it.
     
  10. Oct 16, 2011 at 6:38 PM
    #10
    stagermx317

    stagermx317 Member

    Joined:
    Oct 9, 2011
    Member:
    #64919
    Messages:
    19
    Gender:
    Male
    First Name:
    Justin
    Missouri
    Vehicle:
    95 Tacoma 4x4 V-6
    Pacesetter Catback K&N Air Filter 3" lift 32x11.5 Tires Manik Grill Guard Performance Products Nerf Bars Carbon Fiber Tail lights
    I got a set of NGK plugs and Napa Wires and she runs like new again!
     
To Top