1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Cold air intake 2.7 L

Discussion in 'Technical Chat' started by Fal1128, Mar 14, 2013.

  1. Fal1128

    Fal1128 [OP] New Member

    Joined:
    Mar 14, 2013
    Member:
    #99726
    Messages:
    2
    Gender:
    Male
    Vehicle:
    09 SR5 2.7L
    Can anybody answer some questions. I have a 2009 Tacoma 2.7L SR5. I was looking at putting a k&n intake on and found some reviewsp that said they had problems with the mass air flow sensor tripping out. Has anyone heard of this or know what causes this? Also what is the fix for this. Any help would be appreciated. I do t want to start putting mods on my truck and have problem.
     
  2. ABA180

    ABA180 It burns when I pee....

    Joined:
    Oct 8, 2012
    Member:
    #88520
    Messages:
    6,576
    Gender:
    Male
    First Name:
    Chris
    East Bridgewater MA
    Vehicle:
    2010 Tacoma Regular Cab Slider
    Kenwood CD, MTX/Jensen amps, Rockford/Polk speakers.
    Welcome!

    I don't own one of them, but the general consensus is overoiling the filter causes the MAF issues.

    I looked into doing a cold air on my 2010, but read on here that ours already come stock with one. Really no benefit to swapping it out from what I see here.
     
  3. Fal1128

    Fal1128 [OP] New Member

    Joined:
    Mar 14, 2013
    Member:
    #99726
    Messages:
    2
    Gender:
    Male
    Vehicle:
    09 SR5 2.7L
    Thx for the info.
     
To Top