1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Cold Start - Fast Idle

Discussion in '4 Cylinder' started by Fast1, Jul 21, 2009.

  1. Jul 21, 2009 at 1:43 PM
    #1
    Fast1

    Fast1 [OP] Well-Known Member

    Joined:
    Jun 24, 2009
    Member:
    #18875
    Messages:
    123
    Gender:
    Male
    Minneapolis, MN
    Vehicle:
    06 Std Cab 2.7L 4X4
    Just purchased a 2.7L and noticed that when cold (even in the summer at 70 degrees) it idles at 2K to 2200 upon start up.

    Then after a few minutes I hear some type of click and the idle slows way down to almost normal hot idle speed. The click almost sounds like the a/c compresssor is being turned off when the idle slows down.

    Is this normal for this engine?
     
  2. Jul 21, 2009 at 1:56 PM
    #2
    devilsalmostfree

    devilsalmostfree Well-Known Member

    Joined:
    Sep 21, 2008
    Member:
    #9374
    Messages:
    775
    Gender:
    Male
    First Name:
    Carl
    Loudon, Tn
    Vehicle:
    99 Tacoma 4X4, 5 spd, 2.7 ltr
    Deck plate mod, intake silencer removed, AFE Pro Dry S Air Filter, debadged, Goodyear Duratracs 265/75R16. Flowmaster knock-off muffler!
    mine idles high on cold start up, around 1000-1100, i think, but nothing like urs!
     
  3. Jul 21, 2009 at 3:46 PM
    #3
    91r100gs

    91r100gs Understand the Voice Within

    Joined:
    Apr 21, 2008
    Member:
    #6100
    Messages:
    655
    Gender:
    Male
    First Name:
    Dan
    Kansas City area
    Vehicle:
    '08 Impluse Red SR5 I-4
    Factory bed mat, TacomaWorld.com sticker, EGR In-Channel Vent Visors, AFE ProDryS drop in air filter
    There are times when mine will fast idle from a dead cold start at 2000 RPM, but it backs down to 1500 or so in a few seconds. The other day on a very hot day that the truck sat out in the direct sun for 8 hours, when I started it, the cold start cycle didn't even happen and it idled at 700 RPM . :eek: If yours is idle is that high for two minutes something is wrong with the cold start cycle of the ECU.
     
  4. Jul 21, 2009 at 3:50 PM
    #4
    MiikeyD

    MiikeyD The Green Machine

    Joined:
    Jul 6, 2007
    Member:
    #2017
    Messages:
    1,433
    Gender:
    Male
    First Name:
    Mike
    Upland, CA
    Vehicle:
    Green Prerunner DC 2.7L
    Suspension / Wheels / Tires 3.5" Fabtech lift w/ AAL 265/75/16 BFG A/T American Racing Baja Audio Alpine HU CDA-9886 Kicker DS650 Z-Edition 1000W Memphis M3 US Amps 4000W 2.5Farad Cap Lighting 6000K HID 2 Hella 500FF 2 Aux Bed Lights 2 Aux Driving Lights Performance Volant CAI Flomaster Super 44 Doug Thorley Long Tube headers (coming soon) NGK Iridium Sparkplugs Accessories Scanguage II Cobra LTD27-NW with 3' Firestik Radio Shack Triple Trunking Scanner Harbor Freight Hi-Lift Cosmetics Flat Black Bumper Trim Flat Black Grill Surrounding with Satoshi Clear Corners Future Modifications (not specific) Longtravel w/ king shocks or fox Caged bed Shackles rear suspension. Fox / king shocks custom front bumper Custom Glassworks extreme kit for 01-04 (only have hood and passenger side.. need driver panel) Supercharger + 8port intake manifold optima yellow top battery remounted new rims caged interior rear bench removal 4 sparc
    been idling at less than 1500 but above 700 all day any weather, 2000 seems high IMO
     
  5. Jul 21, 2009 at 7:05 PM
    #5
    beastlytaco

    beastlytaco This is TW. One never knows what is a joke anymore

    Joined:
    Jun 30, 2008
    Member:
    #7660
    Messages:
    4,042
    Gender:
    Male
    First Name:
    Ian
    Vehicle:
    08 tacoma standard cab
    15% tinted back window, 25% on sides. Jardine catback exhaust system. horn modification, AFE pro dry S filter and secondary filter removed. All weather toyota tacoma mats.
    one thing you can do to lower your idel if it bothers you is to buy a Pro dry S filter and remove the secondary charcoal filter. it will lower your idel rpms to about 1000 or even less
     
  6. Jul 21, 2009 at 7:08 PM
    #6
    Burgman

    Burgman I KEEEEEL YOU

    Joined:
    Apr 16, 2009
    Member:
    #16072
    Messages:
    26,682
    Gender:
    Male
    First Name:
    Stephen
    Ric VA
    Vehicle:
    08 PreRunner TRD sport Silver
    K&N intake, Boston Acoustic SL 60 6.5 components up front, Rockford Power T16 6.5 in rear, Pioneer P4100 HU, Soon to be Pioneer Prs 4200f
    mine def. goes up tp abput 2k at cold startup i usually put it in gear b4 if goes down, but putting it in gear drops it
     
  7. Jul 21, 2009 at 8:16 PM
    #7
    Fast1

    Fast1 [OP] Well-Known Member

    Joined:
    Jun 24, 2009
    Member:
    #18875
    Messages:
    123
    Gender:
    Male
    Minneapolis, MN
    Vehicle:
    06 Std Cab 2.7L 4X4

    that is exactly what I've been doing also..
     
  8. Jul 22, 2009 at 6:00 AM
    #8
    sriley727

    sriley727 Well-Known Member

    Joined:
    May 3, 2009
    Member:
    #16735
    Messages:
    148
    Gender:
    Male
    Aiken, SC
    Vehicle:
    08 Reg cab PreRunner SR5
    Bone stock
    Sounds normal to me. 2000 may be higher than most people see but its not abnormally high. I'd say you are alright.
     
  9. Jul 22, 2009 at 6:24 AM
    #9
    06dak

    06dak Well-Known Member

    Joined:
    Mar 6, 2008
    Member:
    #5122
    Messages:
    259
    Gender:
    Male
    Central Ohio
    Vehicle:
    05 PreRunner SR5 4cyl
    Undercover hard tonneau, Husky front liners
    Mine does the same thing... always comes down in less than a minute (but I haven't had it in the winter yet)
     
  10. Jul 22, 2009 at 6:45 AM
    #10
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,897
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
    Try cleaning your MAF. How many miles are on the trck?
     
  11. Jul 22, 2009 at 10:00 AM
    #11
    Fast1

    Fast1 [OP] Well-Known Member

    Joined:
    Jun 24, 2009
    Member:
    #18875
    Messages:
    123
    Gender:
    Male
    Minneapolis, MN
    Vehicle:
    06 Std Cab 2.7L 4X4
    can you explain to me in techinical terms why a dirty MAF would cause a fast idle only during the first 60 seconds of cold start up?
     
  12. Jul 22, 2009 at 10:04 AM
    #12
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,897
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
    It reads air temp and air flow.
     
  13. Jul 22, 2009 at 1:32 PM
    #13
    Fast1

    Fast1 [OP] Well-Known Member

    Joined:
    Jun 24, 2009
    Member:
    #18875
    Messages:
    123
    Gender:
    Male
    Minneapolis, MN
    Vehicle:
    06 Std Cab 2.7L 4X4

    and why would this only impact the engine idle when its cold and not hot?
     
  14. Jul 22, 2009 at 2:52 PM
    #14
    91r100gs

    91r100gs Understand the Voice Within

    Joined:
    Apr 21, 2008
    Member:
    #6100
    Messages:
    655
    Gender:
    Male
    First Name:
    Dan
    Kansas City area
    Vehicle:
    '08 Impluse Red SR5 I-4
    Factory bed mat, TacomaWorld.com sticker, EGR In-Channel Vent Visors, AFE ProDryS drop in air filter
    In winter under about 30 degrees it may go even higher. I've seen 2500 for a few seconds when it sits out in really cold weather.
     
  15. Jul 22, 2009 at 3:03 PM
    #15
    bobwilson1977

    bobwilson1977 Well-Known Member

    Joined:
    Jan 7, 2009
    Member:
    #12328
    Messages:
    1,368
    Gender:
    Male
    KaliFORN-I-A
    Vehicle:
    96 Tacoma 2WD ( pizza delivery model)
    none except for crappy hub caps and floor mats.
    I wouldn't worry about it. I have the same engine and it tends to idle a bit high for probably 30 seconds or so. The engine does this to warm up quicker.
     
  16. Jul 22, 2009 at 4:08 PM
    #16
    Hootbro

    Hootbro Omnipotent

    Joined:
    Jun 22, 2009
    Member:
    #18789
    Messages:
    347
    Gender:
    Male
    Delaware
    Vehicle:
    2009 Tacoma Regualr Cab 4x4 2.7L
    Two reasons why, one is emissions. The faster it warms the less it pollutes. The main reason is poor running concerns. In a cold engine the fuel does not mix well with the air. It will actually pool up rather than turn to vapor. Only the vapor burns, the liquid fuel does not. The faster and engine runs the quicker it warms up.
     
  17. Jul 23, 2009 at 5:54 AM
    #17
    sriley727

    sriley727 Well-Known Member

    Joined:
    May 3, 2009
    Member:
    #16735
    Messages:
    148
    Gender:
    Male
    Aiken, SC
    Vehicle:
    08 Reg cab PreRunner SR5
    Bone stock
    It wouldn't. The engine runs in closed loop mode when its warming up and doesn't use the signal from the MAF.
     
  18. Jul 23, 2009 at 6:08 AM
    #18
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,192
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    No charcoal filter on the first gens.
     
  19. Jul 23, 2009 at 6:18 AM
    #19
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,897
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
    Ah-ha!! Is too!!! Mine was in the drivers front wheel well area.
     
  20. Jul 23, 2009 at 6:19 AM
    #20
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,192
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    On a 2000 2.7?????
     
To Top