1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Crate Engines

Discussion in '2nd Gen. Tacomas (2005-2015)' started by lucky, Jan 14, 2010.

  1. Jan 14, 2010 at 7:12 PM
    #1
    lucky

    lucky [OP] Well-Known Member

    Joined:
    Jun 21, 2008
    Member:
    #7468
    Messages:
    353
    Gender:
    Male
    NB, TX
    Vehicle:
    07 PreRunnerX4
    TRD 2 CAI Firestone Ride-Rite TSB Leafs Toytec AAL 5100's and OME Blue LED dash
    Anyone have any vendors they would recommend for buying a rebuilt 4.0? Jasper doesnt offer it. Found a place online called Precision Engines out of Houston. $2300 for long block. Any feedback would be greatly appreciated.

    I'll share the story about why a new engine is on my shopping list a little later.
     
  2. Jan 14, 2010 at 8:45 PM
    #2
    dexterdog

    dexterdog My pee parts itch

    Joined:
    Jul 12, 2009
    Member:
    #19571
    Messages:
    4,610
    Gender:
    Male
    Oly WA
    Vehicle:
    2012 F150
    That doesn't seem too bad for a long block. You could probably have a shop rebuild yours for maybe a grand less than that if your block is good as I am assuming you're doing the labor on the uninstall/install.
     
  3. Feb 2, 2010 at 3:05 PM
    #3
    lucky

    lucky [OP] Well-Known Member

    Joined:
    Jun 21, 2008
    Member:
    #7468
    Messages:
    353
    Gender:
    Male
    NB, TX
    Vehicle:
    07 PreRunnerX4
    TRD 2 CAI Firestone Ride-Rite TSB Leafs Toytec AAL 5100's and OME Blue LED dash
  4. Feb 2, 2010 at 3:16 PM
    #4
    PreRunnerSeth

    PreRunnerSeth Well-Known Member

    Joined:
    Aug 12, 2009
    Member:
    #21110
    Messages:
    4,281
    Gender:
    Male
    Apex, NC
    Vehicle:
    15 Black DC OR Prerunner
    I see used engines show up on CL around here from time to time. I would go that route.
     
  5. Feb 2, 2010 at 10:08 PM
    #5
    TucsonMike

    TucsonMike Blank

    Joined:
    Oct 29, 2009
    Member:
    #25090
    Messages:
    648
    Gender:
    Male
    First Name:
    Mike
    Tucson, AZ
    Vehicle:
    2005 SR5 prerunner
    Yellow fogs,Stock 16" in black, 30" LED bar lower grill
  6. Feb 3, 2010 at 12:24 PM
    #6
    lucky

    lucky [OP] Well-Known Member

    Joined:
    Jun 21, 2008
    Member:
    #7468
    Messages:
    353
    Gender:
    Male
    NB, TX
    Vehicle:
    07 PreRunnerX4
    TRD 2 CAI Firestone Ride-Rite TSB Leafs Toytec AAL 5100's and OME Blue LED dash
    The place I ended up going with is called lowmileageengines.com.

    I bought a 1GRFE from a totaled 2009 PreRunner with 1200 miles on the odo. They provide a carfax of the vehicle and warranty the motor for 1 yr, unlimited miles. I paid $3K. Price includes 2-4 day shipping to my house. No tax. Smoking deal compared to the junk I was finding around south texas. I'll be taking pictures of my swap. Pulling the current engine starts this weekend.
     
    BrennMan likes this.
  7. Feb 3, 2010 at 1:29 PM
    #7
    ItalynStylion

    ItalynStylion Sounds Gooooood

    Joined:
    Jun 15, 2009
    Member:
    #18467
    Messages:
    5,241
    Gender:
    Male
    First Name:
    Steven
    DFW, Tx.
    Vehicle:
    09 Double Cab TRD Sport 4x4
    Wow, that DOES sound good!
     
  8. Feb 3, 2010 at 3:55 PM
    #8
    pataco

    pataco Well-Known Member

    Joined:
    Jan 1, 2009
    Member:
    #12092
    Messages:
    2,069
    Gender:
    Male
    Down by the lake
    Vehicle:
    05 4x4 trd dc white
    FOX 2.0 RESIS,LRUCAS,BILLY 5100S ON THE REAR.MAGNAFLOW 11264,COLOR MATCHED GRILL,YELLOW FOG MOD.OVER HEAD DVD,FEDERAL COURAGIA M/T
    x2,good luck on the install.i like your name too.lucky.lol.
     
  9. Feb 3, 2010 at 7:29 PM
    #9
    lucky

    lucky [OP] Well-Known Member

    Joined:
    Jun 21, 2008
    Member:
    #7468
    Messages:
    353
    Gender:
    Male
    NB, TX
    Vehicle:
    07 PreRunnerX4
    TRD 2 CAI Firestone Ride-Rite TSB Leafs Toytec AAL 5100's and OME Blue LED dash
    If anyone is interested, I'll be selling my current engine. I figure the long block is easily worth $1K since a rebuilt 1GRFE sells for $2500 and up. I'll be removing it from the truck this weekend.
     
  10. Mar 21, 2017 at 6:36 AM
    #10
    StOrMyThEtAcO

    StOrMyThEtAcO ZS

    Joined:
    Mar 23, 2015
    Member:
    #151561
    Messages:
    5,682
    Gender:
    Male
    First Name:
    Cody
    Flagstaff, Arizona
    Vehicle:
    13 DCSB TRD OR 6 speed Supercharged/ 18 T4R TRD Offroad Prem.
    Thread revival!

    How's the new motor running?
     
  11. May 29, 2017 at 6:33 AM
    #11
    lucky

    lucky [OP] Well-Known Member

    Joined:
    Jun 21, 2008
    Member:
    #7468
    Messages:
    353
    Gender:
    Male
    NB, TX
    Vehicle:
    07 PreRunnerX4
    TRD 2 CAI Firestone Ride-Rite TSB Leafs Toytec AAL 5100's and OME Blue LED dash
    Revived revival..
    As of today the engine has approx 115K on it. The truck has 196K.
     
  12. May 30, 2017 at 1:04 PM
    #12
    07 sport 4x4

    07 sport 4x4 Well-Known Member

    Joined:
    Dec 24, 2010
    Member:
    #48165
    Messages:
    928
    Gender:
    Male
    First Name:
    Blake
    Southeast
    Vehicle:
    07 Sport DCSB
    Did you ever figure out why you weren't getting oil to one side of the engine? My truck is running great at 80k miles, but is starting to get the burnt oil looking buildup on the drivers side... I can see it through the fill hole.
     
  13. May 30, 2017 at 1:06 PM
    #13
    07 sport 4x4

    07 sport 4x4 Well-Known Member

    Joined:
    Dec 24, 2010
    Member:
    #48165
    Messages:
    928
    Gender:
    Male
    First Name:
    Blake
    Southeast
    Vehicle:
    07 Sport DCSB
     
  14. May 30, 2017 at 1:34 PM
    #14
    lucky

    lucky [OP] Well-Known Member

    Joined:
    Jun 21, 2008
    Member:
    #7468
    Messages:
    353
    Gender:
    Male
    NB, TX
    Vehicle:
    07 PreRunnerX4
    TRD 2 CAI Firestone Ride-Rite TSB Leafs Toytec AAL 5100's and OME Blue LED dash
    Toyota told me the oil pump wasnt getting enough oil to drivers side, resulting in more heat and eventually premature wear on driver's side valve train, chains and tensioners. They eventually agreed to fix it for $3000, then IIRC they reduced the price to $1500. By that time I had already researched and found a complete engine with 1200 miles for $3000 and I felt like my original engine was now compromised. Since they acknowledged there were other documented cases, I tried all the defective product angles, BBB, etc... but they didnt budge. I cant say for sure that defective oil pump was problem. Some thought maybe I poured bad oil in it... or went too long without change - pretty sure that wasnt it. I replaced the motor - problem fixed - and still running strong.
     
  15. May 30, 2017 at 1:57 PM
    #15
    07 sport 4x4

    07 sport 4x4 Well-Known Member

    Joined:
    Dec 24, 2010
    Member:
    #48165
    Messages:
    928
    Gender:
    Male
    First Name:
    Blake
    Southeast
    Vehicle:
    07 Sport DCSB
    Mines still running great, but it makes me wonder if I should put a new oil pump in. I wish I had an oil pressure gauge, although I'm not sure it would tell you anything. It seems weird to me that you had pressure on one side but not the other.
     
To Top