1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Dashboard and Fog Lights Stopped Working 1st gen

Discussion in 'Lighting' started by dpalmer619, Apr 20, 2011.

  1. Apr 20, 2011 at 12:03 PM
    #1
    dpalmer619

    dpalmer619 [OP] Well-Known Member

    Joined:
    Oct 29, 2010
    Member:
    #45422
    Messages:
    389
    Gender:
    Male
    First Name:
    Derek
    San Diego
    Vehicle:
    '07 White TRD sport doublecab
    Icon 2.5 coilovers
    so i have the DDM 35watt HIDs in the top and i have the fog light mod done.
    i put an LED bulb in for the fog light and now my fog lights don't work and and my dashboard lights dont work either.

    and i dont know where to even start looking for the problem. Did the LED bulb send to much power and fry something? please help
     
  2. Apr 20, 2011 at 1:02 PM
    #2
    Southern01Taco

    Southern01Taco Well-Known Member

    Joined:
    Jul 20, 2010
    Member:
    #40457
    Messages:
    1,966
    Gender:
    Male
    First Name:
    Sean
    Holden, La
    Vehicle:
    01 V6 4x4 Xtra Cab SR5
    Start checking fuses. You might have shorted something out and it popped a fuse.
     
To Top