1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Dealer said my water pump is leaking?

Discussion in '1st Gen. Tacomas (1995-2004)' started by defleppardsg, Apr 23, 2012.

  1. Apr 23, 2012 at 9:37 AM
    #1
    defleppardsg

    defleppardsg [OP] Well-Known Member

    Joined:
    Mar 6, 2011
    Member:
    #52453
    Messages:
    135
    Gender:
    Male
    First Name:
    chris
    texas
    Vehicle:
    2.7L SR5 4x4
    OME 880's, Wheeler's Offroad 5-Leaf pack. Bilstein 5100's, 1" Daystar shackles, Deck Plate Mod.
    My trucks in getting the frame replaced and the dealer just called me to tell me that my water pump is leaking antifreeze? (2.7L) I told them to fix it while they have everything apart..

    I just wanted to get in here and see if anyone could educate me about what this issue is, and assure me whether or not it sounds like they're screwing me or not...

    Any insight would be appreciated
     
  2. Apr 23, 2012 at 9:44 AM
    #2
    seksilumpia

    seksilumpia Well-Known Member

    Joined:
    Oct 25, 2009
    Member:
    #24905
    Messages:
    592
    Gender:
    Male
    First Name:
    Brandon
    El Dorado Hills
    Vehicle:
    05 TRD Sport DCSB
    Performance mods: TRD CAI, AFE throttle body spacer, Doug Thorley headers, TRD exhaust. Cosmetic mods: HID 10k head+3k fog lights, BHLM, T-rex 2 eyelids, billet grill (5 piece), 20% front window tint, 4% back window tint, tinted 3rd brake light, altezza tail lights, LED license plate lights, door skid protectors, slotted drilled rotors,plasti dip rims,painted rotor and drums. Interior mods: TRD seat covers, LED map and dome lights, 2 kicker 10' w/ 500 watt amp, pioneer door speakers,and Pioneer AVIC X930BT.
    ask for the old one back..then try to wobble the fan..if thats solid,then the seal is good. if it has a slight wobble,then its bad..when they reseal it,ask them to use FIPG as well to make a better seal
     
  3. Apr 24, 2012 at 6:40 AM
    #3
    Hillingdoner

    Hillingdoner Well-Known Member

    Joined:
    Jan 9, 2012
    Member:
    #70273
    Messages:
    458
    Gender:
    Male
    Rio Rancho, NM
    Vehicle:
    95 LX xtracab 3.4L 4x4 5spd
    140 amp Cadillac alternator, Audio system in progress, 4Runner map light mirror conversion, foot well lamp addition, buckets and console from 99 Tacoma regular cab, big three, tint
    Could be possible they noticed your water pump leaking. The water pump has a weep hole located on the bottom of the water pump body towards the fan side. When the water pump starts to go out it will begin dripping your coolant out of this hole. The amount it will leak will vary, but any leak is a sign that the water pump is starting to go out. With Toyota's use of the red antifreeze leaks are pretty easy to find as there will be a residue showing where there is a leak or where it has been running down. If the leak was not severe then the pump may have lasted a while yet, but then maybe not so wisest to just go ahead and replace it.
     
  4. Apr 24, 2012 at 7:00 AM
    #4
    Hoyle

    Hoyle Well-Known Member

    Joined:
    Jan 18, 2011
    Member:
    #49468
    Messages:
    78
    Gender:
    Male
    Davidson, NC
    Vehicle:
    2014 DCSB 4x4 Black
    The Dealer sais, The Dealer sais, they are screwing you... lol... just kidding .. I'm sure it's leaking, get it replaced and go with it.. there are ethical moral people working at dealership..
     
  5. Jul 13, 2012 at 4:30 PM
    #5
    mtlineman

    mtlineman Member

    Joined:
    Sep 4, 2011
    Member:
    #62882
    Messages:
    16
    Gender:
    Male
    First Name:
    Woody
    Billings mt
    Vehicle:
    06 Tacoma 2 wd 4 cyl 5 spd
    Cruise control added, motorcycle rack
    The pump on my 06 with 17068 miles is leaking
     
To Top