1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Dome light only comes on when map lights are turned on?

Discussion in 'Technical Chat' started by moto932, May 1, 2011.

  1. May 1, 2011 at 9:38 AM
    #1
    moto932

    moto932 [OP] What's the matter, Colonel Sandurz? CHICKEN?

    Joined:
    Apr 9, 2009
    Member:
    #15770
    Messages:
    3,100
    Gender:
    Male
    First Name:
    Eric
    Dayton, Ohio
    Vehicle:
    04 TRD Off Road SR5 Impulse Red
    5100's @ 1.25", Scangaugae II, deck plate mod w/AFE Pro Dry S filter, grey wire mod, alarm mod, defrost w/o compressor mod, de-badged, 17" sport wheels powder coated black, 1" B.O.R.A. wheel spacers, 265/70/17 Cooper Zeon LTZ's, sockmonkey beside decals.
    the other day my dome light stopped working. i just thought the bulb burnt out so i ordered on from super bright leds and i go to take the factory bulb out and the filament looks fine. so i put in my new led and get nothing. after messing around for a awhile i went to turn on my map lights so i can see, and to my surprise, the dome light lights up like a christmas tree. turn the map lights off and the dome light goes off. this is all with the doors open and the dome switch on "DOOR" but it's the same way when i switch it to "ON".

    any ideas on what is going on??
     
  2. May 1, 2011 at 11:53 AM
    #2
    moto932

    moto932 [OP] What's the matter, Colonel Sandurz? CHICKEN?

    Joined:
    Apr 9, 2009
    Member:
    #15770
    Messages:
    3,100
    Gender:
    Male
    First Name:
    Eric
    Dayton, Ohio
    Vehicle:
    04 TRD Off Road SR5 Impulse Red
    5100's @ 1.25", Scangaugae II, deck plate mod w/AFE Pro Dry S filter, grey wire mod, alarm mod, defrost w/o compressor mod, de-badged, 17" sport wheels powder coated black, 1" B.O.R.A. wheel spacers, 265/70/17 Cooper Zeon LTZ's, sockmonkey beside decals.
    dome light also comes on when: map lights are turned off, door open, and key turned on in ignition.
     
  3. May 1, 2011 at 12:07 PM
    #3
    MountainEarth

    MountainEarth Well-Known Member

    Joined:
    Feb 1, 2010
    Member:
    #30519
    Messages:
    2,495
    Gender:
    Male
    First Name:
    Bryan
    CO
    Vehicle:
    2010 TRD OR Access
    Leer 100XR Shell, BedRug mat - comfy sleeping, GT Covers microfiber seat covers, BFG All Terrains 265/70r16, Dashmat, Antennax 13" shorty antenna, Weathertech liners, Ultra Gauge, Avid Light Bar, PIAA 520 ATPs, one old dog
    Gremlins?
     
  4. May 1, 2011 at 12:21 PM
    #4
    Average JOE

    Average JOE Well-Known Member

    Joined:
    Nov 26, 2010
    Member:
    #46747
    Messages:
    226
    Gender:
    Male
    First Name:
    Matt
    San Diego
    Vehicle:
    PreRunner
    3'lift,Upgraded sound system,Dyanamat interior flowmaster,K&N,
    Enjoy it. I have heard some members asking how to do that. Maybe you could do a write up on it! JK
     
  5. May 1, 2011 at 5:18 PM
    #5
    moto932

    moto932 [OP] What's the matter, Colonel Sandurz? CHICKEN?

    Joined:
    Apr 9, 2009
    Member:
    #15770
    Messages:
    3,100
    Gender:
    Male
    First Name:
    Eric
    Dayton, Ohio
    Vehicle:
    04 TRD Off Road SR5 Impulse Red
    5100's @ 1.25", Scangaugae II, deck plate mod w/AFE Pro Dry S filter, grey wire mod, alarm mod, defrost w/o compressor mod, de-badged, 17" sport wheels powder coated black, 1" B.O.R.A. wheel spacers, 265/70/17 Cooper Zeon LTZ's, sockmonkey beside decals.
    i looked and didnt see any :notsure:
     
  6. May 1, 2011 at 5:21 PM
    #6
    MHS2846bg8

    MHS2846bg8 Experienced Noob

    Joined:
    Nov 3, 2008
    Member:
    #10451
    Messages:
    747
    Gender:
    Male
    First Name:
    Nate
    South Coast of Oregon
    Vehicle:
    08 Tacoma TRD Dbl Cab 4x4 MT
    I know this is a problem with 1st gens...something about current sensing to feed enough power to the light. I was going to look into possibly putting a resistor up there of some sort, but ive just been too lazy to get a few different rating resistors...but once I find the right one, I'll do a write up.

    If you get to it before I do, let me know! I'm pretty sure that's the problem. The stock bulbs need more current than the led strips.
     
  7. May 1, 2011 at 6:01 PM
    #7
    moto932

    moto932 [OP] What's the matter, Colonel Sandurz? CHICKEN?

    Joined:
    Apr 9, 2009
    Member:
    #15770
    Messages:
    3,100
    Gender:
    Male
    First Name:
    Eric
    Dayton, Ohio
    Vehicle:
    04 TRD Off Road SR5 Impulse Red
    5100's @ 1.25", Scangaugae II, deck plate mod w/AFE Pro Dry S filter, grey wire mod, alarm mod, defrost w/o compressor mod, de-badged, 17" sport wheels powder coated black, 1" B.O.R.A. wheel spacers, 265/70/17 Cooper Zeon LTZ's, sockmonkey beside decals.
    thanks for the info but im clueless when it come to electrical work. why would it work for 7 years then all of the sudden stop working?
     
  8. May 1, 2011 at 7:31 PM
    #8
    MHS2846bg8

    MHS2846bg8 Experienced Noob

    Joined:
    Nov 3, 2008
    Member:
    #10451
    Messages:
    747
    Gender:
    Male
    First Name:
    Nate
    South Coast of Oregon
    Vehicle:
    08 Tacoma TRD Dbl Cab 4x4 MT
    ah...I didn't see that the filament wasn't broken... The bulb may have worn out or there may be a short somewhere...but from what I'm assuming, the problem with the dome light only coming on when map lights are turned on is because the dome isn't pulling enough current to switch something on.
     
  9. Jun 2, 2011 at 7:05 PM
    #9
    moto932

    moto932 [OP] What's the matter, Colonel Sandurz? CHICKEN?

    Joined:
    Apr 9, 2009
    Member:
    #15770
    Messages:
    3,100
    Gender:
    Male
    First Name:
    Eric
    Dayton, Ohio
    Vehicle:
    04 TRD Off Road SR5 Impulse Red
    5100's @ 1.25", Scangaugae II, deck plate mod w/AFE Pro Dry S filter, grey wire mod, alarm mod, defrost w/o compressor mod, de-badged, 17" sport wheels powder coated black, 1" B.O.R.A. wheel spacers, 265/70/17 Cooper Zeon LTZ's, sockmonkey beside decals.
    bump, still haven't figured this out :(

    what would cause this and how could it be fixed?
     
  10. Jun 3, 2011 at 8:05 AM
    #10
    BradleyScottETC

    BradleyScottETC Class IV Category 8 Elite VIP Member (Only)

    Joined:
    Aug 2, 2009
    Member:
    #20521
    Messages:
    1,757
    Gender:
    Male
    First Name:
    Bradley
    Lake County, FL
    Vehicle:
    10 4.0 AC 4x4
  11. Jun 3, 2011 at 8:10 AM
    #11
    BradleyScottETC

    BradleyScottETC Class IV Category 8 Elite VIP Member (Only)

    Joined:
    Aug 2, 2009
    Member:
    #20521
    Messages:
    1,757
    Gender:
    Male
    First Name:
    Bradley
    Lake County, FL
    Vehicle:
    10 4.0 AC 4x4
    You could verify that the old bulb works by wrapping a bare wire around the base of it, touching the end to the positive terminal on your battery and the wire against the negative.
     
  12. Jun 3, 2011 at 9:57 AM
    #12
    skytower

    skytower Well-Known Member

    Joined:
    Jun 7, 2010
    Member:
    #38505
    Messages:
    3,221
    Gender:
    Male
    First Name:
    Dave
    virginia
    Vehicle:
    08 Tacoma 4x4
    Hitch and wiring, aux back-up light, rear strobe lights, radio and underseat sub.
    Your dome light is missing its ground, or is shorted to the map light.
     
  13. Jun 3, 2011 at 10:10 AM
    #13
    JLee

    JLee The Man! Vendor

    Joined:
    Jul 20, 2010
    Member:
    #40461
    Messages:
    15,324
    Gender:
    Male
    First Name:
    Jerry
    Bay Area NorCal
    Vehicle:
    02 Extra cab SAS Linked front and rear
    I lost track thousands of dollars ago.

    It's not a ground on 1st Gens when the key is turned off it's dims the dome light so if you install a LED it will not turn on unless you turn the key on. if you pulled that LED out right now and installed a filament bulb it would work just fine.

    And yes the map and dome lights are on the same 12v source and that is why if you turn on the map lights your LED will turn on. Try and installing a LED in the map lights as well they will not turn on unless the key is on.


    There is a way to fix it.
    This is what I'm going to do is wire a #74 bulb inline with the dome and paint over it so no light is let out and the right amount of current is drawn and the LED's will light up. Ive seen it before and it works great. The only other way is rewire the dome light to a straight 12v source and they will work fine.
     
  14. Oct 5, 2011 at 6:53 PM
    #14
    moto932

    moto932 [OP] What's the matter, Colonel Sandurz? CHICKEN?

    Joined:
    Apr 9, 2009
    Member:
    #15770
    Messages:
    3,100
    Gender:
    Male
    First Name:
    Eric
    Dayton, Ohio
    Vehicle:
    04 TRD Off Road SR5 Impulse Red
    5100's @ 1.25", Scangaugae II, deck plate mod w/AFE Pro Dry S filter, grey wire mod, alarm mod, defrost w/o compressor mod, de-badged, 17" sport wheels powder coated black, 1" B.O.R.A. wheel spacers, 265/70/17 Cooper Zeon LTZ's, sockmonkey beside decals.
    finally got my dome light working again. not real sure what i did but it works. i took the map light completely apart and unplugged it. blew the fuse in the process by touching my screwdriver to a couple thing i wasnt supposed to. re-installed the map lights, threw in a new fuse and BAM, it works. so i guess it must have been a bad ground? if thats the case, wonder why it didnt start working the frist time i disassembled it? oh it works now. thanks for everyone input, it is appreciated :thumbsup:
     
  15. Nov 10, 2011 at 8:41 AM
    #15
    TIPICOTACO

    TIPICOTACO Well-Known Member

    Joined:
    Nov 22, 2010
    Member:
    #46556
    Messages:
    2,023
    Gender:
    Male
    First Name:
    Tyler
    nw nj
    Vehicle:
    '01 DC 4X4 TRD "RAD BARON"
    Some lift, some armor, some scratches.. check out the build!
     
To Top