1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Drive start control malfunction

Discussion in '3rd Gen. Tacomas (2016-2023)' started by rharris, Jun 17, 2020.

  1. Jun 17, 2020 at 3:19 PM
    #1
    rharris

    rharris [OP] Member

    Joined:
    Apr 3, 2018
    Member:
    #249254
    Messages:
    21
    Gender:
    Male
    Hi folks, got an error today and was wondering if anyone could help me out.

    2018 DCSB OR all stock with 16000 km on it. It had a service 3 completed (as per maintenance schedule) on May 20th. It has not been driven much due to Covid and due to that I'm lucky enough that I can bike to work. Last time I drove was probably a week ago.

    Started up my 2018 today without issue and went to put it into Drive. It did physically go into drive but it did not acknowledge that the truck was in drive visually. The LED "D" by the shifter did not light up and it did not register as in D on the speedometer (no little D by the ODO - R and N would show up when the truck is in shifted into those).

    I drove fine to Walmart, did my shopping, and returned to the truck. Started it up again and again the LED D did not light up nor was it visible on the speedometer by the ODO. After about 30 seconds I received an error that stated "Drive Start Control Malfunction Visit Your Dealer." Drove home with no issue and parked in my driveway. I shifted between R, N, D, and S mode and the D would light up periodically but then would not. Did anyone bring this issue to the dealer/have it resolved?

    I googled this issue before posting and everything seemed to be related to OV tune or having different lights/not stock electronics. This is not the case with my truck as everything is stock.

    Any help would be greatly appreciated!!
     
  2. Jun 17, 2020 at 3:20 PM
    #2
    9th

    9th Not a Civil Engineer

    Joined:
    Mar 24, 2017
    Member:
    #214312
    Messages:
    2,675
    Gender:
    Male
    First Name:
    Smitty
    Tropic of Cancer
    Vehicle:
    2017 Unicorn Silver Sky
    lubricated fuel door hinge
    take it to the dealer?
     
  3. Jun 17, 2020 at 4:00 PM
    #3
    rharris

    rharris [OP] Member

    Joined:
    Apr 3, 2018
    Member:
    #249254
    Messages:
    21
    Gender:
    Male
    Yes, I am going to! The error message popped up when they were already closed and figured I would check to see if there was any insight before calling them tomorrow.
     
  4. Jun 17, 2020 at 4:04 PM
    #4
    MOC221_

    MOC221_ 3 pedal metal

    Joined:
    Feb 20, 2016
    Member:
    #178858
    Messages:
    7,824
    Gender:
    Male
    First Name:
    Frank
    Vehicle:
    2019 DCSB Sport M/T Barcelona Red
    vF Tuned; ADM; Core SS
    Nothing aftermarket using the OBD port?
    No shiftsense pro?

    Can u read codes?
     
  5. Jun 17, 2020 at 4:08 PM
    #5
    rharris

    rharris [OP] Member

    Joined:
    Apr 3, 2018
    Member:
    #249254
    Messages:
    21
    Gender:
    Male
    Nothing aftermarket at all and no shiftsense pro! I do not have a code reader sadly.
     
    MOC221_[QUOTED] likes this.
  6. Jun 17, 2020 at 4:18 PM
    #6
    MOC221_

    MOC221_ 3 pedal metal

    Joined:
    Feb 20, 2016
    Member:
    #178858
    Messages:
    7,824
    Gender:
    Male
    First Name:
    Frank
    Vehicle:
    2019 DCSB Sport M/T Barcelona Red
    vF Tuned; ADM; Core SS
    Is the error in the cluster just text or does it have a foot and brake graphic too?
    I've seen it b4 but only when flashing a tune file (unrelated to your issue).
    Yes, this is going somewhere..
     
    Last edited: Jun 17, 2020
  7. Jun 17, 2020 at 4:38 PM
    #7
    rharris

    rharris [OP] Member

    Joined:
    Apr 3, 2018
    Member:
    #249254
    Messages:
    21
    Gender:
    Male
    Haha it's all good man, I appreciate the help! Yes the error is in the cluster and yes there is an orange foot and picture of the brake. I can probably post a picture if needed!
     
    MOC221_[QUOTED] likes this.
  8. Jun 17, 2020 at 4:51 PM
    #8
    MOC221_

    MOC221_ 3 pedal metal

    Joined:
    Feb 20, 2016
    Member:
    #178858
    Messages:
    7,824
    Gender:
    Male
    First Name:
    Frank
    Vehicle:
    2019 DCSB Sport M/T Barcelona Red
    vF Tuned; ADM; Core SS
    I wonder if it could be as simple as your brake light switch sticking or a loose connector? Are your brake lights working properly?
    Just a shot in the dark before a trip to the dealer..
    Good luck man!
     
  9. Jun 17, 2020 at 4:55 PM
    #9
    rharris

    rharris [OP] Member

    Joined:
    Apr 3, 2018
    Member:
    #249254
    Messages:
    21
    Gender:
    Male
    I'll check it out! Appreciate the help man. I'm rattled about the LED indicator not showing up by the shifter and not beside the ODO on the digital speedometer. Hopefully the dealer can fix it up for me.
     
  10. Mar 10, 2022 at 6:41 AM
    #10
    Tacoma in Ottawa

    Tacoma in Ottawa New Member

    Joined:
    Mar 10, 2022
    Member:
    #392260
    Messages:
    2
    Gender:
    Male
    First Name:
    David
    Vehicle:
    2018 Tacoma - DoubleCab V6 with Sport Upgrade
    None, all stock
    Hi,
    I know this is a little late, but I thought my experience might be useful to others.

    My "Drive-Start Malfunction Control Malfunction" came up yesterday as well on my 2018 Tacoma. I visited the dealer to have it diagnosed (as suggested by the message) and their scan indicated that there was a "neutral safety switch short circuit (P070513)". The correction (as determined by the computer) was to replace the neutral safety switch (P/N 84540-60050). The part cost was $264.92 and the labor was $161.94, but unfortunately the switch was in Toronto (I am in Ottawa), so I would have to pay for it up front and then come back to have the Tacoma serviced.

    Luckily for me, I had the ECP plan! Well, not really, because the service advisor indicated that the ECP plan wouldn't cover it, AND... my ECP had expired in February. :(

    The shifter has been a bit stiff for the past 4 months, and wouldn't always light up the LED position beside the shifter (which I had noticed about 4 months ago in November when it was very cold out (about -20°C) prior to this incident). The advisor indicated that the technician had lubricated the shifter (not indicated on the work order), and that I could think about the replacement, but the vehicle was safe to drive.

    Now the truck shifts very smoothly, the lights beside the shifter come on as they're supposed to, and the "Drive-Start Malfunction Control Malfunction" error is NOT displayed.

    Really thankful that the technician had the idea to lubricate the shifter AND that the part wasn't immediately available, otherwise I probably would have paid for the computer recommended service.



    David.
    All stock, 2018 Tacoma, 20228 km.
     
    Metalskool and hiPSI like this.
  11. Mar 19, 2022 at 7:56 AM
    #11
    Clymber

    Clymber Well-Known Member

    Joined:
    Mar 16, 2014
    Member:
    #125419
    Messages:
    413
    Gender:
    Male
    Vermont
    Vehicle:
    Trd
    I just got this code today along with a bunch of other things truck currently has 7300 miles on it
    Reverse camera on when driving
    Drive & Reverse lite on shift column
    Drive icon flashing on dash
    Strange static noice coming from speakers
     

Products Discussed in

To Top