1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

DSM UCA's installed... got a few questions

Discussion in 'Suspension' started by jusmac, Oct 26, 2010.

  1. Oct 26, 2010 at 9:11 AM
    #1
    jusmac

    jusmac [OP] Well-Known Member

    Joined:
    Mar 2, 2010
    Member:
    #32419
    Messages:
    276
    So i installed a set of DSM UCA's and they are great. they look great quality is top notched and install is super easy.

    had one hickup though after the install was done. i have the toytec ultimate lift with 285/70/17 and a 17x9 rim with a -12mm offset. with stock control arms they didnt rub one bit, no matter what. But now with the new UCA's the tires are rubbing on the cab mounts when i turn and a ton when the suspension compresses. DSM and i cannot figure out why this would be happening with aftermarket ones when it didnt with stock control arms. any ideas, or has anyone had this issue with other aftermarket UCA's?
     
  2. Oct 26, 2010 at 9:25 AM
    #2
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,156
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Caster correcting UCA's move the top of the spindle back a couple degrees. This can cause rubbing of the body mount if 33" tires are mounted on the truck.
     
  3. Oct 26, 2010 at 9:33 AM
    #3
    jusmac

    jusmac [OP] Well-Known Member

    Joined:
    Mar 2, 2010
    Member:
    #32419
    Messages:
    276
    ya i thought someone might say that, i was hoping they didnt send me the built in caster UCA's
     
  4. Oct 26, 2010 at 9:38 AM
    #4
    brutalguyracing

    brutalguyracing BIG DADDY

    Joined:
    Jun 28, 2009
    Member:
    #19000
    Messages:
    24,038
    Gender:
    Male
    F.U> GUYZ
    broken mods
  5. Oct 26, 2010 at 9:44 AM
    #5
    jusmac

    jusmac [OP] Well-Known Member

    Joined:
    Mar 2, 2010
    Member:
    #32419
    Messages:
    276
    well i thought so but my truck was aligned perfect with stock arms. Its not a big issue I can cut the cab mounts I just wanted to see if anyone had this issue as well. Keep an eye out I will be posting a review of the install and pics and such. thanks guys
     
  6. Oct 26, 2010 at 10:30 AM
    #6
    jusmac

    jusmac [OP] Well-Known Member

    Joined:
    Mar 2, 2010
    Member:
    #32419
    Messages:
    276
    yes, and the stock ones hit the coils when they drooped.
     
  7. Nov 4, 2010 at 3:40 PM
    #7
    Sb_Bob_E10

    Sb_Bob_E10 Well-Known Member

    Joined:
    Apr 5, 2010
    Member:
    #34664
    Messages:
    89
    Gender:
    Male
    First Name:
    Bobby
    Goleta/Santa Barbara,Ca.
    Vehicle:
    10 Tacoma 4x4 Sport LB
    Icon's Extended C/O's, 285/70r17 Duratracs on Eagle 063's Raven Black, Weathertech floor mats,AFE Drop In, 1" block in rear for now w/ billie 5100's.

    Can you please post up some pics of your new installed DSM UCA's? Thanks!
     
To Top