1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Electrical Help!

Discussion in '2nd Gen. Tacomas (2005-2015)' started by TacoKurt, May 3, 2011.

  1. May 3, 2011 at 4:36 PM
    #1
    TacoKurt

    TacoKurt [OP] Member

    Joined:
    Apr 13, 2011
    Member:
    #54859
    Messages:
    6
    Gender:
    Male
    First Name:
    Kurt
    Canyon Country
    Vehicle:
    2010 PreRunner Tacoma
    KMC Addict Rims Hankook MT Tires Satoshi Grill Hella 500FF lights Smoked Tail Lights
    I tried to wire a PA system to my car, and when I finally got done wiring everything up, I attached the negative terminal and the dash lights and parking lights flashed. And my truck wont start. Someone please help!

    Ive tried leaving the negative terminal disconnected for 2 minutes and connecting it again, and same thing happened.

    Please help!

    :confused::confused::confused:

    :help::help::help::help:
     
  2. May 3, 2011 at 4:40 PM
    #2
    brutalguyracing

    brutalguyracing BIG DADDY

    Joined:
    Jun 28, 2009
    Member:
    #19000
    Messages:
    24,038
    Gender:
    Male
    F.U> GUYZ
    broken mods
    sounds like you blew a fuse......
    what are doing exactly???
     
  3. May 4, 2011 at 6:33 AM
    #3
    StandingCow

    StandingCow Well-Known Member

    Joined:
    Apr 24, 2009
    Member:
    #16373
    Messages:
    1,799
    Gender:
    Male
    First Name:
    John
    NJ
    Vehicle:
    09 SR5 4x4 V6 access cab
    Yea, def blew a fuse somewhere...
     
  4. May 4, 2011 at 7:40 AM
    #4
    brutalguyracing

    brutalguyracing BIG DADDY

    Joined:
    Jun 28, 2009
    Member:
    #19000
    Messages:
    24,038
    Gender:
    Male
    F.U> GUYZ
    broken mods
    dont listen to him ....his truck is on :bananadead: from electrical work:D:rolleyes:
     
  5. May 4, 2011 at 10:45 AM
    #5
    JR616

    JR616 Well-Known Member

    Joined:
    Oct 15, 2010
    Member:
    #44723
    Messages:
    123
    Gender:
    Male
    First Name:
    JAMES
    SOCAL
    Vehicle:
    06 double cab prerunner
    lol check your valet switch ya big dummy:facepalm::facepalm::facepalm::facepalm:
     
  6. May 4, 2011 at 11:08 PM
    #6
    TacoKurt

    TacoKurt [OP] Member

    Joined:
    Apr 13, 2011
    Member:
    #54859
    Messages:
    6
    Gender:
    Male
    First Name:
    Kurt
    Canyon Country
    Vehicle:
    2010 PreRunner Tacoma
    KMC Addict Rims Hankook MT Tires Satoshi Grill Hella 500FF lights Smoked Tail Lights
    JR616 was right! Thank you! :brianr::brianr:
     
  7. May 4, 2011 at 11:42 PM
    #7
    StandingCow

    StandingCow Well-Known Member

    Joined:
    Apr 24, 2009
    Member:
    #16373
    Messages:
    1,799
    Gender:
    Male
    First Name:
    John
    NJ
    Vehicle:
    09 SR5 4x4 V6 access cab
    Communist lies!
     
To Top