1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

electrical madness!!!!

Discussion in 'Lighting' started by Bartaco, May 6, 2011.

  1. May 6, 2011 at 11:41 PM
    #1
    Bartaco

    Bartaco [OP] Well-Known Member

    Joined:
    Apr 19, 2011
    Member:
    #55221
    Messages:
    102
    Gender:
    Male
    First Name:
    Bill
    Connecticut
    Vehicle:
    Red extra cab 6 cyl with chip,gibson flowma
    Bilstein 5100 series ,uniball uca's,3" lift kit ,extra leaf, Gibson exhaust.limited slip rear, six lug,lock out hubs,K&N air cleaner sysytem
    All of my interior lights (for the most part) are acting strange. like, the dome light comes on about 2 seconds after I hit the switch. the dash cluster is doing the same thing.the climate control leds are waay too dim. Everyone is saying replace the rheostat/dimmer switch and disconnect theorange illumination wire from the stereo/head unit.does this sound like it c ould be the dimmer switch? could it effect the dome lights as well??? I'm trying to get
    some aideas cuz I'm lost i bought the truck like this...:( soljah helped me out big time but theres more to it this I think.
     
To Top