1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Electronic problems

Discussion in 'Technical Chat' started by Ctrice, Apr 3, 2012.

  1. Apr 3, 2012 at 7:27 AM
    #1
    Ctrice

    Ctrice [OP] New Member

    Joined:
    Apr 3, 2012
    Member:
    #76179
    Messages:
    1
    Gender:
    Male
    Saskatchewan
    Vehicle:
    09 Trd Tacoma
    Got a 2009 trd tacoma, recently lost transmission lights in dash(ie. P R N D 4 3 2 L) no climate control, no signal lights, also airbag light is on. I haven't checked fuses yet, but I thought id post here since I doubt it can all be caused by fuses.
     
  2. Apr 3, 2012 at 9:55 PM
    #2
    khx73

    khx73 Well-Known Member

    Joined:
    Sep 22, 2011
    Member:
    #63950
    Messages:
    611
    Gender:
    Male
    Saint John NB, CAN
    Vehicle:
    11 MGM DCLB TRD Sport +leather
    Rear camera anytime switch, 4x4 Illuminated Switch (from rcbs204) , rear view mirror lift bracket (from ImMrYo), 75 cent tailgate anti-theft. Technically not mods but give me a break I'm trying to fill space here... OEM Leather pkg, keyless unlock & ACC chime silence, BakFlip G2, Ultra Gauge EM, WeatherTech floor mats, OEM roof rack
    I bet it is :D

    Worth a quick check, don't ya think?
     
  3. Apr 3, 2012 at 10:00 PM
    #3
    Jerez

    Jerez SoCal LED Dash Swap

    Joined:
    Feb 1, 2010
    Member:
    #30488
    Messages:
    15,734
    Gender:
    Male
    First Name:
    Roderick aka Royer
    Ontario/Chino Area (CALI)
    Vehicle:
    08 TRD ESport DCLB
    Half LT dont count
    have you done anything that would cause the fuses to go out?
     
To Top