1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Engine Code help

Discussion in '2nd Gen. Tacomas' started by SJginger, May 5, 2012.

  1. SJginger

    SJginger [OP] Well-Known Member

    Joined:
    Jul 26, 2011
    Member:
    #60566
    Messages:
    96
    Gender:
    Male
    First Name:
    Jerry
    South Jersey
    Vehicle:
    08 tacoma trd sport, stock for right now!!!
    So on my way to work my ultra gauge started buzzing with a "pending engine code" display pull over and check what it is throwing up and the code came back as "P0012". Looked it up on yahoo and its a camshaft postion sensor.

    I understand its not a good code to have but how bad is it really? Any help would be apparicated.
     
  2. whippersnapper02

    whippersnapper02 Well-Known Member

    Joined:
    Dec 20, 2009
    Member:
    #27905
    Messages:
    35,266
    Gender:
    Male
    First Name:
    Christian
    Yorba Linda, CA
    Vehicle:
    10 MGM TRD OR 4wd Auto DCSB
    Banks Monster Exhaust, Pop n Lock tailgate lock, Hook-Ups tie down brackets, USA Spec Ipod adaptor, WO seat covers, color matched grill with Grillcraft insert, Tuffy locking bed box
    Erase it and see if it comes back. When driving my ex gf's dad's Infinity I35 I got that same code. I thought somehow I damaged the engine but I erased the code and it never came back. It could be a simple glitch.
     
To Top