1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Engine Code P1780 Solution!

Discussion in 'Technical Chat' started by CayucosTacoma, May 5, 2013.

  1. May 5, 2013 at 9:02 PM
    #1
    CayucosTacoma

    CayucosTacoma [OP] Just think outside the Yota

    Joined:
    Mar 9, 2012
    Member:
    #74580
    Messages:
    4,764
    Gender:
    Male
    First Name:
    Chris
    San Luis Obispo/Santa Barbara CA
    Vehicle:
    1998 Tacoma, 4x4 5 Speed, V6
    Specs in the Build Thread
    So had this weird engine code pop up on my truck. P1780.
    Did some searching and came up with the problem of "trans neutral Switch".
    Replaced the part(100 bucks shipped of rock auto), light went away for about 30 minutes.
    Comes back on, so I think it might be a faulty connection. Some Electric parts cleaner and Di Electric grease doesn't solve the issue.

    Today out of random luck I was messing with my tail light wiring, because it was pretty torn up.
    Connected the wire that illuminates the brake "light" when you hit the brakes back together and boom engine code gone.

    The tail light wiring and Trans Neutral Switch is somehow linked?

    But anyways just made this post incase someone scoping google is having similar issues.

    :cheers:
     
    Last edited: Apr 7, 2015
  2. Jan 5, 2014 at 10:39 AM
    #2
    philga5

    philga5 New Member

    Joined:
    Aug 4, 2011
    Member:
    #61127
    Messages:
    1
    Gender:
    Male
    First Name:
    phil
    canada
    Vehicle:
    02 tacoma 4x4 xcab 3.4l v6
    Thanks for this post ! I checked my tacoma for codes this morning ( CEL bulb is dead ) and P1780 appeared... I had to clean my break light connector maybe 2 weeks ago after removing it and replacing it the connection was bad and all kind of weird shit would happen like my fog lights would come on when braking. Anyway. I got this fixed and this is probally what triggered my p1780 ! now its cleared , ill wait a couple of days and check it again and will update this post !

    all this to say : thank you very much !
     
  3. Jun 3, 2014 at 9:20 AM
    #3
    darqnez

    darqnez Member

    Joined:
    May 28, 2014
    Member:
    #130787
    Messages:
    5
    Gender:
    Male
    Vehicle:
    DarqComa
    Howdy guys, I know this is kind of old, but I am having similar issues, my rear lights have lost their mind and do all kinds of weird stuff like the blinkers and brake dont work on the passenger side but if you turn on the emergency blinker the reverse light blinks on that same passenger side and if you press the brake with the blinker on the running lights light up and not the brake etc

    Also my front right headlight is always on when the truck is "on" and when started - so basically whenever the key has been turned, my drivers left head light is usually on when the truck is "on" but not when started... I also have had the p1780 code

    what exactly did you clean to resolve your issue? the plug that connects to the tail light housing?


     
To Top