1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Engine cranks but doesn’t start

Discussion in '2nd Gen. Tacomas (2005-2015)' started by stringah, Oct 10, 2021.

  1. Oct 10, 2021 at 11:30 PM
    #1
    stringah

    stringah [OP] Active Member

    Joined:
    Apr 3, 2009
    Member:
    #15550
    Messages:
    28
    Gender:
    Male
    Kaneohe, HI
    Vehicle:
    08 PreRunner Sport
    Need some help with my 2008 V6 Tacoma. I drove it this morning and it ran perfectly fine. Parked it for a couple of hours and went to start it and it wouldn’t fire. It just cranks. I was thinking possibly fuel pump so I disconnected the fuel lines near the gas tank and tried to start the engine and fuel shot out of one of the lines with good pressure. So the fuel pump is ruled out.
    Next I hooked up a noid light to one of the fuel injectors to see if there is power getting to them and tried to start the engine and no blinking of the noid light at all. I also checked the fuses and none are blown. So, now I am stuck. Could it possibly be a crank position sensor issue? Or anything I might have missed. Appreciate any help anybody has.
     
  2. Oct 11, 2021 at 12:12 AM
    #2
    TnShooter

    TnShooter Well-Known Member

    Joined:
    Sep 2, 2010
    Member:
    #42625
    Messages:
    6,226
    Gender:
    Male
    Vehicle:
    07' TRD Off-Road, Auto
    STOCK
    The engine immobilizer cuts powers to the EFI System.
    Have you tried a different key?

    What does the immobilizer light do on the dash?
    Is it blinking with the key in the ignition and on?
     
  3. Oct 11, 2021 at 12:51 AM
    #3
    stringah

    stringah [OP] Active Member

    Joined:
    Apr 3, 2009
    Member:
    #15550
    Messages:
    28
    Gender:
    Male
    Kaneohe, HI
    Vehicle:
    08 PreRunner Sport
    Yes with the key in the ignition and turned to “on” the light still blinks. Does that mean my key is not turning off the immobilizer? I won’t be able to get the spare key for a few days.
     
  4. Oct 11, 2021 at 2:49 AM
    #4
    Jimmyh

    Jimmyh Well-Known Member

    Joined:
    May 16, 2012
    Member:
    #78991
    Messages:
    12,748
    Gender:
    Male
    SC
    Vehicle:
    2012 Prerunner SR5

    Yes, it should stop blinking when the chip in the key is detected and accepted.
     
    JC15Taco and TnShooter like this.
  5. Oct 11, 2021 at 4:35 AM
    #5
    stringah

    stringah [OP] Active Member

    Joined:
    Apr 3, 2009
    Member:
    #15550
    Messages:
    28
    Gender:
    Male
    Kaneohe, HI
    Vehicle:
    08 PreRunner Sport
    I have to wait a few days for my spare key to be available. Thank you so much for the help. I was taking things apart in the engine bay and almost dropped my fuel tank to change the pump. Didn’t even think my key had taken a dive.
    Thanks again I will update when I get a hold of the spare key.
     
    JC15Taco, TnShooter and steelcity2 like this.
  6. Oct 13, 2021 at 7:51 PM
    #6
    stringah

    stringah [OP] Active Member

    Joined:
    Apr 3, 2009
    Member:
    #15550
    Messages:
    28
    Gender:
    Male
    Kaneohe, HI
    Vehicle:
    08 PreRunner Sport
    Finally got the spare key. The engine started up no problem. Thank you for the help!! Now I have to get a new key made and programmed.
     
    Jimmyh, TnShooter and tacomataco2 like this.
  7. Oct 13, 2021 at 8:32 PM
    #7
    TnShooter

    TnShooter Well-Known Member

    Joined:
    Sep 2, 2010
    Member:
    #42625
    Messages:
    6,226
    Gender:
    Male
    Vehicle:
    07' TRD Off-Road, Auto
    STOCK
    Good to hear.

    Thanks for the update
     
    Jimmyh likes this.
  8. Oct 13, 2021 at 11:23 PM
    #8
    Waasheem

    Waasheem The catholic radio bear

    Joined:
    Jun 26, 2019
    Member:
    #297494
    Messages:
    1,119
    Gender:
    Male
    First Name:
    Waasheem
    Vehicle:
    2007 xrunner
    I’m wondering, do the keys go bad over time, like a battery inside dies, or do yo get x amount of uses before it goes bad? When I bought mine used, it came with something like 7 keys. Are they gonna be dead in time sitting unused?
     
  9. Oct 14, 2021 at 1:41 AM
    #9
    Jimmyh

    Jimmyh Well-Known Member

    Joined:
    May 16, 2012
    Member:
    #78991
    Messages:
    12,748
    Gender:
    Male
    SC
    Vehicle:
    2012 Prerunner SR5
    There are no batteries on the OEM Stock chipped keys. The sensor ring around the ignition switch has a current going through it which produces a field that reads the chipped key code the same way that an RFID Chip in a credit or debit card. There are some cheap ass non-OEM keys that do have a battery... steer clear of these.

    https://nonstoplocksmith.com/how-do-transponder-keys-work/

    https://www.youtube.com/watch?v=zyDfUas-qSs
     
    Torspd, Waasheem and Dm93 like this.

Products Discussed in

To Top