1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Engine knock with cold start.

Discussion in '1st Gen. Tacomas (1995-2004)' started by Willieq, Nov 3, 2008.

  1. Nov 3, 2008 at 4:08 PM
    #1
    Willieq

    Willieq [OP] Member

    Joined:
    Oct 28, 2008
    Member:
    #10337
    Messages:
    5
    Vehicle:
    tacoma
    Its an "02" 4-cylinder with 135k miles. I have a engine knock with a cold start. No problems when I start it with a warm engine. Used a high dollar oil additive with no results. Have changed the oil every 3000 miles. Please help! Thanks.
     
  2. Nov 3, 2008 at 6:12 PM
    #2
    Ridgerunner

    Ridgerunner Well-Known Member

    Joined:
    Mar 14, 2008
    Member:
    #5269
    Messages:
    3,621
    Gender:
    Male
    First Name:
    Frank
    San Francisco
    Vehicle:
    2001 prerunner doublecab limited
    2001 with; cat-back twin exhaust,elbow mod, Westin bullbar with Hella550's, Snugtop XTR camper shell, TRD off-road 2x4-black beauty.
    Hi Willie-I say no worries-you have a slower oil pickup in there-the exact same thing has occured without fail in my wife's '87 Celica GTS...fire it up and the valve train rattles for about 3 seconds till it gets oil. Not going to hurt it at all because the HEAT of friction is a killer and this doesn't happen anywhere near long enough to matter:)
     
  3. Nov 3, 2008 at 8:04 PM
    #3
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,192
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    X2!
     
  4. Nov 4, 2008 at 4:16 AM
    #4
    Willieq

    Willieq [OP] Member

    Joined:
    Oct 28, 2008
    Member:
    #10337
    Messages:
    5
    Vehicle:
    tacoma
    Thanks for the info!
     
  5. Aug 15, 2010 at 9:03 PM
    #5
    trucklover63

    trucklover63 Active Member

    Joined:
    Jan 24, 2010
    Member:
    #29947
    Messages:
    37
    Gender:
    Male
    illinois
    Vehicle:
    04 PreRunner sr5
    Rattle or knock?..If it is a knock,it is probably piston slap..."normal" sound for Toyota 4 cylinder engines per two dealerships that listened to mine...I had 58,000 miles when mine started and it had to be under 30 degrees. Now,if its 70 degrees on a cold start,it knocks...Just another depressing quality slip up by Toyota,that they won't admit to..
     
  6. Aug 16, 2010 at 8:22 AM
    #6
    Willieq

    Willieq [OP] Member

    Joined:
    Oct 28, 2008
    Member:
    #10337
    Messages:
    5
    Vehicle:
    tacoma
    Thanks again..
    I now have about 170,000 miles and the knock is not as bad. Go figure?
     
  7. Aug 16, 2010 at 2:30 PM
    #7
    Barnone

    Barnone Guest

    Maybe you are use to the sound of the knock or your hearing is going bad. LOL
     
  8. Aug 18, 2010 at 12:17 PM
    #8
    Willieq

    Willieq [OP] Member

    Joined:
    Oct 28, 2008
    Member:
    #10337
    Messages:
    5
    Vehicle:
    tacoma
    Good one! :)
     
To Top