1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Engine Light Came On - I just bought it yesterday!

Discussion in 'Technical Chat' started by Jason chairs, Feb 24, 2011.

  1. Feb 24, 2011 at 5:38 PM
    #1
    Jason chairs

    Jason chairs [OP] Active Member

    Joined:
    Feb 23, 2011
    Member:
    #51687
    Messages:
    25
    Gender:
    Male
    First Name:
    jason
    Coatesville,pa
    Vehicle:
    2007.
    none yet want many
    I just bought a used 2007 Toyota Tacoma. I put a locking gas cap on it from my other vehicle (not a Toyota) and the 'engine malfunction' light is now on. I have since taken the cap off and put the old one that came with the truck back on it.
    I hope this will solve the problem.

    Jason
     
  2. Feb 24, 2011 at 5:41 PM
    #2
    PWhite13

    PWhite13 Well-Known Member

    Joined:
    Apr 11, 2010
    Member:
    #35075
    Messages:
    474
    Gender:
    Male
    First Name:
    Prescott
    Southern California
    Vehicle:
    06 Silverado Crew Cab 5.3
    Did it fix it?
     
  3. Feb 24, 2011 at 5:43 PM
    #3
    jandrews

    jandrews Carolina Alliance Southwest Region Ambassador

    Joined:
    Jun 7, 2009
    Member:
    #18122
    Messages:
    12,180
    Gender:
    Male
    Vehicle:
    '09 FourDubDee TRD OR
    A-TRUCK, Fat Kid in the Bed, Custom Pinstriping, Ported and Polished Muffler Bearing, Hi-Performance Bed Mat
    May need to reset the light by taking the terminals off the battery for about ten minutes.
     
  4. Feb 24, 2011 at 9:12 PM
    #4
    island808

    island808 Me l've got brains.

    Joined:
    Oct 9, 2010
    Member:
    #44414
    Messages:
    1,892
    Gender:
    Male
    First Name:
    Jedediah
    hawaii
    Vehicle:
    '10 6speed 4x4 access cab
    If its an emissions CEL you just have to wait. If it's the gas cap that is. It may turn off with a fuse or battery disconnect, but then you don't know if you fixed the problem or are just waiting for it to come back.

    If it's not flashing, just leave it and see if it goes away. Or if you can pull the code, that would be nice.
     
  5. Feb 24, 2011 at 9:29 PM
    #5
    JasoTaco

    JasoTaco Well-Known Member

    Joined:
    Jan 25, 2010
    Member:
    #30057
    Messages:
    2,007
    Gender:
    Male
    First Name:
    Jason
    Salt Lake City, Utah
    Vehicle:
    09 Tacoma TRD Off Road
    ToyTec Ultimate 3" Lift -TSB Rear springs - TRD Cold Air Intake - TRD Skid Plate - Total Chaos Upper Control Arms - 2 Hella Rallye 4000 lights (130W Bulbs) - Clear Bra - Under Coat - Bed extener - Toyota Bed Mat - Weathertech floor mats - Tailgate hose clamp & washer mod - PIAA Fog Lights - ScanGauge II - Beefed Sliders - Differential Breather Mod - Heated Seats - All-Pro Bumper - Warn M8000 Winch with wireless controls - Boztec Diff Skid - ATO skids
    Put a ScanGuauge or your need to buy list, you can pull the codes and clear them if the check engine light comes on.

    You can also take it to Autozone and they will pull the code for you.
     
  6. Feb 24, 2011 at 9:57 PM
    #6
    island808

    island808 Me l've got brains.

    Joined:
    Oct 9, 2010
    Member:
    #44414
    Messages:
    1,892
    Gender:
    Male
    First Name:
    Jedediah
    hawaii
    Vehicle:
    '10 6speed 4x4 access cab
    The guy at O'riley told us to go somewhere else to buy a OBD scanner. Said theirs were way too expensive.
    FYI.
    FOund about 20 in the Craigs list.
     
To Top