1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Engine miss at lower RPM's 01 1st gen

Discussion in '4 Cylinder' started by movezig, Jan 8, 2011.

  1. Jan 8, 2011 at 12:22 PM
    #1
    movezig

    movezig [OP] New Member

    Joined:
    Aug 5, 2008
    Member:
    #8353
    Messages:
    4
    Gulf Breeze FL
    Vehicle:
    Tacoma TRD
    Ive got a 2001 tacoma 4cyl (3Rz) and I am getting stuttering/missing when I accelerate in any gear at lower RPM's ( 1500 - 3200 ) then once it revs high enough in whatever gear it stops and evens out. I changed my spark plugs to BOSCH PLATINUM +4 and it cleared up the problem for about a week then it started again. This time it is a lot worse and is now throwing a check engine. I dont have an ecu reader to see what code it is. I am wondering if it could be a faulty coil pack? Any help would be great guys thanks!
     
  2. Jan 10, 2011 at 2:20 PM
    #2
    movezig

    movezig [OP] New Member

    Joined:
    Aug 5, 2008
    Member:
    #8353
    Messages:
    4
    Gulf Breeze FL
    Vehicle:
    Tacoma TRD
    I went to Autozone to see what the code was. Looks like it's cyl # 2 that is misfiring. Just to confirm, #2 is the second cylinder from the firewall correct?
     
  3. Jan 12, 2011 at 8:40 PM
    #3
    kloc

    kloc Member

    Joined:
    Apr 15, 2010
    Member:
    #35359
    Messages:
    15
    Gender:
    Male
    First Name:
    kory
    FarNorCal
    Vehicle:
    00' tacoma ext.cab 4x4 2.7
    3" Toytec Lift w/ 2.5" Pro Comp aal's, K&N 57 Series FIPK cai, MagnaFlow Cat-back Dual Exhaust, Delta Low Profile Polished Aluminum Diamond Plate Toolbox, Alpine CD Deck w/Ipod Interface
    i had the same problem with mine, 2000 3rz, mine was 3rd cyl misfire. turned out to be a bad injector. i would suggest you swap the injector from the misfiring cylinder with another one of your functioning cylinders. if thats the problem, then you need to order a set of injectors from L.C. Engineering, about $200 which is actually a smokin deal. they are tested and matched for their flow rate. i bought some and installed them myself. fixed the problem immediately. i noticed a difference in acceleration, much smoother and a little more responsive. there is a $50 dollar core charge but you get it back when you send them your old injectors. you better fix it soon too, because if for some reason there is raw fuel making it through the cylinder into your exhaust, it will burn up the front cat. i had that happen to me as well. just gutted it last month. really opened up my 2.7 a lot! i gained power and torque throughout the rpm range.... hope that helps you...good luck!
     
To Top