1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

engine stalling

Discussion in '4 Cylinder' started by michael tower, Aug 2, 2010.

  1. Aug 2, 2010 at 9:57 PM
    #1
    michael tower

    michael tower [OP] New Member

    Joined:
    Nov 10, 2009
    Member:
    #25749
    Messages:
    1
    Gender:
    Male
    san diego
    Vehicle:
    2002 2.4 sr5
    hello.I have a 2002 tacoma 2.4 liter with 270,000 miles on the odometer.Shes been regularly maintained. .recent air,oil,fuel, filters ,new stock plugs. used a can of that sea foam stuff.The problem:the truck runs fine when i first start it than shut it off like when running into 7-eleven for coffee the engine will start than stall .you have to wait for the fuel pump to quit and your foot to start.It than requires one foot on the brake and one on the gas HEY to keep running.Than,poof,problems vanish . When its hot out the already rough idle gets worse. When at speed the engine purrs like a kitten but when i just went over the grapevine ,hills that i can do at 70 I did at 55!my costco code reader produced the codes po300,301,303,(random misfires),and po171 ,(too lean bank one).My best uneducated guess would be the fuel injector o-rings. Any help would be greatly appreciated.
     
  2. Aug 3, 2010 at 6:10 AM
    #2
    skytower

    skytower Well-Known Member

    Joined:
    Jun 7, 2010
    Member:
    #38505
    Messages:
    3,228
    Gender:
    Male
    First Name:
    Dave
    virginia
    Vehicle:
    08 Tacoma 4x4
    Hitch and wiring, aux back-up light, rear strobe lights, radio and underseat sub.
    Time to check your fuel pressure. There's a check ball on the fuel sender that keeps pressure on the line after shut down. Sounds like its stuck and causing a restriction.
     
To Top