1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

engine trouble

Discussion in '1st Gen. Tacomas (1995-2004)' started by b_martin, May 8, 2010.

  1. May 8, 2010 at 2:09 PM
    #1
    b_martin

    b_martin [OP] New Member

    Joined:
    May 8, 2010
    Member:
    #36761
    Messages:
    2
    Gender:
    Male
    First Name:
    Brandon
    Phoenix/Prescott
    Vehicle:
    2001 Prerunner double cab
    01 v6 prerunner tacoma double cab automatic. everytime i pick up speed, the entire engine acts like it about to fall out. i feels like the engine is misfiring. engine light comes on and says that clinder 3 is misfiring. it acts fine if i put the tranny in park. and rev it. i replaced the spark plugs and it ran great for a trip a hour away and on my way back about 20 minutes from my house it started it again, and does it everytime now. the the truck its self has 175000 miles.I love the truck but i don't know if i love it enough to put in a brand new engine, with that many miles. if you have anything i should try let me know! knightriderbrandon-spam@hotmail.com or on here.
     
  2. May 8, 2010 at 2:44 PM
    #2
    98lowflyingtacoma

    98lowflyingtacoma Well-Known Member

    Joined:
    Dec 7, 2009
    Member:
    #27198
    Messages:
    54
    Gender:
    Male
    Phoenix
    Vehicle:
    1998 Tacoma Prerunner
    maybe check your vacuum lines... there are only so many places really to check.
    Fuel and delivery
    Spark and delivery

    Beyond that its tricky. If you are having it during an acceleration, may be part of something else. Is it Automatic? If not then disregard vacuum
     
  3. May 8, 2010 at 4:55 PM
    #3
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,153
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Can you post the code you are getting?
     
To Top