1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Engine won't high idle at start up

Discussion in '1st Gen. Tacomas (1995-2004)' started by 96 tacomaPtown, Jan 6, 2012.

  1. Jan 6, 2012 at 5:59 PM
    #1
    96 tacomaPtown

    96 tacomaPtown [OP] Well-Known Member

    Joined:
    Aug 28, 2009
    Member:
    #21929
    Messages:
    65
    Gender:
    Male
    First Name:
    Bryan
    Oregon
    Vehicle:
    96 ext cab 4x4 taco
    3 inch spacer lift,pro comp addaleaf, 1 inch diff drop kyb shock/struts, Lc engineering header, stock muffler, hollowed cat, 2 1/4 exhaust, o2simulator , 31 10.50 15 wranglers on stock. Hella 500 headlamps, bug gaurd, vent visors, bed caps, bed liner, Volant cai intake.
    4x4 2.7 liter tacoma. Everytime I Start my truck up warm or cold out it starts up lugs down like its gonna die then idles as if it is already warm. sometimes if i turn it off and start it up again it doesnt start up hesitates i give it gas and it starts up. it is acting like a cold blooded carbeurated ford in negative 10 weather. it does not go on high idle. I cleaned the air filter made sure whole intake was tight. cleaned vaccum valves and sensors. replace alot of vaccuum hoses and evap hoses. I have been fighting this for alon time it has a header a hollowed cat, intake, oxygen sensor simulator. i took the computer 15amp fuse out a week a go to see if it would relearn itself . no check engine light is or and noone can diagnose it with out a light. hesitates at accelloration a little and while speeding up to 50mph. i get 15miles per gallon... i used to get 20-21 it started doing this when i moved to 500 ft elevation from 1500. it didnt start till after a year or so of all the modifications. Been tempted to trade it off cause it is so agravating would like some insight please....
     
  2. Jan 6, 2012 at 6:03 PM
    #2
    TacoMX

    TacoMX TW's Official anti body-lift pundit

    Joined:
    Aug 24, 2011
    Member:
    #62240
    Messages:
    4,831
    Gender:
    Male
    First Name:
    Jonathan
    Deltona, Florida
    Vehicle:
    '13 Tacoma TRD Sport DCLB 4x4
    stock.....for now...
    clean the Throttle body and the idle air control valve.
     
  3. Jan 6, 2012 at 6:04 PM
    #3
    TACOMABOSS

    TACOMABOSS Well-Known Member

    Joined:
    Jul 7, 2011
    Member:
    #59499
    Messages:
    4,310
    Gender:
    Male
    Vehicle:
    96 SR5 4x4
    Bilstein 5100s, Toytec AAL, Deck plate mod, Hella 500ff's, Sportsman Camo seat covers, Total Chaos 1" diff drop, JVC stereo, Painted bumpers and grille, Custom grille insert, HID projectors, Black spray paint
    im not positive on this but i dont think 4 bangers high idle when cold. i know they dont on an 04 4 banger
    edit: unless it did it before
     
  4. Jan 6, 2012 at 6:08 PM
    #4
    96 tacomaPtown

    96 tacomaPtown [OP] Well-Known Member

    Joined:
    Aug 28, 2009
    Member:
    #21929
    Messages:
    65
    Gender:
    Male
    First Name:
    Bryan
    Oregon
    Vehicle:
    96 ext cab 4x4 taco
    3 inch spacer lift,pro comp addaleaf, 1 inch diff drop kyb shock/struts, Lc engineering header, stock muffler, hollowed cat, 2 1/4 exhaust, o2simulator , 31 10.50 15 wranglers on stock. Hella 500 headlamps, bug gaurd, vent visors, bed caps, bed liner, Volant cai intake.
    it usually brings it up to like 1000-1200 rpm but now it stays between 500-750 at start up. when its warm it brings it down of course. ill try cleaning my throttle body i know its difficult to tear everything down but might be best. i did just try spraying it with out taking it off but carbon kept comming out after each spray and never seemed very clean
     
  5. Jan 6, 2012 at 6:10 PM
    #5
    TACOMABOSS

    TACOMABOSS Well-Known Member

    Joined:
    Jul 7, 2011
    Member:
    #59499
    Messages:
    4,310
    Gender:
    Male
    Vehicle:
    96 SR5 4x4
    Bilstein 5100s, Toytec AAL, Deck plate mod, Hella 500ff's, Sportsman Camo seat covers, Total Chaos 1" diff drop, JVC stereo, Painted bumpers and grille, Custom grille insert, HID projectors, Black spray paint
    so it did idle high before. thats interesting. maybe check the cables going to the throttle body as well
     
  6. Jan 6, 2012 at 6:12 PM
    #6
    96 tacomaPtown

    96 tacomaPtown [OP] Well-Known Member

    Joined:
    Aug 28, 2009
    Member:
    #21929
    Messages:
    65
    Gender:
    Male
    First Name:
    Bryan
    Oregon
    Vehicle:
    96 ext cab 4x4 taco
    3 inch spacer lift,pro comp addaleaf, 1 inch diff drop kyb shock/struts, Lc engineering header, stock muffler, hollowed cat, 2 1/4 exhaust, o2simulator , 31 10.50 15 wranglers on stock. Hella 500 headlamps, bug gaurd, vent visors, bed caps, bed liner, Volant cai intake.
    throttle cables? or check vaccuum lines?
     
  7. Jan 6, 2012 at 6:13 PM
    #7
    TACOMABOSS

    TACOMABOSS Well-Known Member

    Joined:
    Jul 7, 2011
    Member:
    #59499
    Messages:
    4,310
    Gender:
    Male
    Vehicle:
    96 SR5 4x4
    Bilstein 5100s, Toytec AAL, Deck plate mod, Hella 500ff's, Sportsman Camo seat covers, Total Chaos 1" diff drop, JVC stereo, Painted bumpers and grille, Custom grille insert, HID projectors, Black spray paint
    throttle cables
     
  8. Jan 6, 2012 at 6:19 PM
    #8
    96 tacomaPtown

    96 tacomaPtown [OP] Well-Known Member

    Joined:
    Aug 28, 2009
    Member:
    #21929
    Messages:
    65
    Gender:
    Male
    First Name:
    Bryan
    Oregon
    Vehicle:
    96 ext cab 4x4 taco
    3 inch spacer lift,pro comp addaleaf, 1 inch diff drop kyb shock/struts, Lc engineering header, stock muffler, hollowed cat, 2 1/4 exhaust, o2simulator , 31 10.50 15 wranglers on stock. Hella 500 headlamps, bug gaurd, vent visors, bed caps, bed liner, Volant cai intake.
    ill try that and notify you when i get results
     
  9. Jan 6, 2012 at 9:06 PM
    #9
    TacoMX

    TacoMX TW's Official anti body-lift pundit

    Joined:
    Aug 24, 2011
    Member:
    #62240
    Messages:
    4,831
    Gender:
    Male
    First Name:
    Jonathan
    Deltona, Florida
    Vehicle:
    '13 Tacoma TRD Sport DCLB 4x4
    stock.....for now...
    Its actually pretty easy. Go get another TB gasket from autozone before you do it though. The original one will fall apart.

    The only real way to clean your TB is by taking it off the truck.
     
  10. Jan 10, 2012 at 5:40 PM
    #10
    96 tacomaPtown

    96 tacomaPtown [OP] Well-Known Member

    Joined:
    Aug 28, 2009
    Member:
    #21929
    Messages:
    65
    Gender:
    Male
    First Name:
    Bryan
    Oregon
    Vehicle:
    96 ext cab 4x4 taco
    3 inch spacer lift,pro comp addaleaf, 1 inch diff drop kyb shock/struts, Lc engineering header, stock muffler, hollowed cat, 2 1/4 exhaust, o2simulator , 31 10.50 15 wranglers on stock. Hella 500 headlamps, bug gaurd, vent visors, bed caps, bed liner, Volant cai intake.
    I went and bought the gasket today and found it was considerably cheap. only $1.76 and 3.99 for cleaner. i took intake off hoses and puled them out of the way. i would of taken it off completely but It is dark and i finally got cash to buy the supplies. I looked inside and found thick chunks of black gunk.my guess it is from the egr valve connected to the throttle body.. I couldnt just spray it away so I took a tooth brush to wipe it out and it was stuck on so I took a screw driver and hasd to scrape itout. It looked like it was blocking the EGR port and TBS port behind the butterfly. when I have the weekend. I am going to take it off all the way and do it right. I put it all back together started it up well turned the key till it started and gave it a lil gas to rid of all the cleaner and it purrred like a kitten. hesitated alil when I drove it but kept in second at 35mph to burn any excess crap pushed down the intake. at 249000 miles cant be that bad to just need a lil intake cleaning.
    I will keep you updated if it rids of the problem entirely. should find out when I start it up in the morning if it idles fine.
     
  11. Jan 12, 2012 at 5:28 PM
    #11
    96 tacomaPtown

    96 tacomaPtown [OP] Well-Known Member

    Joined:
    Aug 28, 2009
    Member:
    #21929
    Messages:
    65
    Gender:
    Male
    First Name:
    Bryan
    Oregon
    Vehicle:
    96 ext cab 4x4 taco
    3 inch spacer lift,pro comp addaleaf, 1 inch diff drop kyb shock/struts, Lc engineering header, stock muffler, hollowed cat, 2 1/4 exhaust, o2simulator , 31 10.50 15 wranglers on stock. Hella 500 headlamps, bug gaurd, vent visors, bed caps, bed liner, Volant cai intake.
    well I went to start my truck this morning and it was 17 degrees I started my truck it died instantly, tried again died again, tried again and gave it gas it ran like crap but ran things that make you go hmmmm. ill try the whole thing this weekend see if things are clogged.
     
  12. Jan 12, 2012 at 9:21 PM
    #12
    Buggys3sgte

    Buggys3sgte Well-Known Member

    Joined:
    Mar 3, 2011
    Member:
    #52274
    Messages:
    64
    Gender:
    Male
    First Name:
    !@$*
    Psycho state of AZ
    Vehicle:
    97 BUDGET Taco
    Newly rearranged front end, sick Hurst shifter yo gives it lightning fast shifts, thats it more to come.
    Sounds like your CSI or your CSI switch isn't working properly.
     
  13. Jan 12, 2012 at 9:35 PM
    #13
    Bosmob

    Bosmob Well-Known Member

    Joined:
    Jun 9, 2011
    Member:
    #58017
    Messages:
    380
    Gender:
    Male
    First Name:
    Kevin
    San Diego, CA
    Vehicle:
    '11 Access Cab SR5 I4 4AT
    Fat Bob's 2.75" front spacers Magnaflow Muffler Doug Thorley Header ImMrYo Mirror Bracket
    That's what I'm guessing too.

    I had a 93 4Runner with that same issue and after replacing the CSI, it returned to normal.
     
  14. Jan 13, 2012 at 1:50 PM
    #14
    96 tacomaPtown

    96 tacomaPtown [OP] Well-Known Member

    Joined:
    Aug 28, 2009
    Member:
    #21929
    Messages:
    65
    Gender:
    Male
    First Name:
    Bryan
    Oregon
    Vehicle:
    96 ext cab 4x4 taco
    3 inch spacer lift,pro comp addaleaf, 1 inch diff drop kyb shock/struts, Lc engineering header, stock muffler, hollowed cat, 2 1/4 exhaust, o2simulator , 31 10.50 15 wranglers on stock. Hella 500 headlamps, bug gaurd, vent visors, bed caps, bed liner, Volant cai intake.
    what exactly is the csi? Ive been reading the Haynes repair manual and after looking at all the abbreviations my heads spinning.
     
  15. Jan 13, 2012 at 10:39 PM
    #15
    Buggys3sgte

    Buggys3sgte Well-Known Member

    Joined:
    Mar 3, 2011
    Member:
    #52274
    Messages:
    64
    Gender:
    Male
    First Name:
    !@$*
    Psycho state of AZ
    Vehicle:
    97 BUDGET Taco
    Newly rearranged front end, sick Hurst shifter yo gives it lightning fast shifts, thats it more to come.
    Cold Start Injector or the switch that triggers the injector.
     
  16. Jan 20, 2012 at 7:55 PM
    #16
    96 tacomaPtown

    96 tacomaPtown [OP] Well-Known Member

    Joined:
    Aug 28, 2009
    Member:
    #21929
    Messages:
    65
    Gender:
    Male
    First Name:
    Bryan
    Oregon
    Vehicle:
    96 ext cab 4x4 taco
    3 inch spacer lift,pro comp addaleaf, 1 inch diff drop kyb shock/struts, Lc engineering header, stock muffler, hollowed cat, 2 1/4 exhaust, o2simulator , 31 10.50 15 wranglers on stock. Hella 500 headlamps, bug gaurd, vent visors, bed caps, bed liner, Volant cai intake.
    posted some pics on my profile of befores and afters forgot to get after closeups of intake and throttle body but you can tell there was alot of gunk. it seemed to help a little bit in the morning but still has moments that it stumbles.
     
  17. Sep 14, 2012 at 12:30 AM
    #17
    96 tacomaPtown

    96 tacomaPtown [OP] Well-Known Member

    Joined:
    Aug 28, 2009
    Member:
    #21929
    Messages:
    65
    Gender:
    Male
    First Name:
    Bryan
    Oregon
    Vehicle:
    96 ext cab 4x4 taco
    3 inch spacer lift,pro comp addaleaf, 1 inch diff drop kyb shock/struts, Lc engineering header, stock muffler, hollowed cat, 2 1/4 exhaust, o2simulator , 31 10.50 15 wranglers on stock. Hella 500 headlamps, bug gaurd, vent visors, bed caps, bed liner, Volant cai intake.
    found out the exhaust gases comming to my egr valve had clogged the line to the diaphram. had tried previously to clean it but it was stubborn. had a chance to takeit off again and dissassemble it by running very hot water on it and using dishsoap to loosen the tube to pull it out. it was solid carbon and i had to use a drill to clean it out the run a piece of wire through it to clean any excess material out. ive prob only driven it 5 miles. but ive done that clean the filter oil change rear end seals bearings brakes, and new oxygen sensors. its running alot better now , im just waiting to see what the effects will be after running a few tanks through it and see the change in mileage.
     
To Top