1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Excessive Blow-by from 2.7L

Discussion in '4 Cylinder' started by Tooner, Dec 5, 2008.

  1. Dec 5, 2008 at 12:20 PM
    #1
    Tooner

    Tooner [OP] New Member

    Joined:
    Dec 5, 2008
    Member:
    #11303
    Messages:
    2
    Gender:
    Male
    Elk Grove, CA
    Vehicle:
    04 PreRunner 2.7 L
    I have a 2004 Tacoma PreRunner 4x2 with a 2.7 L engine and 55k miles. It seems to lack power so I did a compression check which turned out OK, but when I did a leak down test, it had 50% leakage in each cylinder. This is way above the normal range of 5% to 15%. I could hear air leaking from the oil fill hole in the valve cover. I couldn’t hear any leakage in the exhaust pipe or the intake manifold. When I take the oil fill cap off while the engine is running (hot or cold), air blows out. So much blows out that an oil mist sprays out and I can feel the air (and droplets of oil) from 2' above the hole. Does anyone else have a 2.7 L Toyota that does this? It does 0 to 60 mph in about 12.5 sec. Is that about right for this engine?
    Thanks in advance for any help!
     
  2. Dec 5, 2008 at 12:25 PM
    #2
    tacoskim

    tacoskim Tuned By Gadget

    Joined:
    Mar 13, 2008
    Member:
    #5252
    Messages:
    2,395
    Gender:
    Male
    Los Angeles, CA
    Vehicle:
    09 TRD 4x4 Pyrite Mica
    Stock
    welcome to TW! sorry bout ur problems, that doesnt sound good. did u just purchase the truck?
     
  3. Dec 5, 2008 at 1:44 PM
    #3
    ubermx5

    ubermx5 Well-Known Member

    Joined:
    May 21, 2008
    Member:
    #6783
    Messages:
    264
    Santa Clara CA
    Vehicle:
    98 2.4 5 speed
    K&N Air filter
    Unless you are a good tech.

    i would take it to a trust worthy shop and have it tested not fixed.
    Once 2 people have looked at then tackle the issue.

    I really hope it is simple...
     
  4. Dec 6, 2008 at 3:47 PM
    #4
    Tooner

    Tooner [OP] New Member

    Joined:
    Dec 5, 2008
    Member:
    #11303
    Messages:
    2
    Gender:
    Male
    Elk Grove, CA
    Vehicle:
    04 PreRunner 2.7 L
    I've been working on cars for many years and have done leak down tests before. Just to make sure the guage was working correctly, I did a leak down test on my Camaro's 350 Chevy engine and it had less than 10% leakage.

    Has anyone with a similar Tacoma checked their 0-60 time?

    Thanks
     
  5. Dec 6, 2008 at 5:19 PM
    #5
    AUDITECH

    AUDITECH Carolina Alliance: LAZY DIVISION

    Joined:
    Feb 10, 2007
    Member:
    #875
    Messages:
    840
    charlotte nc
    Vehicle:
    07 double cab prerunner
    none
    sounds like it might be the rings if its coming out of the oil filler. but with 50% in each cylinder with a good compresion check. i would do the leak down again. dump some oil in the spark plug hole just a little before the leak down test
     
  6. Dec 6, 2008 at 6:49 PM
    #6
    darkturtleninja

    darkturtleninja 9th level dungeon master

    Joined:
    Dec 3, 2008
    Member:
    #11243
    Messages:
    265
    Gender:
    Male
    Illinois
    Vehicle:
    95 2.7 3rz turd
    cold air intake, body lift, suspension lift.
    ive got 34'' tires and a 5 speed and my 0-60 is faster than that
     
To Top