1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

exhaust rattle...2.7L

Discussion in '1st Gen. Tacomas' started by brelandt, Aug 27, 2010.

  1. Aug 27, 2010 at 7:46 PM
    #1
    brelandt

    brelandt [OP] Well-Known Member

    Joined:
    Jul 21, 2009
    Member:
    #19979
    Messages:
    460
    Gender:
    Male
    First Name:
    Terry
    Dublin, CA
    Vehicle:
    04 Prerunner reg cab SR5
    3" lift front and back
    I have a very loud exhaust rattle coming from under the cab after I put my automatic tranny in gear. Doesn't matter if it's "drive" or "reverse". Seems to happen mostly when the engine is cold but will still do it when warm as well just not as often. Also goes away when I accelerate.
    Is there a "common" part that is causing this? Plan on getting underneath to check it out in the morning but just wanted to see if there was something I ought to be looking at first before I waste my time looking in the wrong areas!
     
  2. Aug 27, 2010 at 8:47 PM
    #2
    Digiratus

    Digiratus Adventurer

    Joined:
    Mar 26, 2010
    Member:
    #34006
    Messages:
    10,683
    Gender:
    Male
    First Name:
    Mike
    the Pacific Northwest, Exploring
    Vehicle:
    The RedHead
    King ET Coilovers Camburg Uniball UCAs Alcan 8-Leaf Rear Spring Packs Fox 2.0 Resi Rear Shocks FrankenFab Rear Shock Relocate Trail Gear U-bolt Flip Toytec 1" Extended Shackle 4.88 Nitro Gears ARB Front Locker OBA ARB Twin Comp 15x8 D Window Steelies 33" BFG KM2s Limited Edition Elite Front Bumper Smittybilt X2O 10K Winch PIAA 510 SMR Fog Lights Lightforce 170s Badland Sliders FrankenFab Tire Carrier Swingout bumper w/kitchen BudBuilt Front & Bellypan Skids BAMF Rear Diff Skid Whynter 65 qt. Fridge/Freezer CVT Mt Bachelor RTT Badland Custom Bed Rack GM 140 amp alternator Optima Yellow Top battery Magnaflow 18" Muffler Braided Steel Brake Lines K&N Drop-in air filter ScanGauge II OBDII Scanner Uniden 520xl CB radio 3’ Firestik Adjustable tip antenna Pioneer DEH-P9400BH HU Alpine Amps & Type R components (F) and coaxials (R) Wet Okole Seat Covers Weathertech Digital Liners Deck Plate Mod 1” Diff Drop Carrier Bearing Drop
    Check the heat shield above your cats. My v6 has 2 catalytic converters. Not sure what the 2.7Ls have.
     
  3. Aug 27, 2010 at 8:50 PM
    #3
    steve o 77

    steve o 77 braaap

    Joined:
    Nov 29, 2009
    Member:
    #26726
    Messages:
    19,947
    Gender:
    Male
    First Name:
    Steven
    In a corn field, OH
    Vehicle:
    2001 4x4 5Spd Xtra Cab V6
    265/75/16 BFG A/T's, OME 881's, Wheelers 5 leaf pack, 5100's, Home Made Sliders
    either the heat shield or the cat is actually bad, but I would think the CEL would be on it the cat was bad.
     
  4. Aug 27, 2010 at 9:13 PM
    #4
    brelandt

    brelandt [OP] Well-Known Member

    Joined:
    Jul 21, 2009
    Member:
    #19979
    Messages:
    460
    Gender:
    Male
    First Name:
    Terry
    Dublin, CA
    Vehicle:
    04 Prerunner reg cab SR5
    3" lift front and back
    well i hope it's not the cat. I only have 68K on it. LOL I am throwing a code for the O2 bank 1 sensor, but it's been on for 3 years now!
     
  5. Aug 27, 2010 at 9:33 PM
    #5
    907taco

    907taco Alaskan Assassin

    Joined:
    Mar 27, 2010
    Member:
    #34091
    Messages:
    1,364
    Gender:
    Male
    First Name:
    Bobby
    Alaska
    Vehicle:
    2010 BlackSandPearl 4x4
    ultimate lift kit ( toytec ) ome dakar leaf pack , w/ extended length billies, LR uca's, Pro comp 7089s, KM2's 285 70 17, neoprene seat covers, weather techs, CBI sliders w/kickout, URD ss, cab mount chop, VHT night shade tint>tails,3rd B-light. Debadged. Grillecraft grille, rear diff breather mod. CBI Moab front bumper, warn M8000 winch, HID kragens 7", Hella's micro fogs. retrofit headlights HIDS, LED solutions maps/license! 886 back up light mod,
    i bought my 2010 in march, i noticed the same rattle the 1st time i started it after bringing it back home, goes away after it it warms up..... should i worry about that? maybe i should look at the heat shield when i get back home.
     
  6. Aug 28, 2010 at 9:32 AM
    #6
    brelandt

    brelandt [OP] Well-Known Member

    Joined:
    Jul 21, 2009
    Member:
    #19979
    Messages:
    460
    Gender:
    Male
    First Name:
    Terry
    Dublin, CA
    Vehicle:
    04 Prerunner reg cab SR5
    3" lift front and back
    well, after thinking back to when I bought mine in jan 2004 I remmeber it doing the samething then and the dealer fixed it. Just not sure what they fixed or even how they fixed it. My only concern then was that the noise was gone.
    I guess this is another one of those, "Tacoma" issues that most of us just live with like the rattle under the dash on the passenger side! and the coin tray always opening when you hit a rough patch of road.....LOL
     
  7. Aug 29, 2010 at 2:57 PM
    #7
    brelandt

    brelandt [OP] Well-Known Member

    Joined:
    Jul 21, 2009
    Member:
    #19979
    Messages:
    460
    Gender:
    Male
    First Name:
    Terry
    Dublin, CA
    Vehicle:
    04 Prerunner reg cab SR5
    3" lift front and back
    ok went under the truck and found the issue. Seems that there is a bracket on the bell housing that extends to the pipe and there is a round clamp with a single bolt holding the 2 together. my clamp loosened up enough that it slipped off of the bracket and was resting on the O2 sensor.
    Fix was easy. Just loosen the bolt a few turns place it back on the bracket and then stick a 12mm socket and extension between the top of the frame and the wheelwell where the small rubber splash shield is and tighten the hell out of it.
     
  8. Aug 29, 2010 at 3:01 PM
    #8
    08pretaco

    08pretaco Almost there

    Joined:
    Sep 26, 2008
    Member:
    #9502
    Messages:
    9,160
    Gender:
    Male
    First Name:
    Oliver
    az
    Vehicle:
    2014 Tundra 4x4 CM 5.7L SR5
    AFE pro dry s, Husky X-act Contour
    I used to have a rattle, it was my exhaust banging on my shackle/hangar
     
To Top