1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

External mag issue with Savage Axis xp. help?

Discussion in 'Guns & Hunting' started by 808Raider, Mar 4, 2012.

  1. Mar 4, 2012 at 5:16 PM
    #1
    808Raider

    808Raider [OP] State of Mind

    Joined:
    Nov 22, 2009
    Member:
    #26356
    Messages:
    176
    Gender:
    Male
    HAWAI'I
    Vehicle:
    '10 PreRunner SR5 AC
    BHLM, Debadged, Black Billet Grille, Tinted, Nerf Bars, Mudflaps Removed, AFE Pro Dry-S Air Filter, Secondary Air Filter Removed, Sock Decals, Bilstein 5100s @1.75, AAL TSB, Pro Comp 7089s, 265/75/16 Firestone Destination A/Ts
    just got a new savage axis xp 30-06 and took it out to the range today to sight it in. it has the 4+1 external mag which when put in it clips in with the clip towards the barrell and away from the stock. after every time i would fire a round the side of the mag closer the stock would pop out a little bit so it wouldnt reload a new round without me clicking the mag back in. frustrating and I am by no means a firearms expert so im not sure whats wrong but i know it probably shouldn't do that on a brand new rifle. tried to jam it in there but its in there flush where its supposed to go. it would still pop out every time i would fire. heres a pic too which shows what the mag looks like after fired. maybe you guys know what could be the issue? bad mag? [​IMG]
     
  2. Mar 4, 2012 at 5:32 PM
    #2
    Alderleet

    Alderleet Ace of Spades

    Joined:
    Oct 16, 2011
    Member:
    #65324
    Messages:
    1,134
    Gender:
    Male
    First Name:
    Nick
    Salty Hell
    Vehicle:
    '00 Acc Cab TRD 4x4
    Pull the rifle from its stock and check the mag well.

    Im wagering a guess that the mag retaining tab is bent a little more out that need be, resulting incomplete hold.

    If it locks cleanly when its outside the stock, then its a issue with the stock putting pressure on box and retaining assembly.
     
  3. Mar 5, 2012 at 12:46 PM
    #3
    nomad_archer

    nomad_archer Well-Known Member

    Joined:
    Apr 14, 2010
    Member:
    #35243
    Messages:
    513
    Gender:
    Male
    First Name:
    Trevor
    Brickerville (Lititz), PA
    Vehicle:
    08 DC Tacoma V6 SR5
    Try putting the clip in with the back (towards the trigger) all the way in then rocking the clip forward until it clicks. With my experience with savages the back goes in first then the front and everything locks up just right. If that doesnt work then call savage they should be able to walk you through trouble shooting it.

    If you feel inclided to take it apart follow the instructions that came with the gun or go online and get the user manual. Also put a little bit of duct tap one your tools it will keep from scratching the finish of the gun.
     
To Top