1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

extreme steering problems

Discussion in 'Suspension' started by TBLOCK09, Dec 30, 2009.

  1. Dec 30, 2009 at 10:14 AM
    #1
    TBLOCK09

    TBLOCK09 [OP] Member

    Joined:
    Feb 15, 2009
    Member:
    #13647
    Messages:
    20
    Gender:
    Male
    San Diego
    Vehicle:
    05 5Lug
    Total chaos lt in front , icon aal in back, Hannemann front fenders ( painted stock white and painted the roof black at same time), window tint thats not to dark (i had to get the last pair taken off they had to find a ticket for something...)Afe cold air intake, Alpine 102 deck, kenwood eXcelon KFC-X1730P componets, alpine s-12 shallow sub behind the seat pushed by a rockford fosgate mono 400 wt amp, Grillcraft black grill (re powdered flat black), and just installed the LCE header.
    any allignment shops in the southbay?
     
  2. Dec 30, 2009 at 10:31 AM
    #2
    jr114

    jr114 Well-Known Member

    Joined:
    Nov 18, 2009
    Member:
    #26147
    Messages:
    1,176
    Gender:
    Male
    First Name:
    Jon
    SoCal
    Vehicle:
    Truck
    Icon Ext travel CO, Icon tubular uniball UCAs, Maxtrac Spindles, Icon RR rear w 2"aal.
    Check with downsouthmotorsports if you havent already. I was under the impression that the long travel kits only fit onto 6 lug trucks? I just checked tc's website and I didnt see anything right off the bat that specified 6 lug only. The only thing that I saw was that it said "NOTE:
    THIS KIT WILL NOT WORK WITH VEHICLES EQUIPPED WITH 1.25" THICK TRD BRAKE ROTORS."

    So not sure if your running those or if this helps, but Im sure someone will chime in. PM bajamoon or mjp2 I know that they are running lt but not sure what kits maybe they can help better

     
  3. Dec 30, 2009 at 11:12 AM
    #3
    TBLOCK09

    TBLOCK09 [OP] Member

    Joined:
    Feb 15, 2009
    Member:
    #13647
    Messages:
    20
    Gender:
    Male
    San Diego
    Vehicle:
    05 5Lug
    Total chaos lt in front , icon aal in back, Hannemann front fenders ( painted stock white and painted the roof black at same time), window tint thats not to dark (i had to get the last pair taken off they had to find a ticket for something...)Afe cold air intake, Alpine 102 deck, kenwood eXcelon KFC-X1730P componets, alpine s-12 shallow sub behind the seat pushed by a rockford fosgate mono 400 wt amp, Grillcraft black grill (re powdered flat black), and just installed the LCE header.
    just checked in with downsouth motorsports. they only work on shocks, but the guy said he would call up a couple buddies to see what he can do. thanks for the recomendation.
    but as far as tc, my kit was made for the 5 lug (what it said on the box)
     
  4. Dec 30, 2009 at 11:18 AM
    #4
    jr114

    jr114 Well-Known Member

    Joined:
    Nov 18, 2009
    Member:
    #26147
    Messages:
    1,176
    Gender:
    Male
    First Name:
    Jon
    SoCal
    Vehicle:
    Truck
    Icon Ext travel CO, Icon tubular uniball UCAs, Maxtrac Spindles, Icon RR rear w 2"aal.

    cool glad someone is getting you some help. thanks for enlightening me on the 5 lug kit. wasnt aware of one. good luck and keep us posted
     
  5. Dec 30, 2009 at 12:29 PM
    #5
    Padilla1880

    Padilla1880 "Let's Ride!"

    Joined:
    May 18, 2009
    Member:
    #17365
    Messages:
    1,167
    Gender:
    Male
    First Name:
    Daniel
    Temecula, CA
    Vehicle:
    05 TRD OffRoad V6 SR5 PreRunner
  6. Dec 30, 2009 at 12:33 PM
    #6
    mjp2

    mjp2 Living vicariously though myself Moderator

    Joined:
    Feb 16, 2007
    Member:
    #924
    Messages:
    17,765
    Gender:
    Male
    First Name:
    Milton Juevos Portimous II
    NJ
    Vehicle:
    '06 TRD Access Cab, v6, 6-speed
    Scaffolding and a painted grill
    Still waiting on pictures of the setup and breakage. Please post either in this thread or your other thread and we'll see if this can be figured out. If it's breaking in the driveway it's gotta be something obvious.
     
  7. Dec 30, 2009 at 12:38 PM
    #7
    SC4333

    SC4333 Well-Known Member

    Joined:
    Dec 9, 2008
    Member:
    #11412
    Messages:
    2,190
    Gender:
    Male
    First Name:
    Grant
    San Antonio, TX
    Vehicle:
    2016 TRD Off-Road 4x4 DCSB - Super White
    SOLD!


    I'd agree. Something does sound right here.


    FWIW, I've always wanted to buy a little 5 lugger and slap the TC kit on it. :D
     
  8. Jan 22, 2010 at 3:15 PM
    #8
    TBLOCK09

    TBLOCK09 [OP] Member

    Joined:
    Feb 15, 2009
    Member:
    #13647
    Messages:
    20
    Gender:
    Male
    San Diego
    Vehicle:
    05 5Lug
    Total chaos lt in front , icon aal in back, Hannemann front fenders ( painted stock white and painted the roof black at same time), window tint thats not to dark (i had to get the last pair taken off they had to find a ticket for something...)Afe cold air intake, Alpine 102 deck, kenwood eXcelon KFC-X1730P componets, alpine s-12 shallow sub behind the seat pushed by a rockford fosgate mono 400 wt amp, Grillcraft black grill (re powdered flat black), and just installed the LCE header.
    ok it took awhile to get back on, house got broken into and just got a new pc. i ended up taking the truck into orw. expensive but finally got it all figured out. pretty much everything on the truck was wrong. fox 2.0 w resi in front with 600 lb coils. the lift calls for 2.5 with 400 lb coils. the tie rods were cut, welded back, reienforced and were installed on opposite sides. the truck is also sitting on 16x10 rims which are to wide and have the wrong offset. to try and cover up this mess the original shop owner continually fed me lies about whats even on the truck. not what i ordered and not whats on the receit. they just kept adding on parts to try and bandaid it up untill i left them alone. took it back 5 times with an open tab, they tried giving me brakes by not charging labor and giving me cars to drive while they scratched there heads on what to do next. and yes i still suposibly owe them money for the stabalizers 2 broken tie rods and used rack and pinion that i needed so bad because the original has "gone bad due to a broken seal that happens over time." but thats not it the shocks in the back were 3 in too long. which i've noticed since the beggining but " they are tc recommended shock length made expand when the truck gets air" or some BS like that is what he said.

    you get what you pay for, my first lesson.

    its now set up right driving like its new. my new bill will soon be covered once my attourney gets a hold of the previous shop
     
  9. Jan 22, 2010 at 4:00 PM
    #9
    Alaskaflyer

    Alaskaflyer My other ride Hovers

    Joined:
    Dec 20, 2008
    Member:
    #11768
    Messages:
    407
    Gender:
    Male
    Cape Cod, MA
    Vehicle:
    08 Prerunner DC TRD Off Road
    OME 885 AAL, 2.5* shim, Light Racing UCA's. BFG AT KO 285/75/16, Spidertrax spacers, OME Shocks up front, Bilstein 5100 Shocks in back.
    ORW did all the work on my Jeep Cherokee I lifted many years ago, no complaints with thier work and service. Glad you got everything straightend out!
     
  10. Jan 22, 2010 at 7:37 PM
    #10
    pataco

    pataco Well-Known Member

    Joined:
    Jan 1, 2009
    Member:
    #12092
    Messages:
    2,070
    Gender:
    Male
    Down by the lake
    Vehicle:
    05 4x4 trd dc white
    FOX 2.0 RESIS,LRUCAS,BILLY 5100S ON THE REAR.MAGNAFLOW 11264,COLOR MATCHED GRILL,YELLOW FOG MOD.OVER HEAD DVD,FEDERAL COURAGIA M/T
    wow,glad u got it fixed up.good luck man.
     
To Top