1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Factory fog light switch with Hella 500s

Discussion in '2nd Gen. Tacomas (2005-2015)' started by sfcadams, Dec 30, 2011.

  1. Dec 31, 2011 at 7:10 AM
    #21
    sfcadams

    sfcadams [OP] Retired Senior NCO

    Joined:
    Aug 13, 2011
    Member:
    #61645
    Messages:
    1,441
    Gender:
    Male
    First Name:
    Dan
    Elizabeth, Indiana
    Vehicle:
    2011 TRD Off Road DCSB Prerunner Skeewped
    So if I connect the red wire (+) from the relay to the + post on the battery and the blue wire (-) from the relay to the + post of the battery, along with the yellow wire (trigger wire from relay) to one wire of the new factory switch and another wire from the factory switch going to a ground, it should operate as a normal push on/push off switch?
     
  2. Dec 31, 2011 at 9:08 AM
    #22
    sfcadams

    sfcadams [OP] Retired Senior NCO

    Joined:
    Aug 13, 2011
    Member:
    #61645
    Messages:
    1,441
    Gender:
    Male
    First Name:
    Dan
    Elizabeth, Indiana
    Vehicle:
    2011 TRD Off Road DCSB Prerunner Skeewped
    I still can't get the lights to shut off via the toyota switch....

    This is driving me apeshit right now
     
  3. Dec 31, 2011 at 9:17 AM
    #23
    griffin407c

    griffin407c Well-Known Member

    Joined:
    Oct 18, 2009
    Member:
    #24489
    Messages:
    724
    Gender:
    Male
    First Name:
    Ryan
    Upstate NY
    Vehicle:
    '12 DCLB MGM 4x4 Sport w/Entune
    OME 885s on Bilstein 5100s set at 0 with 1/2" plate spacers. OME Dakars with Bilstein 5100 Extended Length Shocks. 16" Pro Comp 7032 wheels wrapped with 285/75-16 Duratracs
    these threads make my head hurt...

    disregard the yellow wire with the diode going to the reverse wire.
    auxreverselights2_c7d738004f3563c91654c16ff7e7ea199cf84e16.jpg

    disregard "DRL". top terminal (4) would be the green wire from my diagram. 2nd terminal down (3) is the yellow "ignition" source wire.
    DRL_switch_f7e3184b1537d3ecd26b2bf72f8f26c7402e92c3.jpg


    foglightswitchwiringdiagram_9c690eba6dffd2719232cacf60f2028f73b5af5b.jpg
     
  4. Dec 31, 2011 at 10:26 AM
    #24
    sfcadams

    sfcadams [OP] Retired Senior NCO

    Joined:
    Aug 13, 2011
    Member:
    #61645
    Messages:
    1,441
    Gender:
    Male
    First Name:
    Dan
    Elizabeth, Indiana
    Vehicle:
    2011 TRD Off Road DCSB Prerunner Skeewped
    I think I found out what the issue is. The switch that is supposed to be the same as the fog light switch in my dash must not be the same. I pulled the factory fog light switch out and hooked it up and everything worked fine and they turned on/off with the switch. Guess the switch I have is not the correct switch, even though it looks like it is.....

    Either that or the switch I got is defective?

    There are 2 different #s on the side of the switch

    Factory has this on it

    15A492
    >ABS< 1

    One I bought has this on it

    15A492
    >ABS< 2

    Other than that, they look the same...

    Anyone else bought a factory fog light switch that can confirm what # is on the side of it?
     
  5. Dec 31, 2011 at 11:48 AM
    #25
    sfcadams

    sfcadams [OP] Retired Senior NCO

    Joined:
    Aug 13, 2011
    Member:
    #61645
    Messages:
    1,441
    Gender:
    Male
    First Name:
    Dan
    Elizabeth, Indiana
    Vehicle:
    2011 TRD Off Road DCSB Prerunner Skeewped
    anyone?
     
  6. Jan 1, 2012 at 4:49 PM
    #26
    sfcadams

    sfcadams [OP] Retired Senior NCO

    Joined:
    Aug 13, 2011
    Member:
    #61645
    Messages:
    1,441
    Gender:
    Male
    First Name:
    Dan
    Elizabeth, Indiana
    Vehicle:
    2011 TRD Off Road DCSB Prerunner Skeewped
  7. Jan 1, 2012 at 6:23 PM
    #27
    GoDeacsWFU23

    GoDeacsWFU23 Well-Known Member

    Joined:
    Jun 9, 2011
    Member:
    #57986
    Messages:
    1,162
    Gender:
    Male
    First Name:
    Jonathan
    Clemmons, NC
    Vehicle:
    2013 Tacoma PreRunner TRD Sport
    I just did this. Give me a sec and I will get you the directions on what to do.
     
  8. Jan 1, 2012 at 6:26 PM
    #28
    GoDeacsWFU23

    GoDeacsWFU23 Well-Known Member

    Joined:
    Jun 9, 2011
    Member:
    #57986
    Messages:
    1,162
    Gender:
    Male
    First Name:
    Jonathan
    Clemmons, NC
    Vehicle:
    2013 Tacoma PreRunner TRD Sport
    [​IMG]

    This pretty much made it idiot proof for me. Took about 30 minutes to complete the install after finding this diagram.
     
  9. Jan 1, 2012 at 6:29 PM
    #29
    GoDeacsWFU23

    GoDeacsWFU23 Well-Known Member

    Joined:
    Jun 9, 2011
    Member:
    #57986
    Messages:
    1,162
    Gender:
    Male
    First Name:
    Jonathan
    Clemmons, NC
    Vehicle:
    2013 Tacoma PreRunner TRD Sport
  10. Jan 1, 2012 at 6:33 PM
    #30
    2008taco

    2008taco Well-Known Member

    Joined:
    Mar 4, 2011
    Member:
    #52323
    Messages:
    2,251
    Gender:
    Male
    First Name:
    chris
    san diego
    The blue wire from the hella relay goes to ground. This is ground for the relay and it will not work correctly if it is not to ground. Red goes to the battery. Black goes to lights. Yellow goes to the switch. The two wires you're looking for on the switch are the blue and the blue with white stripe. The greens (bottom two) are for the switch lighting. I believe the solid blue off the switch should be the one to connect to the yellow.
     
  11. Jan 1, 2012 at 6:57 PM
    #31
    sfcadams

    sfcadams [OP] Retired Senior NCO

    Joined:
    Aug 13, 2011
    Member:
    #61645
    Messages:
    1,441
    Gender:
    Male
    First Name:
    Dan
    Elizabeth, Indiana
    Vehicle:
    2011 TRD Off Road DCSB Prerunner Skeewped
    Thanks for everyone's help on this. I have pretty much came to the conclusion that my switch is bad. I popped the factory fog light switch out of the dash and it operates the lights just fine. The switch I purchased will not shut the lights off. They just stay lit all of the time.

    GoDeacsWFU23,

    Any way you could check the side of your switch and tell me what letters/numbers are on it? The switch I picked up has this on it.

    15A492
    >ABS< 2

    My factory switch has this on it.

    15A492
    >ABS< 1

    Thanks!
     
  12. Jan 8, 2012 at 10:23 AM
    #32
    Faryota

    Faryota Well-Known Member

    Joined:
    Jan 29, 2010
    Member:
    #30291
    Messages:
    561
    Gender:
    Male
    First Name:
    Mic
    Ridgefield, WA.
    Vehicle:
    13, 4x4, long bed, Sport, Debad
    6" BDS lift in front, warn winch, AFE cold air intake & exhaust, Body Armor Rear bumper, Tuffy in bed storage box, DZ bed mat, ARB front bumper & Warn winch w/light kit, Husky floor mats, dash mat,
    Nice write up!
     

Products Discussed in

To Top