1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

FM & Am Signal Amp Amplifier Booster

Discussion in 'Audio & Video' started by harshest, Jan 12, 2009.

  1. Jan 12, 2009 at 5:45 AM
    #1
    harshest

    harshest [OP] I am the Sofa King

    Joined:
    Aug 13, 2008
    Member:
    #8508
    Messages:
    567
    Gender:
    Male
    Michigan
    Vehicle:
    05 PreRunner SR5
    Fog Light On, Hidden Garage Door Opener, Scanguage II, Weathertech Liners, Cig lighter always on, Door buzzer removed from dash- Upcoming: 5100s for front and rear, set fronts to 2.5" and Toytec AALs.
    Has anyone used or installed one on their vehicle. There is one radio station I really want to listen to and it comes in on one side of town but not the other, and there are no hills. It comes in perfect in my wifes explorer so I thought maybe I just need a little more "umph". Opinions?

    http://www.crutchfield.com/p_12044UA60/FM-Signal-Amplifier.html?search=FM+Signal+Amplifier&tp=3351

    http://www.jcwhitney.com/AUTOTEK-AM-FM-RADIO-ANTENNA-BOOSTER/GP_2001196_N_111+2005+200729294+600014099_10101.jcw
     
  2. Jan 12, 2009 at 6:17 AM
    #2
    sooner07

    sooner07 1/2 man 1/2 amazing

    Joined:
    Feb 17, 2008
    Member:
    #4783
    Messages:
    1,400
    Gender:
    Male
    First Name:
    A A Ron
    DFW, Texas
    Vehicle:
    Debadged 2008 Rugged Trail
    Always working on the stereo, painted the front skid plate black to match the truck, debadged , toy tech ultimate lift kit, light racing UCAs, ARB bumper Looking into a supercharger and new exhaust.
    I actually installed the one in the crutchfield link. I put it in my car back 8 or 9 years ago. I don't think it did anything for me, in fact, some stations came in clearer when it was off. Might have been installation error or something, but I didn't see much use in it.
     
To Top