1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

forum virgin

Discussion in 'New Members' started by blkbelt193, Jan 8, 2013.

  1. Jan 8, 2013 at 2:32 PM
    #1
    blkbelt193

    blkbelt193 [OP] Member

    Joined:
    Nov 8, 2012
    Member:
    #90754
    Messages:
    12
    Gender:
    Male
    buckeye az
    Vehicle:
    95 tacoma 3.4 L
    Whats up everyone. This is my first forum subscription. I have a 95 tacoma. 3.4 liter v6 4x4 with 190k on it and it has some issues .Been searching around tacoma world and everybody seems very helpful. hopefully i can get some help and give some help.
     
  2. Jan 8, 2013 at 2:33 PM
    #2
    Highland Logan

    Highland Logan UBIQUE

    Joined:
    Apr 11, 2011
    Member:
    #54752
    Messages:
    2,804
    Gender:
    Male
    First Name:
    Frank
    Nova Scotia, Canada
    Vehicle:
    2011 Black AC TRD Off Road w/ factory tow pkg
    Icon Stage 2 w/ overload left in, SPC LR UCA, 265/75 16 BFG KO2, front and rear Weathertech floor liners, OEM (Extang) solid fold tonneau, OEM bed mat, OEM front skid plate, OEM billet oil cap, "TOYOYA" tailgate decal
    Welcome to Tacoma World, from Nova Scotia.

    Frank
     
  3. Jan 8, 2013 at 2:40 PM
    #3
    anthony250f

    anthony250f Well-Known Member

    Joined:
    Feb 18, 2012
    Member:
    #73066
    Messages:
    8,752
    Gender:
    Male
    First Name:
    Anthony
    goleta/santa barbara, ca
    Vehicle:
    97 5 speed 4x4 v6
    lt
    welcome!
     
  4. Jan 8, 2013 at 2:53 PM
    #4
    Warputer

    Warputer Dirt Road Inspector

    Joined:
    Jul 31, 2011
    Member:
    #60864
    Messages:
    7,981
    Gender:
    Male
    First Name:
    Chris
    Lake Murray, South Carolina
    Vehicle:
    2011 TRD Off Road
    A little lift & some extra steel....
    Welcome to TW virgin! What kind of issues does the truck have?
     
  5. Jan 8, 2013 at 3:06 PM
    #5
    blkbelt193

    blkbelt193 [OP] Member

    Joined:
    Nov 8, 2012
    Member:
    #90754
    Messages:
    12
    Gender:
    Male
    buckeye az
    Vehicle:
    95 tacoma 3.4 L
    Thank you. Were do i start? Lol. just replaced the valve cover gasket. Throttle body gasket. Made sure to clean it out good. Also just replaced the clutch. Couple days after i put her back together.was having problems staying up to temp was running cold. That stop. But now when its up to temp and i accelerate, it makes this crazy noise on the driver side engine and my oil light flutters on when I'm in neutral. I hope its just a bad sensor....
     
  6. Jan 8, 2013 at 5:11 PM
    #6
    blkbelt193

    blkbelt193 [OP] Member

    Joined:
    Nov 8, 2012
    Member:
    #90754
    Messages:
    12
    Gender:
    Male
    buckeye az
    Vehicle:
    95 tacoma 3.4 L
    That's just the first issue...
     
  7. Jan 8, 2013 at 5:17 PM
    #7
    Warputer

    Warputer Dirt Road Inspector

    Joined:
    Jul 31, 2011
    Member:
    #60864
    Messages:
    7,981
    Gender:
    Male
    First Name:
    Chris
    Lake Murray, South Carolina
    Vehicle:
    2011 TRD Off Road
    A little lift & some extra steel....
    And that's a lot! Better start a new thread with that list....you'll get more help.
     
To Top