1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Front suspension "click" on speed bumps

Discussion in 'Suspension' started by probin, Sep 17, 2012.

  1. Sep 17, 2012 at 10:20 AM
    #1
    probin

    probin [OP] New Member

    Joined:
    Oct 17, 2011
    Member:
    #65357
    Messages:
    4
    Gender:
    Male
    Vehicle:
    TACO 2012 4x4 TRD Spport Pack
    Tires
    hi Guys!

    I have 4x4 2012 automatic doble cab tacoma TRD Sport Package with less than 10,000 miles and always, hitting speed bumps, a strong click sounds on 70-75% on suspension compression. It also sounds sometimes at the beginining of the bump, but commonly after passing.

    I was unable to see a mark or friction point in the suspension. This truck comes with blistein shocks from factory.

    It also seems that with the car cold, early morning, sound more

    Any idea about what's happening?

    Does this truck needs Molibden grease on front suspension? I could not see the grease points as I see it in my previous Hilux.

    Thanks
    PR
     
  2. Sep 17, 2012 at 12:36 PM
    #2
    BTO

    BTO Well-Known Member

    Joined:
    Nov 12, 2009
    Member:
    #25836
    Messages:
    387
    Gender:
    Male
    California
    Vehicle:
    '07 Silver PR DC AT SR5 TP LSD
    Defroster mod, Bilstein 5100s front, Adjustable Ranchos rear.
    Are you sure it's not the mud flaps hitting the bump? If you still have them on remove them before they decide to come loose and beat the hell out of the side of your truck.
     
  3. Sep 17, 2012 at 5:39 PM
    #3
    The Traveler

    The Traveler REBELTACO

    Joined:
    Mar 28, 2012
    Member:
    #75806
    Messages:
    6,791
    Gender:
    Male
    First Name:
    Matt
    SoCal
    Vehicle:
    '10 Long Travel 4x4 DCSB
    Total Chaos 3.5" LT kit, King remote resi 8x2.5 coilovers, Glassworks Unlimited fiberglass fenders and bedsides, Icon resi rears, All Pro Expo leaf pack, Wheeler's super bumps, drop in AFE Pro Dry-S, Aero-Turbine 2525XL Muffler, Spidertrax, Rigid Industries Dually Amber Floods, rock lights, Strobe amber/white dust lights, bushwhacker fender flares, CB and HAM radios, Pelfreybilt Off Road front three hoop bumper, All-Pro APEX kickout sliders, CBI Trail Rider rear bumper, Tres Tacos LED rock lights, 50" LED Light Bar,
    I used to get that all the time...never figured it out, but it went away after I upgraded to Bilstein 5100's. It also only came from the driver side front.

    Where was that rub mark located? Springs, control arms?
     
To Top