1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Gap in gauge cluster trim, fix?

Discussion in '2nd Gen. Tacomas (2005-2015)' started by STLTaco09, Jun 23, 2009.

  1. Jun 23, 2009 at 6:38 AM
    #1
    STLTaco09

    STLTaco09 [OP] Well-Known Member

    Joined:
    Dec 4, 2008
    Member:
    #11281
    Messages:
    363
    Gender:
    Male
    5100's all around, fronts at 1.75". TSB leaf pack + Toytec TSB AAL
    So I noticed a decent size (to me) gap between the trim around the gauge cluster (above the left most A/C vent) and the flat piece above the gauge cluster itself (not sure what to call it). This is what I'm talking about:

    [​IMG]

    [​IMG]


    Now the trim piece going around the gauge cluster and the A/C vent was replaced by the dealership after they scratched up the original getting my 09 radio replaced. I just noticed this the other day. Are clips broken? Is something just misaligned and needs to be adjusted?

    I hate taking apart this kind of stuff because I always end up breaking something (clips, tabs, etc).

    I can push the piece so it sits flush, but it doesn't stay there.

    Any insight would be appreciated.
     
  2. Jun 23, 2009 at 6:54 AM
    #2
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Staff Member

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    103,918
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    If the dealer did it, make them fix it.
     
  3. Jun 23, 2009 at 6:56 AM
    #3
    techgeekwill

    techgeekwill Captain Funk

    Joined:
    Apr 2, 2009
    Member:
    #15497
    Messages:
    200
    Gender:
    Male
    Spring, TX
    Vehicle:
    09 Tiberland Mica DC LB
    Take it back to the dealer. No excuse for that.
     
  4. Jun 23, 2009 at 6:57 AM
    #4
    STLTaco09

    STLTaco09 [OP] Well-Known Member

    Joined:
    Dec 4, 2008
    Member:
    #11281
    Messages:
    363
    Gender:
    Male
    5100's all around, fronts at 1.75". TSB leaf pack + Toytec TSB AAL
    I know, but my problem is they put in a new radio, fubar'd up some trim pieces. I made them fix that, then they fubar'd up this. It's like an on going process by a bunch of incompetent kids who don't care about their work. If its something I can just do in an hour or something, I'd prefer to go that route. I'm just trying to figure out what I'm getting into before I dig in.
     
  5. Jun 23, 2009 at 7:01 AM
    #5
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Staff Member

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    103,918
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    If it wont press right in, hold them accountable for their mistakes. No excuse for that, and they should fix it.
     
  6. Jun 23, 2009 at 7:03 AM
    #6
    techgeekwill

    techgeekwill Captain Funk

    Joined:
    Apr 2, 2009
    Member:
    #15497
    Messages:
    200
    Gender:
    Male
    Spring, TX
    Vehicle:
    09 Tiberland Mica DC LB
    Chances are, they broke a clip or are missing screws. If you do it, and have to go back to the dealer later, they will blame you. You can call Toyota or the DM for the area and complain (Seems to be the only way to get things done right).

    Not sure where you are, but if you have another dealer close, try them.
     
  7. Jun 23, 2009 at 9:06 AM
    #7
    DdayIsNear

    DdayIsNear Well-Known Member

    Joined:
    Jun 14, 2009
    Member:
    #18432
    Messages:
    6,510
    Gender:
    Male
    First Name:
    Crazy
    NW Jersey
    Vehicle:
    TRD Offroad
    All pro sliders
    what i do at the stealerships is ask who has worded there the longest and meet the mechanic. then after they work on car/truck and all is good, i request the same person when i drop ti off to work on it. for teh 6 years i owned my 03 MSP, i had only 2 mechanics ever work on the car...so thats what i would do.
     
  8. Jun 23, 2009 at 9:15 AM
    #8
    wing103

    wing103 Well-Known Member

    Joined:
    Jul 8, 2008
    Member:
    #7807
    Messages:
    1,041
    Gender:
    Male
    Boston
    Vehicle:
    Tacoma TRD Sport / Dark Gray
    Grill Craft upper & Lower Grill WetOK Seat Cover, Devil Horn, Bug, Windows Deflector, Side step Bar, HID 55W 8000K Headlight, HID 35W 4000K Foglight, Fog Light Mod, Interior LED Map Light Mod, Electric Tail Gate Lock, Leer Cab, Key ring light, Bed LED lights Mod, Kenwood DNX5120, Signal Mirror with Heat
    Make the dealer fix it. Bring it back. Also check the TSB and have them do it at the same time.
     
  9. Jun 23, 2009 at 9:21 AM
    #9
    STLTaco09

    STLTaco09 [OP] Well-Known Member

    Joined:
    Dec 4, 2008
    Member:
    #11281
    Messages:
    363
    Gender:
    Male
    5100's all around, fronts at 1.75". TSB leaf pack + Toytec TSB AAL
    What TSB? I have the rear TSB leaf pack if that is what you are referring to.
     
  10. Jun 23, 2009 at 9:26 AM
    #10
    Pster

    Pster Well-Known Member

    Joined:
    Jun 30, 2008
    Member:
    #7654
    Messages:
    2,754
    Gender:
    Male
    Charlotte, NC
    Vehicle:
    2006 Tacoma 4x4
    Bak Flip bed cover, shorty antenna, Peripheral iPod interface, Garmin 750 mount, add'l bed tie down rings, Westin nerf bars, hitch safe, tailgate lock, Ideal 1 3/4" turn-key clamp to secure tailgate from removal, Spare tire security cable, spare tire stainless air hose extender, Fumoto oil drain valve, Amp Research Bed X-Tender w/Schlage Cable Lock, bed mat, Redline hood struts
    My guess is that they removed the silver bezel from around the radio (not necessary if you are just r/r radio) which is "integrated" into the face piece for the guage surround by overlapping lips. Can be fudgy to reinstall neatly. They just re-installed it improperly.
     
To Top