1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Got a Question

Discussion in '2nd Gen. Tacomas (2005-2015)' started by JW150, Dec 3, 2009.

  1. Dec 3, 2009 at 10:00 AM
    #1
    JW150

    JW150 [OP] New Member

    Joined:
    Dec 2, 2009
    Member:
    #26891
    Messages:
    4
    Gender:
    Male
    I was looking at some
    Helo Series Wheels here is the specs on em

    • 17x8, Bolt Pattern 6x5.5
    • Backspace = 4.5 in.
    • Max Load = 2200lbs
    • Finish = Black Machined
    • Hubcentric = No
    • Offset = 0 mm
    And a Goodyear Wrangler size 265/70/17
    The question is would this work without rubbing? Any input would be helpful Thanks
    My Truck is a 2009 TRD sport double cab completely stock at this point
     
  2. Dec 3, 2009 at 10:08 AM
    #2
    CAMZTRD

    CAMZTRD Well-Known Member

    Joined:
    Jun 19, 2008
    Member:
    #7401
    Messages:
    512
    Gender:
    Male
    First Name:
    steve
    hampton, va
    Vehicle:
    2006 DC TRD Off-Road 4x4
    billy 5100's @ 2.5 w/ 1/4 spacers, toytec aal, LR UCA's, revotec headlights,revotec taillights, lamin-x fogs, color matched grille and rear bumper, undercover, bed-extender, black nerf bars, scan gaugeII , afe drop in, 50 series flowmaster, 6000k bi-xenon hids, more to come.......
    you will have no issues.
     
  3. Dec 3, 2009 at 10:29 AM
    #3
    brian

    brian Another Traitor

    Joined:
    Apr 15, 2009
    Member:
    #16011
    Messages:
    7,557
    Gender:
    Male
    Elizabeth City, NC
    Vehicle:
    2008 F-350 Powerstroke
    same size and backspace as my wheels. I rub a very little with 285's but with 265's you should have no problems.
     
To Top