1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Grom, No Right Channel

Discussion in 'Audio & Video' started by kwmayo, Mar 4, 2010.

  1. Mar 4, 2010 at 6:27 AM
    #1
    kwmayo

    kwmayo [OP] New Member

    Joined:
    Mar 1, 2010
    Member:
    #32362
    Messages:
    2
    Gender:
    Male
    This is my fault, because I dont remember this working or not when I tested it...

    I just finished tearing out and reinstalling the dash on my 07 to put in the GROM USB2/iPOD adapter. USB works great, Radio/Changer all work great, but the AUX-in and iPod features dont have a right audio channel. I can hear them if I move the balance all the way to the side, but they're muffled and difficult to hear. Left works great.

    Any ideas?

    Thanks.
     
  2. Mar 4, 2010 at 9:58 AM
    #2
    pyrite_taco

    pyrite_taco Member

    Joined:
    Aug 30, 2009
    Member:
    #22012
    Messages:
    21
    Gender:
    Male
    First Name:
    Brad
    south jersey
    Vehicle:
    2010 Pyrite DC TRD Sport JBL
    ok, taking the fact that in USB mode you can hear all channels means that the connection from the Grom to the Radio is good.

    in the manual it says to not have a usb disk and ipod connected at the same time. are you only attaching one of the sources at a time? the wire from the unit should be fine, just do not plug anything into the other ends.

    moving on to the Ipod: check the cable connecting the Ipod to the Grom for a bent pin in the cable. and make sure it is plugged in tight. same for the AUX in.

    if that does not solve the problem, next i would check your firmware version, the full procedure is in the manual also but its something like: disconnect all devices (usb stick, ipod, aux) press FM wait one second then press disc to activate the Grom the track number will show the firmware build id

    goto Grom's website and download the firmware (follow their steps to place on a usb stick) and update the unit if need be.

    last resort call their tech support :wink:
     
To Top