1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Half of Speedometer is dim when it's cold

Discussion in '1st Gen. Tacomas (1995-2004)' started by defleppardsg, Oct 7, 2011.

  1. Oct 7, 2011 at 7:43 AM
    #1
    defleppardsg

    defleppardsg [OP] Well-Known Member

    Joined:
    Mar 6, 2011
    Member:
    #52453
    Messages:
    134
    Gender:
    Male
    First Name:
    chris
    texas
    Vehicle:
    2.7L SR5 4x4
    OME 880's, Wheeler's Offroad 5-Leaf pack. Bilstein 5100's, 1" Daystar shackles, Deck Plate Mod.
    I thought I had a bulb out behind the left side of the speedometer, but then when it warmed up last spring, it started to come on like normal. Now that it's getting cold again, that same half is out.. Annoying.

    So what's the problem? it cant be the bulb... Is there anything I could do to seat the bulb better or ensure a solid connection?
     
  2. Oct 7, 2011 at 8:10 AM
    #2
    Blackdawg

    Blackdawg Dr. Frankenstein

    Joined:
    Dec 31, 2010
    Member:
    #48500
    Messages:
    69,469
    Gender:
    Male
    First Name:
    Monte
    Wyoming/St. Louis
    Vehicle:
    The Trifecta of Taco's
    ALL OF THEM!...Then some more.
    Sometimes this happens to me. Just smack the dash. Light comes back on for me.
     

Products Discussed in

To Top