1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Has this happened to anyone?

Discussion in 'Technical Chat' started by Babyblue, Dec 31, 2011.

  1. Dec 31, 2011 at 11:09 AM
    #1
    Babyblue

    Babyblue [OP] Member

    Joined:
    Dec 28, 2011
    Member:
    #69513
    Messages:
    23
    Gender:
    Female
    First Name:
    Shelly
    Dallas, TX
    Vehicle:
    07 Xrunner
    KN Air Filter, Pioneer FH-X700BT Dbl din.
    On my 07 xrunner the vent selector switch is stuck in the defrost. The switch handle moves around but it is still stuck in defrost mode. What happened? How to fix it.?
    Thank you.
     
  2. Jan 4, 2012 at 7:02 AM
    #2
    rdm197aps

    rdm197aps Well-Known Member

    Joined:
    Dec 15, 2011
    Member:
    #68839
    Messages:
    69
    Gender:
    Male
    First Name:
    Rick
    DFW
    Vehicle:
    10 TRD Sport 4x4
    ARB bulbar WARN M8000, OME/Dakar, enough recovery gear to yank a GEO Tracker outta ditch!
    sounds like the switch it self is bad. had something similar happen to me on an old chevy i used to own. i replaced the switch from a parts house, and fixed the problem. unfortunately without looking at the truck in person, i cannot give a more accurate diagnosis.

    hope this helps

    rick
     
  3. Jan 5, 2012 at 10:55 AM
    #3
    Babyblue

    Babyblue [OP] Member

    Joined:
    Dec 28, 2011
    Member:
    #69513
    Messages:
    23
    Gender:
    Female
    First Name:
    Shelly
    Dallas, TX
    Vehicle:
    07 Xrunner
    KN Air Filter, Pioneer FH-X700BT Dbl din.
    Thanks, that is what I thought now I get to have fun find it. LOL :)
     
  4. Jan 5, 2012 at 10:58 AM
    #4
    BrokenTusk

    BrokenTusk I support a velociraptor free workplace.

    Joined:
    May 5, 2010
    Member:
    #36607
    Messages:
    31,936
    Gender:
    Male
    First Name:
    Marcelasaurus
    AB, Canada
    Vehicle:
    The Scarlett Whore
    Check Build Thread!!
    I have an 07 Xr as well, the selector switch is right behind the togle, you just remove the lower dash controls (all 3 of the lower circle dials) I think it's 4 screws underneath the dials?
     
  5. Jan 6, 2012 at 6:59 PM
    #5
    Babyblue

    Babyblue [OP] Member

    Joined:
    Dec 28, 2011
    Member:
    #69513
    Messages:
    23
    Gender:
    Female
    First Name:
    Shelly
    Dallas, TX
    Vehicle:
    07 Xrunner
    KN Air Filter, Pioneer FH-X700BT Dbl din.
    Bless you, Tks so much. I wonder if part store would have it or would I need to get from the dealership. Again TU, :)
    Please let me how difficult would it be?
     
  6. Jan 6, 2012 at 7:01 PM
    #6
    Pnicholas1019

    Pnicholas1019 Well-Known Member

    Joined:
    Oct 11, 2011
    Member:
    #65004
    Messages:
    190
    Gender:
    Male
    First Name:
    Parker
    surprise
    Vehicle:
    '92 toyota tacoma
    6" lift, front bumper, Oil cooler, HID lights, toyo m/t 33's.
    something like that happened on my old car. Is the wire behind the switch loose and fell off?
     
  7. Jan 6, 2012 at 9:41 PM
    #7
    rdm197aps

    rdm197aps Well-Known Member

    Joined:
    Dec 15, 2011
    Member:
    #68839
    Messages:
    69
    Gender:
    Male
    First Name:
    Rick
    DFW
    Vehicle:
    10 TRD Sport 4x4
    ARB bulbar WARN M8000, OME/Dakar, enough recovery gear to yank a GEO Tracker outta ditch!
    i took mine off the other day to paint the surround, the plastic thing around the three switches, and its held together with some screws on the back and a few tabs. i didn't go any further than that with disassembling the switch cluster because my goal was to paint the silver part around the switches. it looked pretty simple to take it further apart, so it shouldn't be too hard.

    just remember, if you have to force it... your doing it wrong. i cant imagine the switches being too expensive, these trucks are sold everywhere (called the Hilux across the pond) and parts should be plentiful... :confused:

    :mad: ok i just spent @ an hour searching the net and could not find a replacement A/C switch for the dash. looks like it a dealer part. sorry...
     
  8. Jan 7, 2012 at 5:17 PM
    #8
    Babyblue

    Babyblue [OP] Member

    Joined:
    Dec 28, 2011
    Member:
    #69513
    Messages:
    23
    Gender:
    Female
    First Name:
    Shelly
    Dallas, TX
    Vehicle:
    07 Xrunner
    KN Air Filter, Pioneer FH-X700BT Dbl din.



    Thanks a lot, very nice of you for searching, I would have done it. Bless you for all your help. :) I really appreciate.
     
  9. Jan 10, 2012 at 5:47 PM
    #9
    Babyblue

    Babyblue [OP] Member

    Joined:
    Dec 28, 2011
    Member:
    #69513
    Messages:
    23
    Gender:
    Female
    First Name:
    Shelly
    Dallas, TX
    Vehicle:
    07 Xrunner
    KN Air Filter, Pioneer FH-X700BT Dbl din.
    Don't know yet. Will let everyone know what it was. First thing I will be replacing if the relay.

    Thanks :)
     
  10. Jan 10, 2012 at 10:08 PM
    #10
    MountainEarth

    MountainEarth Well-Known Member

    Joined:
    Feb 1, 2010
    Member:
    #30519
    Messages:
    2,487
    Gender:
    Male
    First Name:
    Bryan
    CO
    Vehicle:
    2010 TRD OR Access
    Leer 100XR Shell, BedRug mat - comfy sleeping, GT Covers microfiber seat covers, BFG All Terrains 265/70r16, Dashmat, Antennax 13" shorty antenna, Weathertech liners, Ultra Gauge, Avid Light Bar, PIAA 520 ATPs, one old dog
  11. Jan 11, 2012 at 6:24 PM
    #11
    Babyblue

    Babyblue [OP] Member

    Joined:
    Dec 28, 2011
    Member:
    #69513
    Messages:
    23
    Gender:
    Female
    First Name:
    Shelly
    Dallas, TX
    Vehicle:
    07 Xrunner
    KN Air Filter, Pioneer FH-X700BT Dbl din.
    Wow, Thanks. My babyblue "07" Xrunner has 110k :( on it and the problem is when switch stop working properly now it is stuck in defrost mode, which it is still blowing good thing since it is winter. :) Now I just need a nice warm enough FREE weekend to open up the controllers and take a look see. Hopefully only with screw driver and my little fingers. LOL
    Bless you.
     
  12. Jan 21, 2012 at 5:26 PM
    #12
    Babyblue

    Babyblue [OP] Member

    Joined:
    Dec 28, 2011
    Member:
    #69513
    Messages:
    23
    Gender:
    Female
    First Name:
    Shelly
    Dallas, TX
    Vehicle:
    07 Xrunner
    KN Air Filter, Pioneer FH-X700BT Dbl din.

    I will be replacing the fan resistor tomorrow. I also got the relay too but my little fingers are not strong enough to pull it. [​IMG] Only in Texas do we have roll coaster ride of weather, it will be in the 70's tomorrow. [​IMG]
     
  13. Jan 24, 2012 at 8:09 PM
    #13
    VanCity4x

    VanCity4x The shit show

    Joined:
    Aug 1, 2011
    Member:
    #60970
    Messages:
    1,409
    Gender:
    Male
    First Name:
    DJ
    BC
    Vehicle:
    05 Prerunner SAS
    3link 1tons on 40's and sum stuff
    Just so everybody knows when you take off the back and goto take off the the dial that the knob turns, there is a spring loaded pin in there. Thats what locks the dial in place and gives resistance when you turn it. I lost the pin. I still had the spring so i had to cut the tiniest piece of plastic dowel to make a new one. It works now but not like before. Work in a well lit area where you can protect the unit so the springs or parts dont go missing.
     
  14. Feb 4, 2012 at 2:25 PM
    #14
    Babyblue

    Babyblue [OP] Member

    Joined:
    Dec 28, 2011
    Member:
    #69513
    Messages:
    23
    Gender:
    Female
    First Name:
    Shelly
    Dallas, TX
    Vehicle:
    07 Xrunner
    KN Air Filter, Pioneer FH-X700BT Dbl din.

    The relay was replaced and fixed the problem. I will be replacing the resistor anyway, Toyota has upgraded it.
     
  15. Feb 4, 2012 at 2:40 PM
    #15
    Babyblue

    Babyblue [OP] Member

    Joined:
    Dec 28, 2011
    Member:
    #69513
    Messages:
    23
    Gender:
    Female
    First Name:
    Shelly
    Dallas, TX
    Vehicle:
    07 Xrunner
    KN Air Filter, Pioneer FH-X700BT Dbl din.
    Replaced the relay it fixed the problem. I will still replace the resistor with the new updated one Toyota has made.

    Woohoo! :D
     
To Top