1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

having power steering issues

Discussion in 'Technical Chat' started by 2.7, Jan 2, 2013.

  1. Jan 2, 2013 at 5:10 PM
    #1
    2.7

    2.7 [OP] New Member

    Joined:
    Jan 1, 2013
    Member:
    #94159
    Messages:
    4
    Gender:
    Male
    First Name:
    Adam
    Fort Lauderdale Florida
    Vehicle:
    2.7 liter 4x 4 Tacoma
    new powersteering pump and new rack.im following the procedure in the book but still no power steering
     
  2. Jan 5, 2013 at 8:39 AM
    #2
    tan4x4

    tan4x4 Well-Known Member

    Joined:
    Nov 30, 2011
    Member:
    #67982
    Messages:
    2,036
    Gender:
    Male
    First Name:
    Rick
    Folsom, CA
    Vehicle:
    99 Tacoma EC 4x4 2.7L Auto
    Bilsteins, OME 881's, 3-leaf AAL, Detroit TruTrac, 31" tires, Michelin LTX AT2, stock gears, Tranny skidplate, TC skidplate, CBI rear bumper, sliders, UltraGauge, PowerTank, CB
    Blocked power steering lines?
    Air pocket?
     
  3. Apr 2, 2015 at 7:17 AM
    #3
    kauairq

    kauairq Member

    Joined:
    Mar 28, 2015
    Member:
    #151941
    Messages:
    6
    Gender:
    Male
    Kauai hawaii
    Vehicle:
    99 Tacoma 4x4
    I have the same problem. I changed the rack, pressure line and pump. The same problem occurs when I turn the wheel one way or the other the reservoir overflows with fluid. I changed out two rebuilt pumps and still no power. I cleaned out the screen and the return line and still the same problem.
     
To Top