1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Help! 2001 tacoma supercharger trd kit

Discussion in '1st Gen. Tacomas (1995-2004)' started by importautopros, Sep 17, 2009.

  1. Sep 17, 2009 at 7:44 PM
    #1
    importautopros

    importautopros [OP] Well-Known Member

    Joined:
    May 15, 2009
    Member:
    #17253
    Messages:
    110
    Gender:
    Male
    westminster
    Vehicle:
    2001 Tacoma Supercharged Limited
    I got my 2001 taco and i just put on a trd supercharger with a urd 7th injector kit, I was wondering if there is a MAF difference in the stock and the supercharger version? My truck runs ok but only made 237hp with 271tq, from time to time it acts up and runs like shit, it throws a system too rich, random miss fire, and af code p1130 any input will help thanks
     
  2. Sep 17, 2009 at 7:47 PM
    #2
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,153
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Actually, 237 hp sounds about right for that engine. As for the code, thats a bank one sensor one malfunction. Repace the A/f sensor.
     
  3. Sep 18, 2009 at 8:39 AM
    #3
    importautopros

    importautopros [OP] Well-Known Member

    Joined:
    May 15, 2009
    Member:
    #17253
    Messages:
    110
    Gender:
    Male
    westminster
    Vehicle:
    2001 Tacoma Supercharged Limited
    oh yea i for got to say i also have a 9lb pulley...
     
  4. Sep 18, 2009 at 8:39 AM
    #4
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,153
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Have you replaced your AF sensor?
     
  5. Sep 18, 2009 at 8:56 AM
    #5
    pittim

    pittim mittip

    Joined:
    May 28, 2008
    Member:
    #6939
    Messages:
    16,507
    Gender:
    Male
    Vehicle:
    Respect your elder gen.
    Pink slider.
    Is that power at the wheels or crank? I'm guessing wheels, right?

    The 5vzfe makes 190/220 at the crank, so 237/271 at the wheels sounds like a good improvement
     
  6. Sep 18, 2009 at 5:44 PM
    #6
    EnolaGaia

    EnolaGaia Well-Known Member

    Joined:
    Sep 9, 2006
    Member:
    #9
    Messages:
    1,129
    Gender:
    Male
    Midwest USA
    Vehicle:
    '01 & '04 S-Runners
    01 SR: Double Cab conversion, S/C, lowered.
    I notice your profile says you have a 'Limited'. A Double Cab, right? ...

    If so ... There have been cases where TRD supercharger setups (even with URD upgrades) have resulted in odd or problematical performance on Double Cabs. No one's sure why, but there've been enough instances of this to indicate there's something 'different' about 2001 - 2004 Double Cabs that can cause problems.

    As I recall, the most popular theory is that it must have something to do with the ECM used on the Double Cabs.

    CustomTacos member 'glassdoc' has posted extensively about his frustrating experiences in trying to get all sorts of combinations of TRD supercharger and other components to work on his Double Cab. He's gone to great lengths (including getting Gadget involved ...) without resolving whatever the problem(s) may be.

    I'm not saying you problems are necessarily the same as the ones he grappled with ... I'm only saying some Double Cabs have proven to be problem cases in the past.
     
  7. Sep 18, 2009 at 11:43 PM
    #7
    importautopros

    importautopros [OP] Well-Known Member

    Joined:
    May 15, 2009
    Member:
    #17253
    Messages:
    110
    Gender:
    Male
    westminster
    Vehicle:
    2001 Tacoma Supercharged Limited
    Yes its a limited double cab automatic. well ever since i install the 7th injector from urd its been acting up. it makes a whole lot more power then when it didnt have it. but the a/f code never came on intill the 7th injector was installed and since it came on i do suspect it could be it. i also talked to gadget what he told me was that i have the older 7th injector kit and need to update to the lates one but b4 the kit it worked fine but was slow and didnt make the power. i also notice the maf part # was different from what i got and from what i was told it came off a supercharger tacoma. so i thought it might be that also but to check i would have to buy one first. let me know what u think. thanks for all the input everyone..
     
  8. Sep 18, 2009 at 11:45 PM
    #8
    importautopros

    importautopros [OP] Well-Known Member

    Joined:
    May 15, 2009
    Member:
    #17253
    Messages:
    110
    Gender:
    Male
    westminster
    Vehicle:
    2001 Tacoma Supercharged Limited
    yes thats to the wheels of course. with a 9lbs pulley.
     
  9. Sep 18, 2009 at 11:50 PM
    #9
    importautopros

    importautopros [OP] Well-Known Member

    Joined:
    May 15, 2009
    Member:
    #17253
    Messages:
    110
    Gender:
    Male
    westminster
    Vehicle:
    2001 Tacoma Supercharged Limited
    no i havent replaced it yet, 140 bucks is hard to let go just to check. but i do think i should try it cuz alot of people been pointing it out.
     
  10. Sep 23, 2009 at 5:11 PM
    #10
    importautopros

    importautopros [OP] Well-Known Member

    Joined:
    May 15, 2009
    Member:
    #17253
    Messages:
    110
    Gender:
    Male
    westminster
    Vehicle:
    2001 Tacoma Supercharged Limited
    12313213213213
     
  11. Oct 3, 2009 at 1:00 AM
    #11
    importautopros

    importautopros [OP] Well-Known Member

    Joined:
    May 15, 2009
    Member:
    #17253
    Messages:
    110
    Gender:
    Male
    westminster
    Vehicle:
    2001 Tacoma Supercharged Limited
    now my trucks power is down to 196hp i hooked it back up to the dyno and got my laptop out to tune the engine some more and whatever i did it wont make any change the afr stay around 14 to 15 afr super lean to lean. is there something wrong do anyone know what to do?

    i guess im gonna try a new o2 sensor it looks like it out of range when i got my scanner to it.
     
  12. Oct 14, 2009 at 1:25 AM
    #12
    importautopros

    importautopros [OP] Well-Known Member

    Joined:
    May 15, 2009
    Member:
    #17253
    Messages:
    110
    Gender:
    Male
    westminster
    Vehicle:
    2001 Tacoma Supercharged Limited
    i replaced the front o2 and retuned it and now it runs great but still under power. it put down 223hp with 271tq.
     
To Top