1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Help a fellow tacoworld member out today or tomorrow

Discussion in 'Southern California' started by nighthawk87, Jun 29, 2010.

  1. Jun 29, 2010 at 3:25 PM
    #1
    nighthawk87

    nighthawk87 [OP] Well-Known Member

    Joined:
    Aug 9, 2008
    Member:
    #8434
    Messages:
    1,023
    Is anyone really good with the front suspension and diagnosing a popping sound after a coilover install?

    If so, I could really use your help. I live in Lake Forest, CA (South OC).

    Getting ready to tow a trailer this weekend and would feel better if I found and fixed this problem.

    I have ideas, but nothing concrete yet.

    Help me.... :(
     
  2. Jun 29, 2010 at 7:59 PM
    #2
    S.B.

    S.B. Well-Known Member

    Joined:
    Jun 24, 2009
    Member:
    #18838
    Messages:
    3,566
    Gender:
    Male
    First Name:
    Sean
    SD, CA Now in Colorado Springs, CO
    Vehicle:
    08 Taco 4x4 TRD OffRoad Rugged Trail
    SAW 2.0s, Wheeler's 3-leaf AAL, On Board Air, 255/85/16 Cooper Discover S/T, CBI Sliders, Built right UCAs, 6" Harbor Freight Lights (converted to HIDs), KC Slim Lights.
    When Does it make that sound? And did you buy the coilovers used?
     
  3. Jun 29, 2010 at 8:57 PM
    #3
    LBtaco

    LBtaco Thread killer

    Joined:
    Jan 23, 2009
    Member:
    #12893
    Messages:
    1,242
    Gender:
    Male
    Long Beach , CA
    Vehicle:
    15 Nissan Leaf
    Jetsons mod
    did you relocate your sway bar mounts? it could be hitting.
    re check all the bolts you messed with, use a torque wrench

    post pics?
     
  4. Jun 29, 2010 at 10:33 PM
    #4
    KaoskrewPB

    KaoskrewPB -Empty-

    Joined:
    Sep 6, 2009
    Member:
    #22370
    Messages:
    600
    Gender:
    Male
    First Name:
    Aaron
    Went from: Icon coilovers, Light Racing UCA's, SpiderTrax Wheel spacers, T Rex Eye lids color matched, Rear AAL, Iron Dirt light bar, Hella 500's, Blacked out door badges and front grill badge, Blacked out Hella light covers, Trailer Brake controller, JVC Arsenal KD-AHD69 HU, Sony Xplod Amp To completely stock :(
    Post up a picture of where the sway bar mounts to the frame right near each side of the skid plate
     
  5. Jun 29, 2010 at 10:46 PM
    #5
    Crownedcustoms

    Crownedcustoms Well-Known Member

    Joined:
    Mar 1, 2010
    Member:
    #32385
    Messages:
    178
    Gender:
    Male
    Gilbert
    Vehicle:
    07 dc 4x4 fox coilovers 20's & toyo mudders
    Fox coil-overs, Fox shocks, 20" Helo wheels, blowthough, Jl and focal system, Grillcraft grill, Toyo Mud terrains
    Is your skid plate bent in the front? I bent mine up and them put fox coils in the front after it was bent. Every time i would hit a bump the sway bar would hit the skid plate ans make a popping noise. Just an idea.
     
  6. Jun 29, 2010 at 10:56 PM
    #6
    HBMurphy

    HBMurphy Ban Pending

    Joined:
    Jun 27, 2009
    Member:
    #18993
    Messages:
    6,090
    Gender:
    Male
    First Name:
    Paul
    So California Coast
    Vehicle:
    09 Off Road Delete Model
    None
    I have to drop off my car (at Crevier in Santa Ana - off the 55) at 7:20 am - If you want, I can help you. What's your morning schedule? Also, do you have a good floor jack?
     
  7. Jun 29, 2010 at 10:56 PM
    #7
    tacobo670

    tacobo670 if you have to ask, u can't afford it

    Joined:
    Jan 22, 2010
    Member:
    #29864
    Messages:
    1,878
    Gender:
    Male
    First Name:
    Ray
    Las Vegas
    Vehicle:
    Tacoma Sport 4x4 AC 6spd
    Super cherry n some champion stuff on the side
    u can just check to make sure the swaybar end link is not hitting the coil when the sus flexes.... just a suggestion. look for rub marks.
    also... make sure all bolts are tight!!!! never hurts to double check
     
  8. Jun 29, 2010 at 11:13 PM
    #8
    HBMurphy

    HBMurphy Ban Pending

    Joined:
    Jun 27, 2009
    Member:
    #18993
    Messages:
    6,090
    Gender:
    Male
    First Name:
    Paul
    So California Coast
    Vehicle:
    09 Off Road Delete Model
    None
    Also, what did you install?
     
  9. Jun 30, 2010 at 6:35 AM
    #9
    Mxpatriot

    Mxpatriot Arctic Prerunner

    Joined:
    Nov 18, 2009
    Member:
    #26163
    Messages:
    3,213
    Gender:
    Male
    First Name:
    Chase
    North Pole, Alaska
    Vehicle:
    '06 4x4 AP LT and Locked
    Money pit.
    Here's some things you can do to give us more information so we can help you better:

    Does it make the popping sound when the suspension cycles? If you put a tire up on a curb/rock/loading ramp would it make the "pop" even if you slowly eased up the obstacle to cycle the suspension?

    Does it make it on harsh bumps?

    Does it make it when you turn the wheels?
     
  10. Jun 30, 2010 at 9:08 AM
    #10
    HBMurphy

    HBMurphy Ban Pending

    Joined:
    Jun 27, 2009
    Member:
    #18993
    Messages:
    6,090
    Gender:
    Male
    First Name:
    Paul
    So California Coast
    Vehicle:
    09 Off Road Delete Model
    None
    Just wrapped up with car issue. If you want help right now call 714-404-1089
     
  11. Jun 30, 2010 at 2:36 PM
    #11
    HBMurphy

    HBMurphy Ban Pending

    Joined:
    Jun 27, 2009
    Member:
    #18993
    Messages:
    6,090
    Gender:
    Male
    First Name:
    Paul
    So California Coast
    Vehicle:
    09 Off Road Delete Model
    None
  12. Jun 30, 2010 at 2:38 PM
    #12
    mikesdoublecab

    mikesdoublecab LT Chase Truck

    Joined:
    Jun 15, 2008
    Member:
    #7334
    Messages:
    6,593
    Gender:
    Male
    First Name:
    Mohawk Mike
    Glendale, CA
    Vehicle:
    01 Tacoma DoubleCab V6 Prerunner
    Engage Offroad long travel front and rear with some fat tires.
    Paul, i got this itch in my lower back just above the crack that you could help me with since the OP ain't hitting you up...

    :drool:
     
  13. Jun 30, 2010 at 3:20 PM
    #13
    HBMurphy

    HBMurphy Ban Pending

    Joined:
    Jun 27, 2009
    Member:
    #18993
    Messages:
    6,090
    Gender:
    Male
    First Name:
    Paul
    So California Coast
    Vehicle:
    09 Off Road Delete Model
    None
    Man!!! I was wondering when you would ask!!! I will be up to the Motel 6 by your place and maybe we can watch Brokeback Mountain again! - the e-x-t-e-n-d-e-d version!!! :eek:
     
  14. Jun 30, 2010 at 3:25 PM
    #14
    mikesdoublecab

    mikesdoublecab LT Chase Truck

    Joined:
    Jun 15, 2008
    Member:
    #7334
    Messages:
    6,593
    Gender:
    Male
    First Name:
    Mohawk Mike
    Glendale, CA
    Vehicle:
    01 Tacoma DoubleCab V6 Prerunner
    Engage Offroad long travel front and rear with some fat tires.
    nah, last time we did that, you practically BROKE my BACK...
     
  15. Jun 30, 2010 at 3:29 PM
    #15
    HBMurphy

    HBMurphy Ban Pending

    Joined:
    Jun 27, 2009
    Member:
    #18993
    Messages:
    6,090
    Gender:
    Male
    First Name:
    Paul
    So California Coast
    Vehicle:
    09 Off Road Delete Model
    None
    Ah come on! Sure you may have been sore, but a Broken Back? :eek:
     
  16. Jul 1, 2010 at 12:16 AM
    #16
    dysfunctnlretard

    dysfunctnlretard Hi

    Joined:
    Jun 5, 2009
    Member:
    #18080
    Messages:
    3,760
    Gender:
    Male
    First Name:
    Manny
    CA
    Vehicle:
    2010 FJC
    55w HIDs, 16" Countersteer Offroads, Yokahama All Terrains, Demello Sliders
    :rofl:
     
  17. Jul 5, 2010 at 3:52 PM
    #17
    HBMurphy

    HBMurphy Ban Pending

    Joined:
    Jun 27, 2009
    Member:
    #18993
    Messages:
    6,090
    Gender:
    Male
    First Name:
    Paul
    So California Coast
    Vehicle:
    09 Off Road Delete Model
    None
    Just remincing about this thread.

    It reminded me of how scared my wife was when I asked her on our first date... She thought I was stalking her! For the life of me, I couldn't understand why! Here's a picture of our first date...

    [​IMG]
     
To Top