1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Help! All dash lights out, fuse still good

Discussion in 'Lighting' started by adamg214, Oct 18, 2013.

  1. Oct 18, 2013 at 11:43 AM
    #1
    adamg214

    adamg214 [OP] Member

    Joined:
    Oct 3, 2013
    Member:
    #113758
    Messages:
    5
    Gender:
    Male
    First Name:
    Adam
    94123
    Vehicle:
    2004 SR5 DoubleCab 4x4 Wht
    About two years ago, my dash lights started going out gradually. First it was just the left-most cluster, and I could hit the dash and they'd come back on. Then gradually I lost them all, and hitting the dash didn't help. Took it into the dealer and they fixed it which was great. Now, they're all out again. I tried a new fuse, and that didn't do anything. Could this be something else?

    Thanks for the help.

    1st gen 2004 Tacoma SR5 CrewCab 4x4.
     
  2. Oct 18, 2013 at 11:49 AM
    #2
    Jester243

    Jester243 ( ͡° ͜ʖ ͡°)

    Joined:
    Jun 25, 2008
    Member:
    #7552
    Messages:
    9,349
    Gender:
    Male
    First Name:
    Dan
    Spokane, WA
    Vehicle:
    2008 Doublecab 4x4 IRP
    Lifetime LED 70W headlights 10-8-14 (set #2) Sylvania Silverstar fogs, front side windows tinted 27% to match the others, added Tacomaworld.com sticker, suspension TSB as of 7-21-09, Devil Horns by Andres, BFG's, Alpine with Bluetooth and Ipod contols, Rear view mirror relocation bracket, Ultragauge...
    How long ago was it in the dealer, most work carries a small warranty on labor and parts.
     
  3. Oct 19, 2013 at 7:42 AM
    #3
    adamg214

    adamg214 [OP] Member

    Joined:
    Oct 3, 2013
    Member:
    #113758
    Messages:
    5
    Gender:
    Male
    First Name:
    Adam
    94123
    Vehicle:
    2004 SR5 DoubleCab 4x4 Wht
    Over 90 days ago unfortunately. Indicator lights still work, though, which is strange, like brights, o/d off, turn signals.
     
To Top