1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Help.. Check light, why?

Discussion in '2nd Gen. Tacomas (2005-2015)' started by vivica89, Jan 6, 2010.

  1. May 29, 2012 at 8:41 AM
    #41
    81shark

    81shark Well-Known Member

    Joined:
    Nov 7, 2008
    Member:
    #10567
    Messages:
    1,974
    Gender:
    Male
    Vehicle:
    2006 Base Access CP1

    wtf
     
  2. May 29, 2012 at 8:43 AM
    #42
    The Traveler

    The Traveler Desert Chief

    Joined:
    Mar 28, 2012
    Member:
    #75806
    Messages:
    6,829
    Gender:
    Male
    First Name:
    Matt
    SoCal
    Vehicle:
    1991 Toyota Pickup 4x4 Prerunner
  3. Jun 5, 2012 at 10:16 PM
    #43
    JakeInGrayTacoma

    JakeInGrayTacoma Active Member

    Joined:
    Feb 18, 2011
    Member:
    #51390
    Messages:
    42
    Gender:
    Male
    First Name:
    Jake
    SoCal Mtns
    Vehicle:
    95 4x4 gray tacoma
    Get back up to snuff cuz it wasn't maintained. I got xm radio in it.
    Did you ever get this taken care of? I got a P0170 code the other day. Same deal w/me, no vacuum leaks, cleaned out MAF, BUT I ddin't look at the o2 sensors. Where are they located on the truck? What about the fuel filter? You know where that is?:confused: Thanks for your help!
     
  4. Jun 6, 2012 at 1:03 AM
    #44
    Jimmyh

    Jimmyh Well-Known Member

    Joined:
    May 16, 2012
    Member:
    #78991
    Messages:
    7,526
    Gender:
    Male
    SC
    Vehicle:
    2012 Prerunner SR5
    That made me laugh!
     
  5. Aug 3, 2012 at 6:02 PM
    #45
    xaqori

    xaqori Grammer knotsy

    Joined:
    Jun 10, 2012
    Member:
    #80410
    Messages:
    1,942
    Gender:
    Male
    First Name:
    Zac
    Marietta, Georgia
    Vehicle:
    '06 4x4 Limo
    ARB lockers and 4.88s front and rear, OME 886s, Dakars, etc., Safari Snorkel, 17"Fuel Revolvers w/ 35x12.50r17 KM2s, fenders cut 3" all around, Pioneer AVH-P4400BH w/ Backup cam, CB/PA (PA Installed), Weathertech Digis, Foglight anytime, AP: front bumper, skids, and pack rack, custom sliders, Warn 9.5XP, dual VIAIR 480Cs with a 2.5gal tank, OTRATTW switches galore, URD y-pipe, RCI skids, LF 240s, etc.
    any idea how to fix P2714??? My Ultragauge is reading that; took it to the toyota dealer and they said a new transmission may be needed...(i actually bought a warranty 'cuz I've never had good luck with the transmission)
     
  6. Aug 15, 2012 at 7:07 PM
    #46
    BamaToy1997

    BamaToy1997 ASE Master Tech Vendor

    Joined:
    Jan 31, 2012
    Member:
    #71846
    Messages:
    10,704
    Gender:
    Male
    First Name:
    Bill
    Navarre, FL
    Vehicle:
    1997 Tacoma 4X4 AKA "Blue Beast"
    Multi-point tow hooks, new bored 2.7L engine, custom paint. 3 inch adjustable Fabtech front coils, 2.5 inch rear AAL. Front Aussie locker. LED bed lights. Full LED conversion interior and exterior. Relentless Fabrication front and rear bumpers. 4X4innovation sliders. BAMF bed rack. CVT rooftop tent.
    I believe thee is a TSB on that code that says first step is to reflash the PCM. You will need to find a place that can do that for you obviously.
     
  7. Sep 2, 2012 at 12:15 PM
    #47
    KTM Tacoma

    KTM Tacoma Member

    Joined:
    Dec 17, 2011
    Member:
    #68895
    Messages:
    14
    Gender:
    Male
    First Name:
    Ray
    North Ogden UT
    Vehicle:
    05 ext cab
    lift, shocks, skid plate, Tube Bumpers w/hitch off road lights, 17" tires Brush Plate
    I just fixed my problem with the check engine light...Duh, Bad aftermarket gas cap!!!
    Always check the easiest first. Hope this helps someone else.
     
  8. Jan 30, 2013 at 7:15 AM
    #48
    henrilepuf

    henrilepuf Well-Known Member

    Joined:
    Nov 28, 2012
    Member:
    #92032
    Messages:
    74
    Gender:
    Male
    First Name:
    henri
    Paraguay
    Vehicle:
    tacoma 2008 4x4
    tires load controller single kit
    About the CHECK ENGINE LIGHT : on my 2008 tacoma (45.000 miles), I had to replace twice the pump module fuel RSV (in the tank). I don't think it's normal. Did somebody meet this issue before ?? And would somebody have an idea about this problem ??
    And, one month before the failure of the pump, this check light turn on.....
    Thank for your suggestions or comment.
     
  9. Aug 22, 2013 at 8:55 AM
    #49
    CelsisTaco

    CelsisTaco Senior member.

    Joined:
    Jul 22, 2013
    Member:
    #108805
    Messages:
    972
    Gender:
    Male
    First Name:
    Anthony
    Des Monies, IA
    Vehicle:
    1995 Toyota Tacoma
    Tinted windows, K&N intake, 4 inch lift, Kenwood head unit, Kickers, 10 inch sub, 33 inch Firestone Destination A/T, Rear 5125 Bilistien shocks with 3 inch blocks plus an add-a-leaf, front 3" toytec. Armor: Rear northwest trail innovations weld together kit.
    If you don't really care.. about it being on.... Just unplug the battery, and the light wont be on there! (wouldn't recommend it, you'll never know what was actually wrong with it..)
     
  10. Sep 14, 2013 at 11:44 AM
    #50
    videoman12

    videoman12 New Member

    Joined:
    Sep 14, 2013
    Member:
    #112463
    Messages:
    1
    Gender:
    Male
    First Name:
    frank
    new york
    Vehicle:
    02PreRunner
    camper shell,trailer hitch
    how to check air /fuel sensor heater circuit response(bank1 sensor1
     
  11. Feb 20, 2015 at 9:01 AM
    #51
    LIRR

    LIRR Member

    Joined:
    Feb 18, 2015
    Member:
    #148971
    Messages:
    24
    Gender:
    Male
    First Name:
    Brian
    Pa
    Vehicle:
    02 SR5 Taco w/alts
    Nice posts, won't be wasting any paper when I print that one. lol
     
  12. Feb 20, 2015 at 9:08 AM
    #52
    LIRR

    LIRR Member

    Joined:
    Feb 18, 2015
    Member:
    #148971
    Messages:
    24
    Gender:
    Male
    First Name:
    Brian
    Pa
    Vehicle:
    02 SR5 Taco w/alts
    :cool: NICE POST :cool:
     
  13. Jun 22, 2016 at 4:33 AM
    #53
    jallen810

    jallen810 Member

    Joined:
    Dec 7, 2015
    Member:
    #171687
    Messages:
    5
    Gender:
    Male
    First Name:
    Jake
    Vehicle:
    2009 Grey Taco 4x4 Reg Cab 5 spd
    Gents,

    Think I have a similar but before I go replacing expensive parts I wanted your thoughts. Attached is a snapshot of my error codes

    image.jpg
     
  14. Aug 5, 2016 at 4:51 AM
    #54
    Ghost Pirate

    Ghost Pirate Member

    Joined:
    Aug 5, 2016
    Member:
    #193801
    Messages:
    7
    Gender:
    Male
    First Name:
    Larry
    Vehicle:
    2006 Tacoma 4x4 Double Cab V6 SE5
    K&N filter. Some body mods.
    Well if you overfill your gas tank by clicking it multiple times to force more gas in you can mess up the carbon canister happen to me doing the frame replacement they tilted my truck to far with a full tank of gas and caused the same condition still fighting Toyota trying to get the to fix it. 500 dollar plus part.
    This causes the engine light to come on after resets in the 300 plus mile range. Small emissions code.

    Ghost Pirate Out
     
  15. Aug 8, 2016 at 4:14 PM
    #55
    Scrubber3

    Scrubber3 Not really here

    Joined:
    Aug 6, 2016
    Member:
    #193874
    Messages:
    136
    Gender:
    Male
    Vehicle:
    2016 T4R XP 4X4 MS
    Can I play on this mummified thread?

    It's never a good idea to try to round up when you're filing up the gas tank. It will eventually lead to premature evap canister failure. Once it stops, leave it be.

    So, yeah.... any news on the fix OP?
     
  16. Aug 8, 2016 at 6:33 PM
    #56
    Klaunch

    Klaunch Member

    Joined:
    Apr 17, 2016
    Member:
    #184519
    Messages:
    7
    Gender:
    Male
  17. Aug 8, 2016 at 6:43 PM
    #57
    Notoneiota

    Notoneiota Well-Known Member

    Joined:
    Aug 24, 2014
    Member:
    #136871
    Messages:
    488
    Gender:
    Male
    First Name:
    Mike
    Grand Rapids, MN
    Vehicle:
    14 Tacoma DCLB TRD Sport
    Mostly stock with a few minor mods.
    Good God...I just liked a response on a post that's over 6 years old...who opened this casket?
     
    Markcal and Duck_Hunter like this.
  18. Aug 8, 2016 at 6:59 PM
    #58
    Duck_Hunter

    Duck_Hunter Well-Known Member

    Joined:
    May 27, 2016
    Member:
    #188056
    Messages:
    454
    Gender:
    Male
    Tejas
    Vehicle:
    2014 Tacoma TRD Off Road Manual
    ATC shell
    Perfect. :rofl:
     
  19. Aug 9, 2016 at 8:11 PM
    #59
    blackbirdmach6

    blackbirdmach6 Member

    Joined:
    Aug 9, 2016
    Member:
    #194202
    Messages:
    16
    I am getting a P0158 code as well! I just replaced both downstream o2 sensors, ignition coils, and spark plugs (used all denso oem parts). I checked the resistance across the o2 sensors and they read around 16 ohms at 90 degrees Fahrenheit(means they're good). I logged both downstream o2 sensors and found out that sensor corresponding to bank one would have a voltage that varies. o2 sensor correspding to bank 2 holds at a constant voltage (around .9 volts)I will post pictures to show this. Does anyone know where else I should go from here as far as diagnosing goes? goodCircuitbank1.jpg BadBank2.jpg
     

Products Discussed in

To Top