1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Help!! GOD AWFUL SQUEAKING NOISE!!

Discussion in '2nd Gen. Tacomas' started by eddieEndo, Jan 21, 2011.

  1. Jan 21, 2011 at 9:50 AM
    #1
    eddieEndo

    eddieEndo [OP] Well-Known Member

    Joined:
    Jul 6, 2009
    Member:
    #19357
    Messages:
    775
    Gender:
    Male
    First Name:
    Eddie
    Fullerton, CA
    Vehicle:
    Scion FRS
    I'm running bilstein 5100s and eibach coils in the front and all the other components are stock!! I've had them on there for about a year it feels like and recently there's been this GOD AWFUL squeaking coming from the front what the hell does this mean it's sooooooooo annoying :(
     
  2. Jan 21, 2011 at 9:54 AM
    #2
    steve o 77

    steve o 77 braaap

    Joined:
    Nov 29, 2009
    Member:
    #26726
    Messages:
    19,942
    Gender:
    Male
    First Name:
    Steven
    In a corn field, OH
    Vehicle:
    2001 4x4 5Spd Xtra Cab V6
    265/75/16 BFG A/T's, OME 881's, Wheelers 5 leaf pack, 5100's, Home Made Sliders
    Does it do it when idling? or only when moving?
     
  3. Jan 21, 2011 at 9:55 AM
    #3
    eddieEndo

    eddieEndo [OP] Well-Known Member

    Joined:
    Jul 6, 2009
    Member:
    #19357
    Messages:
    775
    Gender:
    Male
    First Name:
    Eddie
    Fullerton, CA
    Vehicle:
    Scion FRS
    only when moving, or if my car was in place and i shake the front end..

    could it just be dust in my shocks?? I never put the dust protectors on my struts when i was installing them, my car doesn't feel like anything is performing differently
     
  4. Jan 21, 2011 at 9:59 AM
    #4
    Chachie

    Chachie Well-Known Member

    Joined:
    Dec 23, 2009
    Member:
    #28047
    Messages:
    1,852
    Gender:
    Male
    First Name:
    Justin
    Nor Cal
    Vehicle:
    '06 TRD OR, 4x4, Auto, 6" Fabtech, 35's
    Locker mod, Anytime fog mod, always 400w mod.
    Mine squeaks like a sonofa bitch too. But i have a fabtech up front. But im thinking it is my balljoints. Cause i beat on my truck pretty hard.
     
  5. Jan 21, 2011 at 10:01 AM
    #5
    eddieEndo

    eddieEndo [OP] Well-Known Member

    Joined:
    Jul 6, 2009
    Member:
    #19357
    Messages:
    775
    Gender:
    Male
    First Name:
    Eddie
    Fullerton, CA
    Vehicle:
    Scion FRS

    how much $ you think it would cost to remedy this situation, possibly just getting ucas??
     
  6. Jan 21, 2011 at 10:04 AM
    #6
    S.B.

    S.B. Well-Known Member

    Joined:
    Jun 24, 2009
    Member:
    #18838
    Messages:
    3,562
    Gender:
    Male
    First Name:
    Sean
    SD, CA Now in Colorado Springs, CO
    Vehicle:
    08 Taco 4x4 TRD OffRoad Rugged Trail
    SAW 2.0s, Wheeler's 3-leaf AAL, On Board Air, 255/85/16 Cooper Discover S/T, CBI Sliders, Built right UCAs, 6" Harbor Freight Lights (converted to HIDs), KC Slim Lights.
    The ball joints on the ucas should not squeak unless the boot on them broke and they are dry, then they could squeak.

    Is everything except the shocks and springs in the front stock? And are you 100% sure its from the front, like did you listen from out side the truck?
     
  7. Jan 21, 2011 at 10:05 AM
    #7
    Chachie

    Chachie Well-Known Member

    Joined:
    Dec 23, 2009
    Member:
    #28047
    Messages:
    1,852
    Gender:
    Male
    First Name:
    Justin
    Nor Cal
    Vehicle:
    '06 TRD OR, 4x4, Auto, 6" Fabtech, 35's
    Locker mod, Anytime fog mod, always 400w mod.

    Im putting uca's in the very near future. Ill let you know how it turns out. :thumbsup:
     
  8. Jan 21, 2011 at 10:06 AM
    #8
    eddieEndo

    eddieEndo [OP] Well-Known Member

    Joined:
    Jul 6, 2009
    Member:
    #19357
    Messages:
    775
    Gender:
    Male
    First Name:
    Eddie
    Fullerton, CA
    Vehicle:
    Scion FRS

    yeah 100% sure it's from the front, before it was from the front AND back but i pressure washed the shit out of my leaf springs and that went away

    it's very noticable from the front passenger side

    anyone have to replace their balljoints before how much did it run you
     
  9. Jan 21, 2011 at 10:07 AM
    #9
    Chachie

    Chachie Well-Known Member

    Joined:
    Dec 23, 2009
    Member:
    #28047
    Messages:
    1,852
    Gender:
    Male
    First Name:
    Justin
    Nor Cal
    Vehicle:
    '06 TRD OR, 4x4, Auto, 6" Fabtech, 35's
    Locker mod, Anytime fog mod, always 400w mod.
    I am to the point of squeezing grease out of the bottom of the boot. haha
     
  10. Jan 21, 2011 at 10:07 AM
    #10
    S.B.

    S.B. Well-Known Member

    Joined:
    Jun 24, 2009
    Member:
    #18838
    Messages:
    3,562
    Gender:
    Male
    First Name:
    Sean
    SD, CA Now in Colorado Springs, CO
    Vehicle:
    08 Taco 4x4 TRD OffRoad Rugged Trail
    SAW 2.0s, Wheeler's 3-leaf AAL, On Board Air, 255/85/16 Cooper Discover S/T, CBI Sliders, Built right UCAs, 6" Harbor Freight Lights (converted to HIDs), KC Slim Lights.
    Take a look under there and see if there is any thing broken/ torn.
     
  11. Jan 21, 2011 at 10:08 AM
    #11
    eddieEndo

    eddieEndo [OP] Well-Known Member

    Joined:
    Jul 6, 2009
    Member:
    #19357
    Messages:
    775
    Gender:
    Male
    First Name:
    Eddie
    Fullerton, CA
    Vehicle:
    Scion FRS

    see the thing is i don't notice any grease or fluids leaking from my suspension components
     
  12. Jan 21, 2011 at 10:09 AM
    #12
    S.B.

    S.B. Well-Known Member

    Joined:
    Jun 24, 2009
    Member:
    #18838
    Messages:
    3,562
    Gender:
    Male
    First Name:
    Sean
    SD, CA Now in Colorado Springs, CO
    Vehicle:
    08 Taco 4x4 TRD OffRoad Rugged Trail
    SAW 2.0s, Wheeler's 3-leaf AAL, On Board Air, 255/85/16 Cooper Discover S/T, CBI Sliders, Built right UCAs, 6" Harbor Freight Lights (converted to HIDs), KC Slim Lights.
    Ya you need to fix or replace it before it become dry and causing it to fail.
     
  13. Jan 21, 2011 at 10:10 AM
    #13
    Chachie

    Chachie Well-Known Member

    Joined:
    Dec 23, 2009
    Member:
    #28047
    Messages:
    1,852
    Gender:
    Male
    First Name:
    Justin
    Nor Cal
    Vehicle:
    '06 TRD OR, 4x4, Auto, 6" Fabtech, 35's
    Locker mod, Anytime fog mod, always 400w mod.
    Im picking up all pro arms on wednesday. :D:D:D:D:thumbsup: Along with fenders and king coilovers! Time for a facelift!!!!
     
  14. Jan 23, 2011 at 8:09 AM
    #14
    eddieEndo

    eddieEndo [OP] Well-Known Member

    Joined:
    Jul 6, 2009
    Member:
    #19357
    Messages:
    775
    Gender:
    Male
    First Name:
    Eddie
    Fullerton, CA
    Vehicle:
    Scion FRS
    damnit I greased the ball joints and pressure washed my front end and the squeak went away for 15 minutes!! I cant identify exactly where it's coming from I'M GOING CRAZY
     
To Top