1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

help!! my temp gauge and fuel gauge dont work

Discussion in '1st Gen. Tacomas' started by tldpro317, Dec 10, 2009.

  1. tldpro317

    tldpro317 [OP] New Member

    Joined:
    Nov 29, 2009
    Member:
    #26739
    Messages:
    1
    Gender:
    Male
    Hey, I have a 95 4x4 ext cab sr5 and my fuel gauge and temp gauge dont work, every once in a while the temp gauge will bump up but then it just drops back to zero, the fuel gauge doesnt ever attempt to move, I know it could be the sending unit but wondering if the two are somehow connected. also my cruise wont work, It lights up on the dash but wont take over the speed. any opinions would be great.
     
  2. tacoman101

    tacoman101 Well-Known Member

    Joined:
    Jul 11, 2009
    Member:
    #19550
    Messages:
    1,074
    Gender:
    Male
    First Name:
    scott
    vermont
    Vehicle:
    2001 Tacoma sr5 xtra cab 4wd
    blue led headlights, 285/75/16 grabber AT2's, custom pedals, custom shifter, flowmaster 40 series muffler, bedlinered fender flares, 2.5" lift kit via shackles and spacers, custom exhaust out the back, chrome exhaust tip, and Herculined bed, Weathertech floormats, Cabelas Trail Gear Camo Seat Covers ... Nice thing was I got the truck for $4000
    Check the fuses...mabye:confused:
     
  3. EnolaGaia

    EnolaGaia Well-Known Member

    Joined:
    Sep 9, 2006
    Member:
    #9
    Messages:
    1,136
    Gender:
    Male
    Midwest USA
    Vehicle:
    '01 & '04 S-Runners
    01 SR: Double Cab conversion, S/C, lowered.
    Is it an aftermarket cruise control? If so - what make / model?
     
  4. EnolaGaia

    EnolaGaia Well-Known Member

    Joined:
    Sep 9, 2006
    Member:
    #9
    Messages:
    1,136
    Gender:
    Male
    Midwest USA
    Vehicle:
    '01 & '04 S-Runners
    01 SR: Double Cab conversion, S/C, lowered.
    One thing the fuel and temp gauges have in common is the ground point. It's located behind the left kick panel. The primary ground wire you're looking for is brown.

    Are you having 'issues' with your speedometer and / or tach? Both these items are on the same circuit, so I'm having a hard time figuring out how you'd be getting 'fail' on the temp and fuel gauges alone.

    If it's a Toyota cruise control, your cruise control ECU ties into the cluster jointly (co-wired via connector) with the 4WD ECU and the main / engine ECU. I can't figure out how a bad cruise ECU connection could cause the problems you listed without affecting the engine management and the 4WD functions.
     
To Top