1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Help please, things aren't working on my truck

Discussion in 'Technical Chat' started by MMazz365, Feb 20, 2011.

  1. Feb 20, 2011 at 5:53 PM
    #1
    MMazz365

    MMazz365 [OP] Well-Known Member

    Joined:
    Nov 7, 2009
    Member:
    #25564
    Messages:
    649
    Gender:
    Male
    First Name:
    Michael
    NY
    Vehicle:
    TRD Off Road
    -flowmaster dual side exit exhaust -3 inch lift -cb radio -scanner -DTRL's -Fogs Anytime -Truxedo Soft Tonnahu Cover -eyelids -grillcraft upper and lower -fogs behind the grill
    I have a 2010 trd offroad with lots of mods. Never had a problem with electrical wise until tonight when I was going to walmart my check engine light came on, as did my traction control, and airbag, and maintenance light are all on. The passenger seatbelt light isn't working and neither is the outside temp. Also the turn signals and back up lights and back up camera aren't Turning on. What's f$&@Ed up is that my 4 ways work and everything else seems fine oh and my damn speedometer isn't working. WTF. I'm pissed. Help please
     
  2. Feb 20, 2011 at 5:56 PM
    #2
    Brunes

    Brunes abides.

    Joined:
    May 31, 2008
    Member:
    #7011
    Messages:
    17,641
    Gender:
    Male
    First Name:
    Rotorhead
    DC or New Jersey - Depends on the day....
    Vehicle:
    08 Red/Graphite and Satin Black
    Inside: Tint, Wet Okole 1/2 Piped Red/Black Covers, Black Weathertech Digital Fit Mats, URD Short Throw w/ TWM Weighted Knob, USA Spec iPod adapter. Outside: 4300K Retro w/ Angel Eyes and Red Shrouds, 5000K Blazer Fog Light Retrofit, Debadge, Bed Locking Handle, Satin Black Rims Performance: TRD/Steigmeier Blower w/ 2.7 Pulley. 668 Injectors and 320 LPH AEM Fuel pump. URD UCON and 7th Injector. DTLT Headers, URD Y-Pipe, Wicked Flow Muffler. Suspension: Both: OME Shocks Front: 886X's and TC UCAs Rear: Dakars Armor: Relentless Front Bumper Relentless High Clearance Rear w/ Tire/Rotopax Swing Out Relentless Front, Mid, and TCase skids BAMF Diff Skid Recovery and Spares: Fullsize Spare Tire 2x2 gal Rotopax 1x1 gal Rotopax 1x1 gal Water Rotopax Warn 9.5XP-S Winch Hi-Lift Extreme 60" Ironman Off-Road Recovery Kit
    Spiral cable issue maybe?? Sounds like there is something else there tho...I can't see the connection between all of those tho....

    And since I'm guessing it's still under warranty...Get that rig looked at by the "pros"
     
  3. Feb 20, 2011 at 5:57 PM
    #3
    OZ-T

    OZ-T Quite an experience to live in fear , isn't it ?

    Joined:
    Dec 15, 2009
    Member:
    #27584
    Messages:
    38,652
    Gender:
    Male
    First Name:
    Peter North
    British Columbia
    Vehicle:
    Mag Grey 09 Trd Sport DCLB 4x4
    OME 885x , OME shocks and Dakars , Wheelers SuperBumps front and rear , 275/70/17 Hankook ATm , OEM bed mat , Weathertech digifit floor liners , Weathertech in-channel vents , headache rack , Leer 100RCC commercial canopy , TRD bedside decals removed , Devil Horns by Andres , HomerTaco Satoshi
    Dealer time
     
  4. Feb 20, 2011 at 6:01 PM
    #4
    MMazz365

    MMazz365 [OP] Well-Known Member

    Joined:
    Nov 7, 2009
    Member:
    #25564
    Messages:
    649
    Gender:
    Male
    First Name:
    Michael
    NY
    Vehicle:
    TRD Off Road
    -flowmaster dual side exit exhaust -3 inch lift -cb radio -scanner -DTRL's -Fogs Anytime -Truxedo Soft Tonnahu Cover -eyelids -grillcraft upper and lower -fogs behind the grill
    Hell yeah when I get home from my 2 hr ride home from upstate she's going straight to the dealer
     
  5. Feb 20, 2011 at 6:14 PM
    #5
    larryde09

    larryde09 Well-Known Member

    Joined:
    Jul 3, 2010
    Member:
    #39759
    Messages:
    560
    Gender:
    Male
    First Name:
    Larry
    Rochester, NY
    Vehicle:
    (Traded-in) 06 2.7L 5-spd SR5 4x4
    K&N Intake, Magnaflow Cat-back Exhaust, Altezza Tail Lights, Pop&Lock Tailgate Lock, Extang Trifecta Tonneau Cover, PIAA foglights with stock switch, DrawTite Hitch, OBX Shift Knob, Hood Protector, Vent Visors, DIY step bars/sliders/running boards, DIY Bed Lights, DIY Running Board/Ground Lights, DIY Tailgate Electrical Box (12V socket, voltage and current gauges), DIY Internal Lighting (coming soon), Aftermarket switches in stock dash blanks, Sony Head Unit, Illuminated 4x4 switch mod
    Be careful if you have electrical mods, the dealer might give you a hard time regarding warranty.

    It could be anything...blown fuse, sneak ground/short, or a mod you did might be interacting the factory circuit in a weird way.
     
  6. Feb 20, 2011 at 6:24 PM
    #6
    MMazz365

    MMazz365 [OP] Well-Known Member

    Joined:
    Nov 7, 2009
    Member:
    #25564
    Messages:
    649
    Gender:
    Male
    First Name:
    Michael
    NY
    Vehicle:
    TRD Off Road
    -flowmaster dual side exit exhaust -3 inch lift -cb radio -scanner -DTRL's -Fogs Anytime -Truxedo Soft Tonnahu Cover -eyelids -grillcraft upper and lower -fogs behind the grill
    Well let's see I have blue lights, rear blinking lights, fogs behind my grill, hids, scanner, and that's all I can think of. Imma disconnect them before I go there
     
  7. Feb 20, 2011 at 9:37 PM
    #7
    island808

    island808 Me l've got brains.

    Joined:
    Oct 9, 2010
    Member:
    #44414
    Messages:
    1,892
    Gender:
    Male
    First Name:
    Jedediah
    hawaii
    Vehicle:
    '10 6speed 4x4 access cab
    THe lights can screw up a lot of stuff.. but never seen em put on the CEL. Though who knows. Maybe water infiltration to the dash.

    Does the tacoma not use the wires to transmit data like a lot of newer cars do?

    If it does, man the things you can do.
     
  8. Feb 21, 2011 at 3:49 PM
    #8
    larryde09

    larryde09 Well-Known Member

    Joined:
    Jul 3, 2010
    Member:
    #39759
    Messages:
    560
    Gender:
    Male
    First Name:
    Larry
    Rochester, NY
    Vehicle:
    (Traded-in) 06 2.7L 5-spd SR5 4x4
    K&N Intake, Magnaflow Cat-back Exhaust, Altezza Tail Lights, Pop&Lock Tailgate Lock, Extang Trifecta Tonneau Cover, PIAA foglights with stock switch, DrawTite Hitch, OBX Shift Knob, Hood Protector, Vent Visors, DIY step bars/sliders/running boards, DIY Bed Lights, DIY Running Board/Ground Lights, DIY Tailgate Electrical Box (12V socket, voltage and current gauges), DIY Internal Lighting (coming soon), Aftermarket switches in stock dash blanks, Sony Head Unit, Illuminated 4x4 switch mod
    Disconnect them and see if that fixes the problem first. Did you install any of these mods recently? It could be the cause of your problems.
     
  9. Feb 23, 2011 at 7:41 PM
    #9
    MMazz365

    MMazz365 [OP] Well-Known Member

    Joined:
    Nov 7, 2009
    Member:
    #25564
    Messages:
    649
    Gender:
    Male
    First Name:
    Michael
    NY
    Vehicle:
    TRD Off Road
    -flowmaster dual side exit exhaust -3 inch lift -cb radio -scanner -DTRL's -Fogs Anytime -Truxedo Soft Tonnahu Cover -eyelids -grillcraft upper and lower -fogs behind the grill
    alright turns out there was a pinched wire under the dash and it shorted out a fuse that i must have missed while going threw them... only cost me about 140 bec he fixed some wires and they said it wasnt under warrenty... what ever i got my baby back and shes healthy :) lol
     
  10. Feb 23, 2011 at 7:52 PM
    #10
    TexAggie

    TexAggie Well-Known Member

    Joined:
    Dec 16, 2010
    Member:
    #47773
    Messages:
    1,427
    Gender:
    Male
    First Name:
    Eric
    Odessa, TX
    Vehicle:
    17
    OME Lift
    Good Deal!!!
     
To Top