1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

HELP: Thud coming from 3" lift install

Discussion in '2nd Gen. Tacomas (2005-2015)' started by NemoRific, Mar 17, 2011.

  1. Mar 17, 2011 at 3:46 AM
    #1
    NemoRific

    NemoRific [OP] Member

    Joined:
    Feb 14, 2011
    Member:
    #51135
    Messages:
    12
    Gender:
    Male
    HAWAII
    Vehicle:
    08 TACOMA DOUBLE CAB 4X4 3" OME LIFT LR UCA
    3" OME Lift LR UCA Grille Craft MX Grille Projector/6000k HID 8000k HID Fog Lights
    I recently installed a complete 3" OME lift with LR UCA on my 08 Double Cab Tacoma 4X4 and noticed a slight thud coming from under my driver's side floor board. It's been starting at the mid 20's and continues into the 40's. The frequency increases in relation to the speed. I tried putting it in 4 HI to see if it would go away and I'm pretty sure it does, if not, it's barely noticeable. Any ideas? Any more info need, just let me know. Thanks for the help in advance.
     
  2. Mar 17, 2011 at 3:44 PM
    #2
    NemoRific

    NemoRific [OP] Member

    Joined:
    Feb 14, 2011
    Member:
    #51135
    Messages:
    12
    Gender:
    Male
    HAWAII
    Vehicle:
    08 TACOMA DOUBLE CAB 4X4 3" OME LIFT LR UCA
    3" OME Lift LR UCA Grille Craft MX Grille Projector/6000k HID 8000k HID Fog Lights
    to the top, please.
     
To Top