1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

HID Install help

Discussion in 'Lighting' started by bellassaiw10, Dec 25, 2010.

  1. Dec 25, 2010 at 12:02 PM
    #1
    bellassaiw10

    bellassaiw10 [OP] Formally afroman5015

    Joined:
    Jun 16, 2010
    Member:
    #39032
    Messages:
    4,763
    Gender:
    Male
    Currituck NC
    Vehicle:
    00 4WD Prerunner
    I ordered some 8K HIDs from hidkit.com and hooked everything up now they do not come one ? the diagrams are a bit confusing but its all plug and so im assuming any ideas :confused:
     
  2. Dec 25, 2010 at 12:05 PM
    #2
    crf69

    crf69 scraping my emblems off my plasti-dip

    Joined:
    May 18, 2010
    Member:
    #37348
    Messages:
    3,575
    Gender:
    Male
    First Name:
    Ryan
    Ohio
    Vehicle:
    06 TRD OR BSP cab'n 1/2
    ummm yeah
    show a pic of what you got goin on.....do not touch it
     
  3. Dec 25, 2010 at 9:45 PM
    #3
    bellassaiw10

    bellassaiw10 [OP] Formally afroman5015

    Joined:
    Jun 16, 2010
    Member:
    #39032
    Messages:
    4,763
    Gender:
    Male
    Currituck NC
    Vehicle:
    00 4WD Prerunner
  4. Dec 25, 2010 at 10:22 PM
    #4
    medic2230

    medic2230 Ditch Doctor

    Joined:
    Oct 13, 2008
    Member:
    #9942
    Messages:
    10,799
    Gender:
    Male
    First Name:
    Murph
    Columbus, Ga
    Vehicle:
    2011 Taco 4x4 DCLB
    20% Tint, OME 3"complete lift with Dakar's, Light Racing UCA's, 285/75/16 Nitto Terra Grapplers, 10 HP TW sticker, Ultraguage, B.A.M.F. Rock Sliders, MedicFab Bed Rack, Relentless front bumper
    I'm think there is suppose to be a ground somewhere. Mine had a separate ground. Mine had a harness that hooked up to the battery or powerpoint and then to a relay, mine only had one connection that hooked to an actual headlight connection to control the relay to turn them on.
     
  5. Dec 25, 2010 at 10:26 PM
    #5
    Tacomanator

    Tacomanator Boiling denim and bangin whores

    Joined:
    Jul 25, 2010
    Member:
    #40746
    Messages:
    4,584
    Gender:
    Male
    First Name:
    Clam Slammer
    Here
    King 2.5" extended travel coilovers with compression adjusters, Camburg UCA's, King 2.5" rear shocks, Volant cold air intake with ram air scoop.
    check out youtube, they have step by step videos on there.
     
  6. Dec 26, 2010 at 10:08 AM
    #6
    bellassaiw10

    bellassaiw10 [OP] Formally afroman5015

    Joined:
    Jun 16, 2010
    Member:
    #39032
    Messages:
    4,763
    Gender:
    Male
    Currituck NC
    Vehicle:
    00 4WD Prerunner
    yeah i think there was supposed to be a relay kit in the box
     
To Top