1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

How many defect repairs have you had under warranty (not aftermarket related)

Discussion in 'Technical Chat' started by solus, Oct 20, 2010.

  1. Oct 20, 2010 at 2:08 PM
    #1
    solus

    solus [OP] HOME!!!

    Joined:
    Aug 1, 2009
    Member:
    #20487
    Messages:
    4,491
    Gender:
    Male
    First Name:
    Mark
    Bremerton, WA
    Vehicle:
    RR 4wd SR5
    I'm beginning to question Toyota's reliability... My 2008 has had three repairs that needed done under warranty within the two years that I've owned it. I had a Dodge SRT-4 and had ZERO repairs over the same time frame... both were new. I've had Honda's too with no problems. Considering the bad reliability rep that Dodge gets whereas Toyota has good rep (until recently)... its just weird. Maybe I just have a defect prone truck...

    1: Blown axle seal
    2. Blown Axle seal again... with damage to axle and front differential
    3. Throw out bearing

    not to mention the heavy load TSB and tailgate TSB

    its a little ridiculous... btw I have 31K on the odo

    just curious about who else has had several defect related repairs...

    not caused by aftermarket parts or offroading
     
  2. Oct 20, 2010 at 2:09 PM
    #2
    Incognito

    Incognito μολὼν λαβέ

    Joined:
    May 25, 2009
    Member:
    #17626
    Messages:
    13,625
    Gender:
    Male
    First Name:
    Colton
    VA
    Vehicle:
    2012 Pyrite AC TRD OR
    See Build thread
    Nothing wrong whatsoever on my '10 with 7K on it.
     
  3. Oct 20, 2010 at 2:22 PM
    #3
    BakoTruck

    BakoTruck Well-Known Member

    Joined:
    May 1, 2009
    Member:
    #16674
    Messages:
    2,823
    Gender:
    Male
    First Name:
    Herbie Hancock
    Bakersfield, CA
    Vehicle:
    05 PreRunner TRD
    Mostly stock for now, I have added a cb radio, various cheap mods and I plan on adding aftermarket wheels and other items in the future.
    Toyota's quality and reliability has dropped, and that's not from my mouth but from the mouth of Mr. Toyoda from Japan.
     
  4. Oct 20, 2010 at 2:28 PM
    #4
    solus

    solus [OP] HOME!!!

    Joined:
    Aug 1, 2009
    Member:
    #20487
    Messages:
    4,491
    Gender:
    Male
    First Name:
    Mark
    Bremerton, WA
    Vehicle:
    RR 4wd SR5
    give it time... maybe I got a bad batch though
     
  5. Oct 20, 2010 at 2:28 PM
    #5
    Trachito

    Trachito Well-Known Member

    Joined:
    May 7, 2010
    Member:
    #36692
    Messages:
    654
    Gender:
    Male
    New Orleans
    05

    squeeky clutch pedal that was super annoying
    tailgate bent from loading a motorbike. it's been redesigned for strength, but warranty didn't cover it so i need a new one
     
  6. Oct 20, 2010 at 2:29 PM
    #6
    Incognito

    Incognito μολὼν λαβέ

    Joined:
    May 25, 2009
    Member:
    #17626
    Messages:
    13,625
    Gender:
    Male
    First Name:
    Colton
    VA
    Vehicle:
    2012 Pyrite AC TRD OR
    See Build thread
    Don't jinx it... :eek:
     
  7. Oct 20, 2010 at 2:30 PM
    #7
    solus

    solus [OP] HOME!!!

    Joined:
    Aug 1, 2009
    Member:
    #20487
    Messages:
    4,491
    Gender:
    Male
    First Name:
    Mark
    Bremerton, WA
    Vehicle:
    RR 4wd SR5
    oh yeah I forgot I have the squeaky pedal too... I guess I've gotten use to that
     
  8. Oct 20, 2010 at 2:31 PM
    #8
    Jester243

    Jester243 mod status????

    Joined:
    Jun 25, 2008
    Member:
    #7552
    Messages:
    10,004
    Gender:
    Male
    First Name:
    Dan
    Spokane, WA
    Vehicle:
    2016 Trail Premium 4Runner w/ KDSS
    '08 just the suspension TSB so far, fingers crossed...
     
  9. Oct 20, 2010 at 2:32 PM
    #9
    solus

    solus [OP] HOME!!!

    Joined:
    Aug 1, 2009
    Member:
    #20487
    Messages:
    4,491
    Gender:
    Male
    First Name:
    Mark
    Bremerton, WA
    Vehicle:
    RR 4wd SR5
    I saw those hearings too... just sad because I bought a Toyota partially for their reliability rep...
     
  10. Oct 20, 2010 at 2:38 PM
    #10
    Trachito

    Trachito Well-Known Member

    Joined:
    May 7, 2010
    Member:
    #36692
    Messages:
    654
    Gender:
    Male
    New Orleans
    +1 after my tailgate went out i was so pissed and disappointed in their workmanship and customer service. i expected them to replace a weak part. now i gotta blow $550 on a new tailgate and paint it myself. it's gonna have to wait though cuz it's not in the budget right now, and not necessary.
    i could buy a used one but i'd have to know it came from a newer taco, otherwise i might just be buying another weak part.
     
  11. Oct 20, 2010 at 2:44 PM
    #11
    PB65stang

    PB65stang Well-Known Member

    Joined:
    Dec 2, 2009
    Member:
    #26900
    Messages:
    1,636
    Gender:
    Male
    First Name:
    Patrick
    Kansas City
    Vehicle:
    2006 Infiniti M35x
    I had to do the whole radio replacement thing on my '09, and the dealer still refuses to do the tranny TSB even though multiple people have ridden in my truck and agree it shifts weird. I guess that issue is more dealer-related than Toyota. Also have a couple rattles.

    I think the dependability (engine, other mechanicals, getting me from place to place) is still there, but the attention to detail and fit and finish has definitely deteriorated. Still a very good truck.
     
  12. Oct 20, 2010 at 2:51 PM
    #12
    jerysan

    jerysan Well-Known Member

    Joined:
    Dec 7, 2009
    Member:
    #27176
    Messages:
    137
    Gender:
    Male
    San Diego
    Vehicle:
    09 PreRunner TRD Off Road SB
    Flowmaster 40 Delta Flow, K&N Air filter, TSB Rear AAL with 1" Block & 5100's, OME 885x with OME Nitrocharged and Toytec Top spacers, Built Right UCA's , Satoshi Grille, HID's, Bull Bar,
    09 Tacoma, I had the valve cover gasket replaced at 4k, Subwoofer replaced, and just recently had the headlights replace because they were peeling.
    Did do all the TSB's...Add a leaf, steering column.
     
  13. Oct 20, 2010 at 2:55 PM
    #13
    tacoman007

    tacoman007 ignorance is bliss,

    Joined:
    Feb 23, 2010
    Member:
    #31959
    Messages:
    357
    Gender:
    Male
    First Name:
    Josh
    san diego
    Vehicle:
    07SR5ACCESSCABDEBAGED4X4
    alpine headunit,12'' rockford fosgate sub,ipod in g-box,drop in K&N, Marine decor,5100's front/rear,uniden pc68xl,radioshack PA speaker
    cv boot exploded,rear axle replaced,throw out bearing!!!!!!,lost a bed pocket
     
  14. Oct 20, 2010 at 3:01 PM
    #14
    schiz94

    schiz94 Thread Jacker

    Joined:
    May 26, 2009
    Member:
    #17674
    Messages:
    4,234
    Gender:
    Male
    First Name:
    Caleb
    Bellingham,WA
    Vehicle:
    08 Tacoma Reg Cab
    Morimoto Projector Retrofit, alpine cda-105,Wheelskins leather wheel cover, wet okoles,5% tint on back and 24% on front two windows,Debadged tailgate,custom sockmonkey centercap decals, xr rims pced gloss black.
    ive only had the clutch squeak. got it fixed once. and it came back. to lazy to get it fixed again just for it to come back again. :(
     
  15. Oct 20, 2010 at 7:22 PM
    #15
    supralight

    supralight Well-Known Member

    Joined:
    Aug 20, 2009
    Member:
    #21479
    Messages:
    674
    Gender:
    Male
    First Name:
    Dan
    Earth
    Vehicle:
    2013 4Runner limited
    on my '09, I had to replace throw-out bearing at 40K kilometers
     
  16. Oct 20, 2010 at 7:42 PM
    #16
    1337Taco

    1337Taco Sold all 3

    Joined:
    May 9, 2008
    Member:
    #6504
    Messages:
    7,373
    Gender:
    Male
    First Name:
    Kevin
    NorCal
    Vehicle:
    2012 4x4
    Kings
    05. No problems yet that aren't aftermarket related.
     
  17. Oct 20, 2010 at 7:43 PM
    #17
    OffroadToy

    OffroadToy This ain't Dodge City, and you ain't Bill Hickok

    Joined:
    Sep 12, 2009
    Member:
    #22680
    Messages:
    5,260
    Gender:
    Male
    Vehicle:
    07 TRD OFFROAD 4x4 VSC/TRAC/DAC/HAC
    snugtop, piaa, weathertech, westin, oem bed mat, trd seat covers, avs inchannel vent visors, 2" suspension lift, front diff drop, rear differential breather extension, oil filter drain hose, a/c drain hose extention & reroute, front window tint, cat theft protection plate, tailgate clamp mod, xpel headlight/foglight protecters, oem block heater, bfg 265/75R/16 a/t k/o's, cabin air rodent protection screen, rcbs illuminated 4X4 switch mod
    On my 07 I had the intermittant start tsb done and a tail light bulb replaced.
     
  18. Oct 20, 2010 at 7:45 PM
    #18
    Jason'sLawnCare

    Jason'sLawnCare Prepared for Bambi

    Joined:
    Apr 12, 2009
    Member:
    #15878
    Messages:
    12,365
    Gender:
    Male
    First Name:
    Jason
    Jacksonville Florida
    Vehicle:
    08 4x4 Double Cab TRD Rugged Trail
    CBI Moab 2.0, CBI Trail Rider 2.0, CBI sliders w/kickout, Superwinch EPi9.0S, OME sport shocks w/886 coils, OME n182, 1.5" aal, JasonBuilt 3/16th full belly skid, BuiltRight uca, Body Mount Chop, 285/75/16 km2's, Rear cat delete, exhaust crossover rerouted, Fog light anytime, Locker mod, Rear leaf tsb, Debadged, Uws Tool Box, Electric Exhaust Cutout, AFE Pro Dry S, Kiwi Wifi, Diff Breather Relocated, Grom Ipod Adapter, Dual Diehard platinum batteries isolated by BlueSea marine switch
    belt tensioner failing but I can't say if it was from wheeling or not as dirt/mud may have caused it.
     
  19. Oct 20, 2010 at 7:50 PM
    #19
    beckleyota

    beckleyota Well-Known Member

    Joined:
    Nov 26, 2009
    Member:
    #26546
    Messages:
    155
    Gender:
    Male
    wv
    Vehicle:
    o7 taco
    vent visors,tint,kenwood headunit, trex eyelids,kenwood componants,5100's,1 aal,cabellas seatcovers,painted stereo suround
    i had a powersteering pump replaced at 30000, a throught bearing and a wheel bearing at 40000. The leafs squeek from time to time along with the clutch pedal.
     
  20. Oct 20, 2010 at 8:44 PM
    #20
    Isthatahemi

    Isthatahemi Well-Known Member

    Joined:
    Apr 29, 2009
    Member:
    #16582
    Messages:
    1,156
    Gender:
    Male
    Vehicle:
    TRD OFF ROAD
    BFG AT's, Weathertechs, Hoppy's brake controller.
    See my sig.
    Bone stock truck, treated the same as my last 6 trucks.
    It's a truck designed to be used lightly, or heed all the Fanboy warnings about how everything I have always done with my trucks, is abuse, now that I have a Toyota. SICKENING.
    I suppose abuse broke my stereo, blower fan, wiper motor, and caused my 4WD to never have worked properly. Or the alternator only putting out 13.5 volts.
    Toyota is slipping, and I will not buy another. My wife is sick of taking HER daily driver, (I only use it on weekends) in every couple months for this BS.
    Did I mention my rearview mirror was falling off? Cripes
     
To Top