1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

I absolutely hate comcast!!!

Discussion in 'Off-Topic Discussion' started by Bennett707, Mar 23, 2013.

  1. Mar 23, 2013 at 11:34 PM
    #1
    Bennett707

    Bennett707 [OP] Yeti Hunter

    Joined:
    Apr 28, 2012
    Member:
    #77793
    Messages:
    10,540
    Gender:
    Male
    Oregon
    Vehicle:
    '04 V6 3.4 TRD
    Successful GB's: Bora Wheel Spacers 4/2014 WO Seat Covers 2/2014
    Their product is the best I can get, considering the only other internet provider is still stuck on 10mbps.

    But their customer service is terrible. Every time I have an issue, I have to dedicate at least 4 hours of my time to getting it resolved.

    2 days ago I was promo'd into a higher teir, and was told I would see changes by 24 hours and if not power cycle my system. So of course I did, and still no upgrade.

    Well I just wanted to figure out why I am not seeing results, currently on my 4th representative!!! The first one was so helpful, but during a powercycle we lost connection and that was it. :(

    The second one completely ignored me, told me that I was getting the correct speed, and then when I tried to correct him he shot me down and was a smart ass about it.
    I asked to speak to another representative that would treat me like a customer and not a number, so he tells me to disconnect and continue for another. Trying to do so, he resets my internet 3 times without my authorization or permission.

    My 3rd was a cake walk because all I asked for was a complaint department.

    Hoping this 4th rep can help me, my hopes are high, but out of the 4 she is the only one that bothered to verify me so cheers to that I guess.
     
  2. Mar 23, 2013 at 11:36 PM
    #2
    cmack

    cmack Impeach Chris4x4!

    Joined:
    Jun 7, 2009
    Member:
    #18119
    Messages:
    5,234
    Gender:
    Male
    sounds like everything is working how it should
     
  3. Mar 23, 2013 at 11:37 PM
    #3
    MGMTacolover55

    MGMTacolover55 Well-Known Member

    Joined:
    Jan 31, 2013
    Member:
    #96545
    Messages:
    3,884
    Gender:
    Male
    Orygun
    Vehicle:
    2013 MGM Taco TRD Off Road
    floor Mats
    I used to have Comcast and they sucked so I went to century link and I can't notice the difference
     
  4. Mar 23, 2013 at 11:37 PM
    #4
    Bennett707

    Bennett707 [OP] Yeti Hunter

    Joined:
    Apr 28, 2012
    Member:
    #77793
    Messages:
    10,540
    Gender:
    Male
    Oregon
    Vehicle:
    '04 V6 3.4 TRD
    Successful GB's: Bora Wheel Spacers 4/2014 WO Seat Covers 2/2014
    You mean paying for a upgrade and receiving the same old product is how it should be? :confused:
     
  5. Mar 23, 2013 at 11:39 PM
    #5
    MightyMouse-SCT

    MightyMouse-SCT Well-Known Member

    Joined:
    Oct 18, 2010
    Member:
    #44862
    Messages:
    15,500
    Gender:
    Male
    First Name:
    Gabriel
    O'SIDE CA
    Vehicle:
    MightyMouse-SCT - 2011 LT 4x4 Desert Runner
    Long Travel Total chaos kit, fox shocks, smp fab , dmz sua, glassworks, method wheels.
    I went back to 3 Mbps . I was at 20-25 but promotion expired . Nice to have I guess but I didn't use it for what it is . I notice no difference for what I do at 3mbps . My LTE is 30-60 Mbps all day if I want speed .
    I'm sure it says up to .....
     
  6. Mar 23, 2013 at 11:39 PM
    #6
    cmack

    cmack Impeach Chris4x4!

    Joined:
    Jun 7, 2009
    Member:
    #18119
    Messages:
    5,234
    Gender:
    Male
    seems liek the norm these days
     
  7. Mar 23, 2013 at 11:41 PM
    #7
    Bennett707

    Bennett707 [OP] Yeti Hunter

    Joined:
    Apr 28, 2012
    Member:
    #77793
    Messages:
    10,540
    Gender:
    Male
    Oregon
    Vehicle:
    '04 V6 3.4 TRD
    Successful GB's: Bora Wheel Spacers 4/2014 WO Seat Covers 2/2014
    They only offer the 10mbps out here unfortuantly, and the UL speed is not enough for me to stream my media like I do. :(

    must be a jeep thing.
     
  8. Mar 23, 2013 at 11:42 PM
    #8
    cmack

    cmack Impeach Chris4x4!

    Joined:
    Jun 7, 2009
    Member:
    #18119
    Messages:
    5,234
    Gender:
    Male
    you mean you don't like being ripped off?
     
  9. Mar 23, 2013 at 11:42 PM
    #9
    Bennett707

    Bennett707 [OP] Yeti Hunter

    Joined:
    Apr 28, 2012
    Member:
    #77793
    Messages:
    10,540
    Gender:
    Male
    Oregon
    Vehicle:
    '04 V6 3.4 TRD
    Successful GB's: Bora Wheel Spacers 4/2014 WO Seat Covers 2/2014
    Even if it says up to, when I am paying for a 20mbps connection and receiving 25mbps (thankfully) and I am now paying for a 50mbps connection and still receiving 25mbps, something is wrong.
     
  10. Mar 23, 2013 at 11:44 PM
    #10
    MGMTacolover55

    MGMTacolover55 Well-Known Member

    Joined:
    Jan 31, 2013
    Member:
    #96545
    Messages:
    3,884
    Gender:
    Male
    Orygun
    Vehicle:
    2013 MGM Taco TRD Off Road
    floor Mats
    Well you could go with a 4g uh internet connection or something like that
     
  11. Mar 23, 2013 at 11:45 PM
    #11
    Bennett707

    Bennett707 [OP] Yeti Hunter

    Joined:
    Apr 28, 2012
    Member:
    #77793
    Messages:
    10,540
    Gender:
    Male
    Oregon
    Vehicle:
    '04 V6 3.4 TRD
    Successful GB's: Bora Wheel Spacers 4/2014 WO Seat Covers 2/2014
    I know you like being fucked in the ass, but I don't.
     
  12. Mar 23, 2013 at 11:46 PM
    #12
    cmack

    cmack Impeach Chris4x4!

    Joined:
    Jun 7, 2009
    Member:
    #18119
    Messages:
    5,234
    Gender:
    Male
    whoa buddy, no need to get angry with me because you have shitty service providers..
     
  13. Mar 23, 2013 at 11:46 PM
    #13
    BMOC

    BMOC Well-Known Member

    Joined:
    Dec 18, 2010
    Member:
    #47873
    Messages:
    4,026
    Gender:
    Male
    First Name:
    Paden
    Phoenix, AZ
    yeah i haven't heard anything good about them. ever. i guess since they're the best available then they can get away with it.. lame.
     
  14. Mar 23, 2013 at 11:48 PM
    #14
    MightyMouse-SCT

    MightyMouse-SCT Well-Known Member

    Joined:
    Oct 18, 2010
    Member:
    #44862
    Messages:
    15,500
    Gender:
    Male
    First Name:
    Gabriel
    O'SIDE CA
    Vehicle:
    MightyMouse-SCT - 2011 LT 4x4 Desert Runner
    Long Travel Total chaos kit, fox shocks, smp fab , dmz sua, glassworks, method wheels.
    Nah nothing is wrong it varies . Is this a wifi connection ?
     
  15. Mar 23, 2013 at 11:48 PM
    #15
    Bennett707

    Bennett707 [OP] Yeti Hunter

    Joined:
    Apr 28, 2012
    Member:
    #77793
    Messages:
    10,540
    Gender:
    Male
    Oregon
    Vehicle:
    '04 V6 3.4 TRD
    Successful GB's: Bora Wheel Spacers 4/2014 WO Seat Covers 2/2014
    hardwire.
     
  16. Mar 23, 2013 at 11:50 PM
    #16
    MightyMouse-SCT

    MightyMouse-SCT Well-Known Member

    Joined:
    Oct 18, 2010
    Member:
    #44862
    Messages:
    15,500
    Gender:
    Male
    First Name:
    Gabriel
    O'SIDE CA
    Vehicle:
    MightyMouse-SCT - 2011 LT 4x4 Desert Runner
    Long Travel Total chaos kit, fox shocks, smp fab , dmz sua, glassworks, method wheels.
    Why do you want / need 50 Mbps ?
     
  17. Mar 23, 2013 at 11:51 PM
    #17
    Bennett707

    Bennett707 [OP] Yeti Hunter

    Joined:
    Apr 28, 2012
    Member:
    #77793
    Messages:
    10,540
    Gender:
    Male
    Oregon
    Vehicle:
    '04 V6 3.4 TRD
    Successful GB's: Bora Wheel Spacers 4/2014 WO Seat Covers 2/2014
    Promo to lower my bill, I don't need 50, but it will be very beneficial to my streaming.

    Apparently I have to wait til the 28th for my new speed to go into affect.. Jesus.
     
  18. Mar 23, 2013 at 11:57 PM
    #18
    MightyMouse-SCT

    MightyMouse-SCT Well-Known Member

    Joined:
    Oct 18, 2010
    Member:
    #44862
    Messages:
    15,500
    Gender:
    Male
    First Name:
    Gabriel
    O'SIDE CA
    Vehicle:
    MightyMouse-SCT - 2011 LT 4x4 Desert Runner
    Long Travel Total chaos kit, fox shocks, smp fab , dmz sua, glassworks, method wheels.
    Kk . I'm down to 3 Mbps and still don't have many issues streaming porn or YouTube . I don't watch movies though . Hopefully it works out for you .
     
  19. Mar 23, 2013 at 11:58 PM
    #19
    Bennett707

    Bennett707 [OP] Yeti Hunter

    Joined:
    Apr 28, 2012
    Member:
    #77793
    Messages:
    10,540
    Gender:
    Male
    Oregon
    Vehicle:
    '04 V6 3.4 TRD
    Successful GB's: Bora Wheel Spacers 4/2014 WO Seat Covers 2/2014
    You stream 10-100mb files... I stream 10-100GB files.
     
To Top