1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

i have a problem with my compass and temperature.

Discussion in '2nd Gen. Tacomas (2005-2015)' started by 06WHITETRD, Nov 2, 2008.

  1. Nov 2, 2008 at 10:39 AM
    #1
    06WHITETRD

    06WHITETRD [OP] Gotta Love my Taco!!!!

    Joined:
    Mar 31, 2008
    Member:
    #5630
    Messages:
    863
    Gender:
    Male
    So Cal
    Vehicle:
    06 Toyota Tacoma OFF-ROAD
    Tinted windows, window visors, XDI True Flow intake, White Devil Emblem, sport white grill, stubbie 6' antenna, TRD license plate frame,TRD Exhaust, weathertech floor front & rear, LED map/dome & license plate lights,Black Grille,T-Rex eyebrows,black Skid Plate,Lower bumper cover,Black emblems,white TRD Emblem,lamin-x yellow,Slotted & Cross Drilled rotors,Redline shocks(hood),HID 6k,more to come
    I got a 06 tacoma. I recently have notices that my compass and temperature isnt working. I press n press and nothing comes out. SHould I have it to the dealership with my warrantly or what should I do???
     
  2. Nov 2, 2008 at 10:49 AM
    #2
    mws4ua

    mws4ua I'll try being nicer if you try being smarter.

    Joined:
    May 14, 2008
    Member:
    #6624
    Messages:
    6,525
    Gender:
    Male
    First Name:
    Matt
    Birmingham
    Vehicle:
    Sold my truck Jan '13... Still hang around.
    If you're still under warranty let them deal with it. No reason to waste your own time/effort, especially if you (like me) don't know what you're getting in to.

    I have an '06 myself... I'm nowhere near the mileage limit, but my 'in-service date' was January 31, 2006, so the clock is ticking on my free repairs...
     
  3. Nov 2, 2008 at 12:46 PM
    #3
    06WHITETRD

    06WHITETRD [OP] Gotta Love my Taco!!!!

    Joined:
    Mar 31, 2008
    Member:
    #5630
    Messages:
    863
    Gender:
    Male
    So Cal
    Vehicle:
    06 Toyota Tacoma OFF-ROAD
    Tinted windows, window visors, XDI True Flow intake, White Devil Emblem, sport white grill, stubbie 6' antenna, TRD license plate frame,TRD Exhaust, weathertech floor front & rear, LED map/dome & license plate lights,Black Grille,T-Rex eyebrows,black Skid Plate,Lower bumper cover,Black emblems,white TRD Emblem,lamin-x yellow,Slotted & Cross Drilled rotors,Redline shocks(hood),HID 6k,more to come
    what about if my warranty expires lol.. im fuck huh.. any can help me..
     
  4. Nov 2, 2008 at 1:02 PM
    #4
    coppert

    coppert Mall Krawler

    Joined:
    Apr 12, 2007
    Member:
    #1300
    Messages:
    882
    Gender:
    Male
    First Name:
    Travis
    916
  5. Nov 2, 2008 at 1:06 PM
    #5
    06WHITETRD

    06WHITETRD [OP] Gotta Love my Taco!!!!

    Joined:
    Mar 31, 2008
    Member:
    #5630
    Messages:
    863
    Gender:
    Male
    So Cal
    Vehicle:
    06 Toyota Tacoma OFF-ROAD
    Tinted windows, window visors, XDI True Flow intake, White Devil Emblem, sport white grill, stubbie 6' antenna, TRD license plate frame,TRD Exhaust, weathertech floor front & rear, LED map/dome & license plate lights,Black Grille,T-Rex eyebrows,black Skid Plate,Lower bumper cover,Black emblems,white TRD Emblem,lamin-x yellow,Slotted & Cross Drilled rotors,Redline shocks(hood),HID 6k,more to come
    what thread.. get me the link...
     
  6. Nov 2, 2008 at 1:07 PM
    #6
    coppert

    coppert Mall Krawler

    Joined:
    Apr 12, 2007
    Member:
    #1300
    Messages:
    882
    Gender:
    Male
    First Name:
    Travis
    916
  7. Nov 2, 2008 at 1:31 PM
    #7
    BeefTaco

    BeefTaco WESTern Alliance: NORCAL COAST

    Joined:
    May 8, 2008
    Member:
    #6481
    Messages:
    631
    Gender:
    Male
    Santa Cruz County Ca.
    It is covered under Toyota's warranty for 3 years or 36,000 miles.
     
  8. Nov 9, 2008 at 5:31 PM
    #8
    06WHITETRD

    06WHITETRD [OP] Gotta Love my Taco!!!!

    Joined:
    Mar 31, 2008
    Member:
    #5630
    Messages:
    863
    Gender:
    Male
    So Cal
    Vehicle:
    06 Toyota Tacoma OFF-ROAD
    Tinted windows, window visors, XDI True Flow intake, White Devil Emblem, sport white grill, stubbie 6' antenna, TRD license plate frame,TRD Exhaust, weathertech floor front & rear, LED map/dome & license plate lights,Black Grille,T-Rex eyebrows,black Skid Plate,Lower bumper cover,Black emblems,white TRD Emblem,lamin-x yellow,Slotted & Cross Drilled rotors,Redline shocks(hood),HID 6k,more to come
    i just find out, that my warranty is done.. so what should i do now??
     
  9. Nov 9, 2008 at 5:34 PM
    #9
    eordonez

    eordonez Living vicariously through mjp2

    Joined:
    Mar 17, 2008
    Member:
    #5340
    Messages:
    8,363
    Gender:
    Male
    First Name:
    Ed
    Chihuahua, Mexico
    Vehicle:
    TRD Sport Dcab 4x2 Black Sand Pearl
    OEM All Weather Mats, wheel locks, Toyota Silver Tube steps.....
    mmm, why don't you have the problem diagnosed at the dealership, to see exactly what is wrong, than you can search for the replacement parts online, i don't think its a lot complicated to change the parts yourself....
     
  10. Nov 9, 2008 at 10:03 PM
    #10
    medic2230

    medic2230 Ditch Doctor

    Joined:
    Oct 13, 2008
    Member:
    #9942
    Messages:
    11,636
    Gender:
    Male
    First Name:
    Murph
    Columbus, Ga
    Vehicle:
    2011 Taco 4x4 DCLB
    20% Tint, OME 3"complete lift with Dakar's, Light Racing UCA's, 285/75/16 Nitto Terra Grapplers, 10 HP TW sticker, Ultraguage, B.A.M.F. Rock Sliders, MedicFab Bed Rack, Relentless front bumper
  11. Jan 21, 2009 at 8:59 AM
    #11
    06WHITETRD

    06WHITETRD [OP] Gotta Love my Taco!!!!

    Joined:
    Mar 31, 2008
    Member:
    #5630
    Messages:
    863
    Gender:
    Male
    So Cal
    Vehicle:
    06 Toyota Tacoma OFF-ROAD
    Tinted windows, window visors, XDI True Flow intake, White Devil Emblem, sport white grill, stubbie 6' antenna, TRD license plate frame,TRD Exhaust, weathertech floor front & rear, LED map/dome & license plate lights,Black Grille,T-Rex eyebrows,black Skid Plate,Lower bumper cover,Black emblems,white TRD Emblem,lamin-x yellow,Slotted & Cross Drilled rotors,Redline shocks(hood),HID 6k,more to come
    thanks. ima give this thread a try , this coming weekend. Hopefully it works.
     
  12. Jan 21, 2009 at 9:22 AM
    #12
    MyToyTaco

    MyToyTaco ╒╪╕

    Joined:
    Sep 23, 2008
    Member:
    #9417
    Messages:
    4,340
    Gender:
    Male
    First Name:
    Nick
    Port Hueneme
    Vehicle:
    08 Taco
  13. Jan 21, 2009 at 9:23 AM
    #13
    MyToyTaco

    MyToyTaco ╒╪╕

    Joined:
    Sep 23, 2008
    Member:
    #9417
    Messages:
    4,340
    Gender:
    Male
    First Name:
    Nick
    Port Hueneme
    Vehicle:
    08 Taco
    Or if you feel like driving to thousand oaks, i'll do it for you.. i think azuza is only like 45 minutes south right..?
     
  14. Jan 21, 2009 at 11:01 AM
    #14
    T@co_Pr3runn3r

    T@co_Pr3runn3r XXXXXXXXXXXXXXXXXXX

    Joined:
    Jan 20, 2009
    Member:
    #12767
    Messages:
    10,416
    Gender:
    Male
    <----------------->
    Vehicle:
    08 RC Prerunner SR5
    Got one of these in my car. Pretty simple, does it have pwr & a grnd? Is it getting signal from temp sensor? Have you done the calibrate the compass procedure? How is it not working? No lights or display at all? Crazy readings or what?
     
  15. Mar 14, 2009 at 9:10 AM
    #15
    06WHITETRD

    06WHITETRD [OP] Gotta Love my Taco!!!!

    Joined:
    Mar 31, 2008
    Member:
    #5630
    Messages:
    863
    Gender:
    Male
    So Cal
    Vehicle:
    06 Toyota Tacoma OFF-ROAD
    Tinted windows, window visors, XDI True Flow intake, White Devil Emblem, sport white grill, stubbie 6' antenna, TRD license plate frame,TRD Exhaust, weathertech floor front & rear, LED map/dome & license plate lights,Black Grille,T-Rex eyebrows,black Skid Plate,Lower bumper cover,Black emblems,white TRD Emblem,lamin-x yellow,Slotted & Cross Drilled rotors,Redline shocks(hood),HID 6k,more to come
    well, it doesnt show in the display or light from the inside of the truck. before it was working, then sometimes i would have to hit it so it can come out ( meanin to read the temp/ compass ) but not its looks that something is wrong.. ima do what the thread first.. if it doesnt work, i will ya know
     
  16. Nov 12, 2009 at 12:30 PM
    #16
    goofyfoot

    goofyfoot New Member

    Joined:
    Nov 11, 2009
    Member:
    #25810
    Messages:
    2
    Gender:
    Male
    First Name:
    Mike
    So-Calif
    Vehicle:
    05 Tacoma
    Bed lid; bed carpet kit
    What a great web site! Googgled Toyota compass and temperature. found this site and followed the directions for repairs. So simple even a cave man can do it! LOL! Didn't see any separation of solder but hit the resistors anyway and wala! Back to working!

    Many thanks!

    Mike '05 Tacoma
     
  17. Nov 12, 2009 at 3:07 PM
    #17
    victheyankee

    victheyankee Well-Known Member

    Joined:
    Nov 12, 2009
    Member:
    #25842
    Messages:
    47
    Gender:
    Male
    arizona
    upgraded sound system eclipse and alpine and mb wheels.
    I fixed mine for 9 dollars. I just bought the soldering iron and it worked. Thanks this site is great
     
  18. Nov 12, 2009 at 3:30 PM
    #18
    doakes

    doakes Well-Known Member

    Joined:
    Sep 10, 2009
    Member:
    #22541
    Messages:
    63
    Gender:
    Male
    This item costs $922-$1120. The solder job only takes a few minutes. Just follow the web site.
     
  19. Dec 14, 2009 at 7:17 AM
    #19
    sdv55ce

    sdv55ce New Member

    Joined:
    Dec 8, 2009
    Member:
    #27254
    Messages:
    2
    Gender:
    Male
    Knoxville, TN
    Vehicle:
    06 PreRunner SR5
    It takes about 20 minutes, a soldering gun and some .032 solder.

    1. Take out the screw where the sunglasses are stored.
    2. Pop the frot end out, a little tricky - leverage your knuckles against the overhead. The back is hooked on so it swings down from the front.
    3. Take off the 2 connections, use your fingernail to push down the clip that holds them in.
    4. Lay it out on a surface that won't scratch the finished surface and take out three tox screws on the back.
    5. Take of the displat cover - four snap in points - 2 on each side. You can use your finger nails to put back and coax each side out.
    6. Take a close look at the 510 transitors for cracking. Just solder them back and put it back in. Take a look at the 181 trans

    I followed the directions I got here, but can't find them again.

    14DEC09 - Tempearture Display.jpg
    14DEC09 - Temp Display Fix - Before.jpg
    14DEC09 - Temp Display Fix2 - After.jpg
     
  20. Dec 14, 2009 at 8:26 AM
    #20
    goofyfoot

    goofyfoot New Member

    Joined:
    Nov 11, 2009
    Member:
    #25810
    Messages:
    2
    Gender:
    Male
    First Name:
    Mike
    So-Calif
    Vehicle:
    05 Tacoma
    Bed lid; bed carpet kit
    Read below on this thread on how to fix this problem. I did it about a month ago. Very easy to do follwoing directions on the thread and it is still working.

    mike aka goofyfoot
     
To Top